summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-04-16 14:18:14 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-04-16 14:18:14 +0000
commit736c606ed8ecff085ee9c42190b94f5718290fea (patch)
tree4028920a8454aee8c076e00aa51f5bf3457cda09
parentVersion bump. Remove dev-python/python-distutils-extra dependency, fixes bug ... (diff)
downloadgentoo-2-736c606ed8ecff085ee9c42190b94f5718290fea.tar.gz
gentoo-2-736c606ed8ecff085ee9c42190b94f5718290fea.tar.bz2
gentoo-2-736c606ed8ecff085ee9c42190b94f5718290fea.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--dev-libs/liboil/ChangeLog9
-rw-r--r--dev-libs/liboil/liboil-0.3.17.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/dev-libs/liboil/ChangeLog b/dev-libs/liboil/ChangeLog
index 72394fe91eee..1ac9f3db4a27 100644
--- a/dev-libs/liboil/ChangeLog
+++ b/dev-libs/liboil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/liboil
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/liboil/ChangeLog,v 1.82 2009/11/13 00:41:54 josejx Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liboil/ChangeLog,v 1.83 2010/04/16 14:18:14 ssuominen Exp $
+
+*liboil-0.3.17 (16 Apr 2010)
+
+ 16 Apr 2010; Samuli Suominen <ssuominen@gentoo.org> +liboil-0.3.17.ebuild:
+ Version bump.
13 Nov 2009; Joseph Jezak <josejx@gentoo.org> liboil-0.3.16.ebuild:
Marked ppc64 stable.
diff --git a/dev-libs/liboil/liboil-0.3.17.ebuild b/dev-libs/liboil/liboil-0.3.17.ebuild
new file mode 100644
index 000000000000..21b66e01e016
--- /dev/null
+++ b/dev-libs/liboil/liboil-0.3.17.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liboil/liboil-0.3.17.ebuild,v 1.1 2010/04/16 14:18:14 ssuominen Exp $
+
+EAPI=2
+inherit flag-o-matic
+
+DESCRIPTION="library of simple functions that are optimized for various CPUs"
+HOMEPAGE="http://liboil.freedesktop.org/"
+SRC_URI="http://liboil.freedesktop.org/download/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0.3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +examples test"
+
+RDEPEND="examples? ( dev-libs/glib:2 )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+src_prepare() {
+ if ! use examples; then
+ sed "s/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die
+ fi
+
+ if ! use test; then
+ sed "s/^\(SUBDIRS =.*\)testsuite\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die
+ fi
+}
+
+src_configure() {
+ strip-flags
+ filter-flags -O?
+ append-flags -O2
+
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable doc gtk-doc) \
+ --with-html-dir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUG-REPORTING HACKING NEWS README || die
+}
+
+pkg_postinst() {
+ if ! use examples; then
+ ewarn "You have disabled examples USE flag. Beware that upstream might"
+ ewarn "want the output of some utilities that are only built with"
+ ewarn "USE='examples' if you report bugs to them."
+ fi
+}