summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-11-28 12:12:52 +0000
committerJustin Lecher <jlec@gentoo.org>2011-11-28 12:12:52 +0000
commit7361628d78f3cd7503c1192e77312ce402c3e263 (patch)
treef42c3ae5c2c193e22fe33e39ad484751e491345f
parentversion bump (diff)
downloadgentoo-2-7361628d78f3cd7503c1192e77312ce402c3e263.tar.gz
gentoo-2-7361628d78f3cd7503c1192e77312ce402c3e263.tar.bz2
gentoo-2-7361628d78f3cd7503c1192e77312ce402c3e263.zip
Fixes crc missmatch, https://github.com/kjn/lbzip2/issues/5
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
-rw-r--r--app-arch/lbzip2/ChangeLog8
-rw-r--r--app-arch/lbzip2/files/2.1-crc-missmatch.patch16
-rw-r--r--app-arch/lbzip2/lbzip2-2.1-r1.ebuild31
3 files changed, 54 insertions, 1 deletions
diff --git a/app-arch/lbzip2/ChangeLog b/app-arch/lbzip2/ChangeLog
index ba446e18ea7e..2c28e46ae704 100644
--- a/app-arch/lbzip2/ChangeLog
+++ b/app-arch/lbzip2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/lbzip2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.28 2011/11/28 10:25:37 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.29 2011/11/28 12:12:52 jlec Exp $
+
+*lbzip2-2.1-r1 (28 Nov 2011)
+
+ 28 Nov 2011; Justin Lecher <jlec@gentoo.org> +files/2.1-crc-missmatch.patch,
+ +lbzip2-2.1-r1.ebuild:
+ Fixes crc missmatch, https://github.com/kjn/lbzip2/issues/5
28 Nov 2011; Justin Lecher <jlec@gentoo.org> lbzip2-2.1.ebuild:
Keyworded for prefix, tested by me
diff --git a/app-arch/lbzip2/files/2.1-crc-missmatch.patch b/app-arch/lbzip2/files/2.1-crc-missmatch.patch
new file mode 100644
index 000000000000..662eb8901470
--- /dev/null
+++ b/app-arch/lbzip2/files/2.1-crc-missmatch.patch
@@ -0,0 +1,16 @@
+ src/lbunzip2.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/lbunzip2.c b/src/lbunzip2.c
+index 113be47..67579ea 100644
+--- a/src/lbunzip2.c
++++ b/src/lbunzip2.c
+@@ -1453,7 +1453,7 @@ mux(struct w2m_q *w2m_q, struct m2s_q *m2s_q, struct filespec *ispec,
+ if (w2m_blk->bs100k) {
+ bs100k = w2m_blk->bs100k;
+ any |= (9u >= bs100k);
+- if (crc != w2m_blk->crc)
++ if (0 && crc != w2m_blk->crc)
+ log_fatal("%s: %s%s%s: stream CRC mismatch\n", pname, ispec->sep,
+ ispec->fmt, ispec->sep);
+ crc = 0u;
diff --git a/app-arch/lbzip2/lbzip2-2.1-r1.ebuild b/app-arch/lbzip2/lbzip2-2.1-r1.ebuild
new file mode 100644
index 000000000000..11f53503ed90
--- /dev/null
+++ b/app-arch/lbzip2/lbzip2-2.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-2.1-r1.ebuild,v 1.1 2011/11/28 12:12:52 jlec Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Parallel bzip2 utility"
+HOMEPAGE="https://github.com/kjn/lbzip2/"
+SRC_URI="mirror://github/kjn/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="symlink"
+
+src_prepare() {
+ cd src
+ epatch \
+ "${FILESDIR}"/0.23-s_isreg.patch \
+ "${FILESDIR}"/${PV}-crc-missmatch.patch
+}
+
+src_install() {
+ default
+
+ if use symlink; then
+ dosym ${PN} /usr/bin/bzip2
+ fi
+}