summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-06-18 19:42:35 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-06-18 19:42:35 +0000
commit7339188462a810ae23057d489b8b8684eb73c425 (patch)
tree2215b5780cfdefe597f90406fe74cf61e0112738
parentBump patchset to fix bug #219444 (diff)
downloadgentoo-2-7339188462a810ae23057d489b8b8684eb73c425.tar.gz
gentoo-2-7339188462a810ae23057d489b8b8684eb73c425.tar.bz2
gentoo-2-7339188462a810ae23057d489b8b8684eb73c425.zip
Version bumped.
(Portage version: 2.1.5.6)
-rw-r--r--media-tv/channeleditor/ChangeLog10
-rw-r--r--media-tv/channeleditor/channeleditor-1.9.2.1.ebuild51
2 files changed, 59 insertions, 2 deletions
diff --git a/media-tv/channeleditor/ChangeLog b/media-tv/channeleditor/ChangeLog
index 599e26f2409f..fd5938fba7d1 100644
--- a/media-tv/channeleditor/ChangeLog
+++ b/media-tv/channeleditor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-tv/channeleditor
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/channeleditor/ChangeLog,v 1.1 2007/10/04 16:40:37 zzam Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/channeleditor/ChangeLog,v 1.2 2008/06/18 19:42:35 zzam Exp $
+
+*channeleditor-1.9.2.1 (18 Jun 2008)
+
+ 18 Jun 2008; Matthias Schwarzott <zzam@gentoo.org>
+ +channeleditor-1.9.2.1.ebuild:
+ Version bumped.
*channeleditor-1.9.2 (04 Oct 2007)
diff --git a/media-tv/channeleditor/channeleditor-1.9.2.1.ebuild b/media-tv/channeleditor/channeleditor-1.9.2.1.ebuild
new file mode 100644
index 000000000000..44ee3ba22412
--- /dev/null
+++ b/media-tv/channeleditor/channeleditor-1.9.2.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/channeleditor/channeleditor-1.9.2.1.ebuild,v 1.1 2008/06/18 19:42:35 zzam Exp $
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Editor for VDR channels.conf"
+HOMEPAGE="http://renier.re.funpic.de/"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}_src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/${PN}"
+
+mainclass() {
+ # read Main-Class from MANIFEST.MF
+ sed -n "s/^Main-Class: \([^ ]\+\).*/\1/p" "${S}/MANIFEST.MF"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # move files out of build and remove stuff not needed in the package
+ mv build/* "${S}"
+ rm -f src/java/org/javalobby/icons/{README,COPYRIGHT}
+
+ # copy build.xml
+ cp -f "${FILESDIR}/build.xml" build.xml
+
+ # convert CRLF to LF
+ edos2unix MANIFEST.MF
+}
+
+src_compile() {
+ eant build -Dmanifest.mainclass=$(mainclass)
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ java-pkg_dolauncher ${PN} --main $(mainclass)
+
+ make_desktop_entry channeleditor Channeleditor "" "Utility" || \
+ die "Couldn't make desktop entry"
+}