summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-06-28 09:32:47 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-06-28 09:32:47 +0000
commit72174a6b04327a484b9fcbbcccb4f4f8386f6fe2 (patch)
tree597fda3dbba4b0545e8d210b5ff5004ca3629b7c
parentRemove old (diff)
downloadgentoo-2-72174a6b04327a484b9fcbbcccb4f4f8386f6fe2.tar.gz
gentoo-2-72174a6b04327a484b9fcbbcccb4f4f8386f6fe2.tar.bz2
gentoo-2-72174a6b04327a484b9fcbbcccb4f4f8386f6fe2.zip
Bump to 0.9.9.8.2, fixes #275242
(Portage version: 2.2_rc33/cvs/Linux x86_64)
-rw-r--r--app-misc/anki/ChangeLog7
-rw-r--r--app-misc/anki/anki-0.9.9.8.2.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/app-misc/anki/ChangeLog b/app-misc/anki/ChangeLog
index 69ed1996a89f..d1a2ea1ef04d 100644
--- a/app-misc/anki/ChangeLog
+++ b/app-misc/anki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/anki
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.15 2009/06/09 22:09:50 hncaldwell Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.16 2009/06/28 09:32:47 patrick Exp $
+
+*anki-0.9.9.8.2 (28 Jun 2009)
+
+ 28 Jun 2009; Patrick Lauer <patrick@gentoo.org> +anki-0.9.9.8.2.ebuild:
+ Bump to 0.9.9.8.2, fixes #275242
09 Jun 2009; Heath Caldwell <hncaldwell@gentoo.org>
-anki-0.9.9.7.6b.ebuild, -anki-0.9.9.7.9.ebuild:
diff --git a/app-misc/anki/anki-0.9.9.8.2.ebuild b/app-misc/anki/anki-0.9.9.8.2.ebuild
new file mode 100644
index 000000000000..98cc7d4bde66
--- /dev/null
+++ b/app-misc/anki/anki-0.9.9.8.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/anki-0.9.9.8.2.ebuild,v 1.1 2009/06/28 09:32:47 patrick Exp $
+
+EAPI=2
+
+inherit eutils multilib python
+
+DESCRIPTION="A spaced-repetition memory training program (flash cards)"
+HOMEPAGE="http://ichi2.net/anki/"
+SRC_URI="http://ichi2.net/${PN}/download/files/${P}.tgz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="furigana +graph latex recording +sound"
+
+DEPEND="dev-lang/python
+ dev-python/setuptools"
+RDEPEND=">=dev-python/PyQt4-4.4[X,svg,webkit]
+ >=dev-python/sqlalchemy-0.4.3
+ >=dev-python/simplejson-1.7.3
+ || ( >=dev-python/pysqlite-2.3.0 >=dev-lang/python-2.5[sqlite] )
+ latex? ( app-text/dvipng )
+ furigana? ( app-i18n/kakasi )
+ graph? (
+ dev-python/numpy
+ >=dev-python/matplotlib-0.91.2
+ )
+ recording? (
+ media-sound/sox
+ dev-python/pyaudio
+ media-sound/lame
+ )
+ sound? ( media-video/mplayer )"
+
+src_install() {
+ doicon icons/${PN}.png || die
+
+ cd libanki
+ python setup.py install --root="${D}" || die
+ cd ..
+ python setup.py install --root="${D}" || die
+
+ make_desktop_entry ${PN} ${PN} ${PN}.png "Education"
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/ankiqt
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/anki
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages/ankiqt
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages/anki
+}