summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-12-19 15:26:01 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-12-19 15:26:01 +0000
commit711c9f89f3364e417cc1a7853d3dba49cb0d213a (patch)
treef1be302ee7353f416f072f7aaa3ea161c18b9575
parentVersion bump and old versions cleanup (diff)
downloadgentoo-2-711c9f89f3364e417cc1a7853d3dba49cb0d213a.tar.gz
gentoo-2-711c9f89f3364e417cc1a7853d3dba49cb0d213a.tar.bz2
gentoo-2-711c9f89f3364e417cc1a7853d3dba49cb0d213a.zip
version bump
(Portage version: 2.1.3.16)
-rw-r--r--dev-java/qtjambi/ChangeLog8
-rw-r--r--dev-java/qtjambi/files/digest-qtjambi-4.3.3_p13
-rw-r--r--dev-java/qtjambi/files/generator-4.3.3.patch10
-rw-r--r--dev-java/qtjambi/qtjambi-4.3.3_p1.ebuild106
4 files changed, 126 insertions, 1 deletions
diff --git a/dev-java/qtjambi/ChangeLog b/dev-java/qtjambi/ChangeLog
index 268789211144..dfce0cc49ea8 100644
--- a/dev-java/qtjambi/ChangeLog
+++ b/dev-java/qtjambi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/qtjambi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/qtjambi/ChangeLog,v 1.10 2007/11/23 21:08:46 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/qtjambi/ChangeLog,v 1.11 2007/12/19 15:26:00 caleb Exp $
+
+*qtjambi-4.3.3_p1 (19 Dec 2007)
+
+ 19 Dec 2007; Caleb Tennis <caleb@gentoo.org> +files/generator-4.3.3.patch,
+ +qtjambi-4.3.3_p1.ebuild:
+ version bump
23 Nov 2007; Samuli Suominen <drac@gentoo.org> qtjambi-4.3.2_p1.ebuild:
Keyword ~amd64 wrt #197763.
diff --git a/dev-java/qtjambi/files/digest-qtjambi-4.3.3_p1 b/dev-java/qtjambi/files/digest-qtjambi-4.3.3_p1
new file mode 100644
index 000000000000..679f1a3b0b86
--- /dev/null
+++ b/dev-java/qtjambi/files/digest-qtjambi-4.3.3_p1
@@ -0,0 +1,3 @@
+MD5 ef6a2afceaa706adf1127369c87263c1 qtjambi-gpl-src-4.3.3_01.tar.gz 3797578
+RMD160 b94d3102035d8e6fa51188e4bcf5e4149ab2fbc8 qtjambi-gpl-src-4.3.3_01.tar.gz 3797578
+SHA256 ada8f18f91b28079c7743fb3687571113a6682485855672340c8d82923348182 qtjambi-gpl-src-4.3.3_01.tar.gz 3797578
diff --git a/dev-java/qtjambi/files/generator-4.3.3.patch b/dev-java/qtjambi/files/generator-4.3.3.patch
new file mode 100644
index 000000000000..2557b0bc0e3d
--- /dev/null
+++ b/dev-java/qtjambi/files/generator-4.3.3.patch
@@ -0,0 +1,10 @@
+--- generator/main.h.orig 2007-10-23 08:03:37.000000000 -0400
++++ generator/main.h 2007-10-23 08:03:42.000000000 -0400
+@@ -74,7 +74,6 @@
+ if (qtdir.isEmpty()) {
+ qWarning("QTDIR environment variable not set. This may cause problems with finding the necessary include files.");
+ } else {
+- qtdir += "/include";
+ includes << (qtdir + "/QtXml");
+ includes << (qtdir + "/QtNetwork");
+ includes << (qtdir + "/QtCore");
diff --git a/dev-java/qtjambi/qtjambi-4.3.3_p1.ebuild b/dev-java/qtjambi/qtjambi-4.3.3_p1.ebuild
new file mode 100644
index 000000000000..5bd960b4ad06
--- /dev/null
+++ b/dev-java/qtjambi/qtjambi-4.3.3_p1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/qtjambi/qtjambi-4.3.3_p1.ebuild,v 1.1 2007/12/19 15:26:00 caleb Exp $
+
+inherit eutils java-pkg-2
+
+QTVERSION=4.3.3
+PATCHRELEASE=01
+
+DESCRIPTION="QtJambi is a set of Java bindings and utilities for the Qt C++ toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+MY_PV=${QTVERSION}_${PATCHRELEASE}
+
+SRC_URI="ftp://ftp.trolltech.com/pub/qtjambi/source/qtjambi-gpl-src-${MY_PV}.tar.gz"
+S=${WORKDIR}/qtjambi-gpl-src-${MY_PV}
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND="~x11-libs/qt-${QTVERSION}
+ >=virtual/jdk-1.5"
+
+RDEPEND="~x11-libs/qt-${QTVERSION}
+ >=virtual/jre-1.5"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch ${FILESDIR}/generator-4.3.3.patch
+ epatch ${FILESDIR}/qtjambi_base.pri.diff
+ epatch ${FILESDIR}/jambi.pri.diff
+
+ # If Qt wasn't built with accessibility use flag, then we needto remove some files from
+ # the list.
+ if ! built_with_use =x11-libs/qt-4* accessibility; then
+ epatch ${FILESDIR}/java_files_remove_accessibility.diff
+ fi
+ if ! built_with_use =x11-libs/qt-4* ssl; then
+ epatch ${FILESDIR}/java_files_remove_ssl.diff
+ fi
+}
+
+src_compile() {
+
+ # Step 1, build the source generator
+ einfo "Building the source generator"
+ cd ${S}/generator
+ /usr/bin/qmake && make || die "Error building generator"
+
+ # Step 2, run the generator
+ einfo "Running the generator. This may take a few minutes."
+ QTDIR=/usr/include/qt4 ./generator
+
+ # Step 3, build the generated sources
+ export JAVADIR=$JDK_HOME
+ einfo "Building the generated sources."
+ cd "${S}" && /usr/bin/qmake && make || die "Error building generated sources"
+
+ # Step 4, generate Ui_.java files
+ einfo "Running juic"
+ cd "${S}" && ./bin/juic -cp .
+
+ # Step 5, compiling java files
+ einfo "Compiling java files"
+ mkdir -p ${S}/class
+ cd "${S}" && ejavac -d class @java_files
+
+ # Step 6, build the jar file
+ cd ${S}/class && jar cf ../qtjambi.jar com/trolltech/qt com/trolltech/tools
+ # copy built classes for demos and examples
+ cd "${S}/class" && cp -r com/trolltech/demos com/trolltech/examples com/trolltech/launcher ../com/trolltech
+ cd "${S}" && jar cf qtjambi-src.jar com
+
+ # generate start scripts
+ jcp="/usr/share/qtjambi-4/lib"
+ cd "${S}" && echo "#!/bin/sh" > bin/jambi-designer
+ cd "${S}" && echo "LD_LIBRARY_PATH=/usr/lib/qt4 CLASSPATH=${jcp}/qtjambi.jar:${jcp}/qtjambi-src.jar:$CLASSPATH /usr/bin/designer" >> bin/jambi-designer
+
+ cd "${S}" && echo "#!/bin/sh" > bin/jambi
+ cd "${S}" && echo "LD_LIBRARY_PATH=/usr/lib/qt4 java -cp ${jcp}/qtjambi.jar:${jcp}/qtjambi-src.jar com.trolltech.launcher.Launcher" >> bin/jambi
+}
+
+src_install() {
+ # Install built jar
+ java-pkg_dojar qtjambi.jar
+ java-pkg_dojar qtjambi-src.jar
+
+ # Install designer plugins
+ insinto "/usr/$(get_libdir)/qt4/plugins/designer"
+ insopts -m0755
+ doins plugins/designer/*.so
+
+ cp -dpPR "${S}"/lib/* "${D}/usr/$(get_libdir)/qt4"
+
+ # Install binaries
+ dobin bin/*
+
+ einfo "eclipse - Project->Properties->Java Build Path->Libraries:"
+ einfo "library: /usr/share/qtjambi-4/lib/qtjambi.jar"
+ einfo "source (& demos): /usr/share/qtjambi-4/lib/qtjambi-src.jar"
+ einfo "native library location: /usr/$(get_libdir)/qt4/"
+}