summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-08-18 05:54:49 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-08-18 05:54:49 +0000
commit706f25cb64ae0ac81f921480c3b27afa5559b94c (patch)
treeebf6025208b8e486752b99371d9c5732343835dc
parentVersion bump. Remove old. Now does not need X display for testing anymore (diff)
downloadgentoo-2-706f25cb64ae0ac81f921480c3b27afa5559b94c.tar.gz
gentoo-2-706f25cb64ae0ac81f921480c3b27afa5559b94c.tar.bz2
gentoo-2-706f25cb64ae0ac81f921480c3b27afa5559b94c.zip
Bump to 3.0.2, from gnome overlay for GNOME 3, keywords dropped: bug 379649
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
-rw-r--r--media-video/cheese/ChangeLog8
-rw-r--r--media-video/cheese/cheese-3.0.2.ebuild71
-rw-r--r--media-video/cheese/metadata.xml14
3 files changed, 87 insertions, 6 deletions
diff --git a/media-video/cheese/ChangeLog b/media-video/cheese/ChangeLog
index fe26629389c4..08c58d595316 100644
--- a/media-video/cheese/ChangeLog
+++ b/media-video/cheese/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/cheese
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cheese/ChangeLog,v 1.48 2011/06/09 01:28:06 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cheese/ChangeLog,v 1.49 2011/08/18 05:54:49 nirbheek Exp $
+
+*cheese-3.0.2 (18 Aug 2011)
+
+ 18 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +cheese-3.0.2.ebuild,
+ metadata.xml:
+ Bump to 3.0.2, from gnome overlay for GNOME 3, keywords dropped: bug 379649
09 Jun 2011; Sebastian Pipping <sping@gentoo.org> cheese-2.32.0.ebuild:
Add >=sys-fs/udev-171[gudev] as an alternative dependency to
diff --git a/media-video/cheese/cheese-3.0.2.ebuild b/media-video/cheese/cheese-3.0.2.ebuild
new file mode 100644
index 000000000000..d381511bd0a5
--- /dev/null
+++ b/media-video/cheese/cheese-3.0.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cheese/cheese-3.0.2.ebuild,v 1.1 2011/08/18 05:54:49 nirbheek Exp $
+
+EAPI="4"
+GNOME2_LA_PUNT="yes"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
+HOMEPAGE="http://www.gnome.org/projects/cheese/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc +introspection"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.28.0:2
+ >=dev-libs/libgee-0.6.0
+ >=x11-libs/gtk+-2.99.4:3[introspection?]
+ >=x11-libs/cairo-1.10
+ >=x11-libs/pango-1.28.0
+ || ( >=sys-fs/udev-171[gudev] >=sys-fs/udev-145-r1[extras] )
+ >=gnome-base/gnome-desktop-2.91.6:3
+ >=gnome-base/librsvg-2.32.0:2
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=media-libs/clutter-1.6.1:1.0[introspection?]
+ >=media-libs/clutter-gtk-0.91.8:1.0
+ >=media-libs/clutter-gst-1.0.0:1.0
+
+ media-video/gnome-video-effects
+ x11-libs/gdk-pixbuf:2[jpeg,introspection?]
+ x11-libs/mx
+ x11-libs/libX11
+ x11-libs/libXtst
+
+ >=media-libs/gstreamer-0.10.32:0.10[introspection?]
+ >=media-libs/gst-plugins-base-0.10.32:0.10[introspection?]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
+RDEPEND="${COMMON_DEPEND}
+ >=media-libs/gst-plugins-bad-0.10.19
+ >=media-libs/gst-plugins-good-0.10.16
+ >=media-plugins/gst-plugins-ogg-0.10.20
+ >=media-plugins/gst-plugins-pango-0.10.20
+ >=media-plugins/gst-plugins-theora-0.10.20
+ >=media-plugins/gst-plugins-v4l2-0.10
+ >=media-plugins/gst-plugins-vorbis-0.10.20
+ || ( >=media-plugins/gst-plugins-x-0.10
+ >=media-plugins/gst-plugins-xvideo-0.10 )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-lang/vala-0.11.6:0.12
+ >=app-text/gnome-doc-utils-0.20
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ dev-util/pkgconfig
+ x11-proto/xf86vidmodeproto
+ app-text/docbook-xml-dtd:4.3
+ doc? ( >=dev-util/gtk-doc-1.14 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ VALAC=$(type -p valac-0.12)
+ $(use_enable introspection)
+ --disable-maintainer-mode
+ --disable-scrollkeeper
+ --disable-static"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
diff --git a/media-video/cheese/metadata.xml b/media-video/cheese/metadata.xml
index 13e2a7036daf..94b87f296470 100644
--- a/media-video/cheese/metadata.xml
+++ b/media-video/cheese/metadata.xml
@@ -1,10 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>gnome</herd>
-<longdescription lang="en">
-Cheese uses your webcam to take photos and videos, applies fancy special effects
-and lets you share the fun with others.
-</longdescription>
+ <herd>gnome</herd>
+ <longdescription lang="en">
+ Cheese uses your webcam to take photos and videos, applies fancy special
+ effects, and lets you share the fun with others.
+ </longdescription>
+ <use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
+ </use>
</pkgmetadata>