summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-08-06 10:21:02 +0000
committerJustin Lecher <jlec@gentoo.org>2010-08-06 10:21:02 +0000
commit702cf2821467ee7049ba586947c5afa051ee883a (patch)
tree5806317eb5e340300939b33447e47815c9ba0661
parentversion bump (diff)
downloadgentoo-2-702cf2821467ee7049ba586947c5afa051ee883a.tar.gz
gentoo-2-702cf2821467ee7049ba586947c5afa051ee883a.tar.bz2
gentoo-2-702cf2821467ee7049ba586947c5afa051ee883a.zip
Version Bump, 322923
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--app-office/scribus/ChangeLog7
-rw-r--r--app-office/scribus/scribus-1.3.8.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/app-office/scribus/ChangeLog b/app-office/scribus/ChangeLog
index b75f1ba7f99e..97bab95c0d2f 100644
--- a/app-office/scribus/ChangeLog
+++ b/app-office/scribus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/scribus
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.134 2010/07/04 13:21:11 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.135 2010/08/06 10:21:02 jlec Exp $
+
+*scribus-1.3.8 (06 Aug 2010)
+
+ 06 Aug 2010; Justin Lecher <jlec@gentoo.org> +scribus-1.3.8.ebuild:
+ Version Bump, 322923
04 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> scribus-1.3.6.ebuild:
ppc64 stable wrt #316177
diff --git a/app-office/scribus/scribus-1.3.8.ebuild b/app-office/scribus/scribus-1.3.8.ebuild
new file mode 100644
index 000000000000..c6dffe9ede33
--- /dev/null
+++ b/app-office/scribus/scribus-1.3.8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/scribus-1.3.8.ebuild,v 1.1 2010/08/06 10:21:02 jlec Exp $
+
+EAPI=2
+PYTHON_DEPEND="2:2.6"
+
+inherit cmake-utils fdo-mime multilib python
+
+DESCRIPTION="Desktop publishing (DTP) and layout program"
+HOMEPAGE="http://www.scribus.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cairo debug +minimal +pdf spell"
+
+COMMON_DEPEND="
+ dev-libs/hyphen
+ dev-libs/libxml2
+ media-libs/fontconfig
+ >=media-libs/freetype-2
+ >=media-libs/jpeg-8a
+ =media-libs/lcms-1*
+ media-libs/libpng
+ media-libs/tiff
+ net-print/cups
+ sys-libs/zlib
+ x11-libs/qt-gui:4
+ spell? ( app-text/aspell )
+ pdf? ( app-text/podofo )
+ cairo? ( x11-libs/cairo[X,svg] )"
+RDEPEND="${COMMON_DEPEND}
+ app-text/ghostscript-gpl"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.5.1-system-hyphen.patch"
+ )
+
+DOCS="AUTHORS ChangeLog* LINKS NEWS README TODO TRANSLATION"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ mycmakeargs=(
+ "-DHAVE_PYTHON=ON"
+ "-DPYTHON_INCLUDE_PATH=$(python_get_includedir)"
+ "-DPYTHON_LIBRARY=$(python_get_library)"
+ "-DWANT_NORPATH=ON"
+ "-DWANT_QTARTHUR=ON"
+ "-DWANT_QT3SUPPORT=OFF"
+ $(cmake-utils_use_has spell ASPELL)
+ $(cmake-utils_use_has pdf PODOFO)
+ $(cmake-utils_use_want cairo)
+ $(cmake-utils_use_want minimal NOHEADERINSTALL)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ doicon resources/icons/scribus.png
+ domenu scribus.desktop
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}