summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-11-13 14:11:30 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-11-13 14:11:30 +0000
commit6fc2c1bf122ac4a011ebcd917c67d618b5db00a9 (patch)
tree476f7c343dadf6cb6f62f6c33024a62e803b0476
parentGnome2 stuff was finally removed (#508854) (diff)
downloadgentoo-2-6fc2c1bf122ac4a011ebcd917c67d618b5db00a9.tar.gz
gentoo-2-6fc2c1bf122ac4a011ebcd917c67d618b5db00a9.tar.bz2
gentoo-2-6fc2c1bf122ac4a011ebcd917c67d618b5db00a9.zip
Version bump and use Debian patchset, fixing QA warnings and bug #515914
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
-rw-r--r--x11-plugins/wmcoincoin/ChangeLog8
-rw-r--r--x11-plugins/wmcoincoin/wmcoincoin-2.6.2_p20140602.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-plugins/wmcoincoin/ChangeLog b/x11-plugins/wmcoincoin/ChangeLog
index 8281588fa601..6c6b15e6dc73 100644
--- a/x11-plugins/wmcoincoin/ChangeLog
+++ b/x11-plugins/wmcoincoin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmcoincoin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcoincoin/ChangeLog,v 1.28 2014/08/10 20:05:40 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcoincoin/ChangeLog,v 1.29 2014/11/13 14:11:30 voyageur Exp $
+
+*wmcoincoin-2.6.2_p20140602 (13 Nov 2014)
+
+ 13 Nov 2014; Bernard Cafarelli <voyageur@gentoo.org>
+ +wmcoincoin-2.6.2_p20140602.ebuild:
+ Version bump and use Debian patchset, fixing QA warnings and bug #515914
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> wmcoincoin-2.5.1f.ebuild,
wmcoincoin-2.6.1.ebuild:
diff --git a/x11-plugins/wmcoincoin/wmcoincoin-2.6.2_p20140602.ebuild b/x11-plugins/wmcoincoin/wmcoincoin-2.6.2_p20140602.ebuild
new file mode 100644
index 000000000000..e4a94217011b
--- /dev/null
+++ b/x11-plugins/wmcoincoin/wmcoincoin-2.6.2_p20140602.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcoincoin/wmcoincoin-2.6.2_p20140602.ebuild,v 1.1 2014/11/13 14:11:30 voyageur Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="a dockapp for browsing dacode news and board sites"
+HOMEPAGE="http://hules.free.fr/wmcoincoin"
+# Grab matching tag and Debian patches
+SRC_URI="https://github.com/d-torrance/${PN}/archive/debian/${PV/_p/+}-1.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls xinerama"
+
+RDEPEND="x11-libs/gtk+:2
+ media-libs/imlib2
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libX11
+ x11-libs/libXft
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-libs/libXt
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-proto/xineramaproto )"
+
+S=${WORKDIR}/${PN}-debian-${PV/_p/-}-1
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ EPATCH_SOURCE="${S}/debian/patches" EPATCH_SUFFIX=patch EPATCH_FORCE=yes epatch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable xinerama)
+}