summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-03-20 07:24:34 +0000
committerJoshua Brindle <method@gentoo.org>2003-03-20 07:24:34 +0000
commit6f09ec80b7ba6ae70ded84d13e9177f3e399343c (patch)
tree9e2ed7f3a74791a902774192bc22214e6f7579c1
parentnew, improved selinux-small, now slices, dices and labels your filesystem (diff)
downloadgentoo-2-6f09ec80b7ba6ae70ded84d13e9177f3e399343c.tar.gz
gentoo-2-6f09ec80b7ba6ae70ded84d13e9177f3e399343c.tar.bz2
gentoo-2-6f09ec80b7ba6ae70ded84d13e9177f3e399343c.zip
revision to add selinux support
-rw-r--r--sys-apps/coreutils/ChangeLog8
-rw-r--r--sys-apps/coreutils/coreutils-4.5.10-r1.ebuild93
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-4.5.10-r12
3 files changed, 102 insertions, 1 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 16ef1937cf68..2ae85019fbae 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/coreutils
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.8 2003/03/17 20:00:39 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.9 2003/03/20 07:24:34 method Exp $
+
+*coreutils-4.5.10-r1 (20 Mar 2003)
+
+ 20 Mar 2003; Joshua Brindle <method@gentoo.org> coreutils-4.5.10-r1.ebuild:
+ Revision bump to add selinux support
+ Thanks to sindian
*coreutils-4.5.10 (14 Mar 2003)
diff --git a/sys-apps/coreutils/coreutils-4.5.10-r1.ebuild b/sys-apps/coreutils/coreutils-4.5.10-r1.ebuild
new file mode 100644
index 000000000000..db68fd614f92
--- /dev/null
+++ b/sys-apps/coreutils/coreutils-4.5.10-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-4.5.10-r1.ebuild,v 1.1 2003/03/20 07:24:34 method Exp $
+
+inherit eutils
+
+IUSE="nls build selinux"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
+HOMEPAGE="http://www.gnu.org/software/coreutils/"
+SRC_URI="ftp://alpha.gnu.org/gnu/coreutils/${P}.tar.bz2"
+use selinux && SRC_URI="${SRC_URI} http://www.ibiblio.org/gentoo/distfiles/coreutils-4.5.10.diff"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa arm"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use selinux && epatch ${DISTDIR}/coreutils-4.5.10.diff
+
+ # patch to remove Stallman's su/wheel group rant (which doesn't apply,
+ # since Gentoo's su is not GNU/su, but that from shadow.
+ epatch ${FILESDIR}/${P}-gentoo-rms.diff
+
+ # Patch to add processor specific info to the uname output
+ if [ -z "`use hppa`" ] && [ -z "`use arm`" ]
+ then
+ epatch ${FILESDIR}/${P}-gentoo-uname.diff
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ use nls || myconf="--disable-nls"
+
+ econf \
+ --bindir=/bin \
+ ${myconf} || die
+
+ if [ "`use static`" ]
+ then
+ emake LDFLAGS=-static || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ einstall \
+ bindir=${D}/bin || die
+
+ # hostname comes from net-base
+ # hostname does not work with the -f switch, which breaks gnome2
+ # amongst other things
+ rm -f ${D}/{bin,usr/bin}/hostname ${D}/usr/share/man/man1/hostname.*
+
+ # /bin/su comes from sys-apps/shadow
+ rm -f ${D}/{bin,usr/bin}/su ${D}/usr/share/man/man1/su.*
+
+ # /usr/bin/uptime comes from the sys-apps/procps packaga
+ rm -f ${D}/{bin,usr/bin}/uptime ${D}/usr/share/man/man1/uptime*
+
+ cd ${D}
+ dodir /usr/bin
+ rm -rf usr/lib
+ cd usr/bin
+ ln -s ../../bin/* .
+
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ dodoc AUTHORS ChangeLog* COPYING NEWS README* THANKS TODO
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+
+pkg_postinst() {
+ # hostname does not get removed as it is included with older stage1
+ # tarballs, and net-tools installs to /bin
+ if [ -e ${ROOT}/usr/bin/hostname ] && [ ! -L ${ROOT}/usr/bin/hostname ]
+ then
+ rm -f ${ROOT}/usr/bin/hostname
+ fi
+}
diff --git a/sys-apps/coreutils/files/digest-coreutils-4.5.10-r1 b/sys-apps/coreutils/files/digest-coreutils-4.5.10-r1
new file mode 100644
index 000000000000..a5544619aba6
--- /dev/null
+++ b/sys-apps/coreutils/files/digest-coreutils-4.5.10-r1
@@ -0,0 +1,2 @@
+MD5 073aa616506e2eede6c199fa9c759ae2 coreutils-4.5.10.tar.bz2 3981173
+MD5 6eac7f5d3247cfbef16078a455e4a946 coreutils-4.5.10.diff 199100