summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-09 04:51:34 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-09 04:51:34 +0000
commit6e9c2bb9e6f81e17e2c466c02996abe1fb29603c (patch)
tree76de6fe8402a0b214cacb25d92392d1fdf1ae005
parent*** empty log message *** (diff)
downloadgentoo-2-6e9c2bb9e6f81e17e2c466c02996abe1fb29603c.tar.gz
gentoo-2-6e9c2bb9e6f81e17e2c466c02996abe1fb29603c.tar.bz2
gentoo-2-6e9c2bb9e6f81e17e2c466c02996abe1fb29603c.zip
*** empty log message ***
-rw-r--r--app-office/mrproject/files/digest-mrproject-0.2.11
-rw-r--r--app-office/mrproject/mrproject-0.2.1.ebuild40
-rw-r--r--gnome-extra/guppi/files/digest-guppi-0.35.51
-rw-r--r--gnome-extra/guppi/guppi-0.35.5.ebuild62
-rw-r--r--gnome-office/guppi/files/digest-guppi-0.35.51
-rw-r--r--gnome-office/guppi/guppi-0.35.5.ebuild62
-rw-r--r--gnome-office/mrproject/files/digest-mrproject-0.2.11
-rw-r--r--gnome-office/mrproject/mrproject-0.2.1.ebuild40
8 files changed, 208 insertions, 0 deletions
diff --git a/app-office/mrproject/files/digest-mrproject-0.2.1 b/app-office/mrproject/files/digest-mrproject-0.2.1
new file mode 100644
index 000000000000..ef6ed1aa0c13
--- /dev/null
+++ b/app-office/mrproject/files/digest-mrproject-0.2.1
@@ -0,0 +1 @@
+MD5 a107d28896def190280964ba1d29b25e mrproject-0.2.1.tar.gz
diff --git a/app-office/mrproject/mrproject-0.2.1.ebuild b/app-office/mrproject/mrproject-0.2.1.ebuild
new file mode 100644
index 000000000000..4e0602a62b00
--- /dev/null
+++ b/app-office/mrproject/mrproject-0.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mikael Hallendal <micke@hallendal.net>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Project management application for GNOME"
+SRC_URI="ftp://ftp.codefactory.se/pub/software/mrproject/source/${A}"
+HOMEPAGE="http://mrproject.codefactory.se/"
+
+DEPEND="nls? ( sys-devel/gettext )
+ >=gnome-base/gal-0.7
+ >=gnome-base/bonobo-1.0.0
+ >=dev-util/xml-i18n-tools-0.8.4"
+
+RDEPEND=">=gnome-base/gal-0.7
+ >=gnome-base/bonobo-1.0.0"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --sysconfdir=/etc/opt/gnome --disable-more-warnings $myconf
+ try make ${MAKEOPTS}
+
+}
+
+src_install () {
+
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO
+
+}
+
+
+
+
+
diff --git a/gnome-extra/guppi/files/digest-guppi-0.35.5 b/gnome-extra/guppi/files/digest-guppi-0.35.5
new file mode 100644
index 000000000000..8006822e0ff9
--- /dev/null
+++ b/gnome-extra/guppi/files/digest-guppi-0.35.5
@@ -0,0 +1 @@
+MD5 93ba14b9334e3838466446614149e2b4 Guppi-0.35.5.tar.gz
diff --git a/gnome-extra/guppi/guppi-0.35.5.ebuild b/gnome-extra/guppi/guppi-0.35.5.ebuild
new file mode 100644
index 000000000000..fa83bb54abc5
--- /dev/null
+++ b/gnome-extra/guppi/guppi-0.35.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# /home/cvsroot/gentoo-x86/gnome-office/gnumeric/gnumeric-0.64-r1.ebuild,v 1.1 2001/05/17 13:29:30 achim Exp
+
+A=Guppi-${PV}.tar.gz
+S=${WORKDIR}/Guppi-${PV}
+DESCRIPTION="GNOME Plottin Tool"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/Guppi/${A}"
+HOMEPAGE="http://www.gnome.org/guppi/"
+
+DEPEND="nls? ( sys-devel/gettext )
+ >=dev-util/guile-1.4
+ >=gnome-office/gnumeric-0.65
+ >=dev-util/xml-i18n-tools-0.8.4
+ python? ( >=dev-lang/python-2.0 )
+ bonobo? ( >=gnome-base/bonobo-0.37 )"
+
+RDEPEND=">=gnome-base/gdk-pixbuf-0.11.0
+ >=dev-util/guile-1.4
+ >=gnome-base/gnome-print-0.29
+ bonobo? ( >=gnome-base/bonobo-0.37 )"
+
+src_compile() {
+ local myconf
+
+ if [ "`use bonobo`" ]
+ then
+ myconf="--enable-bonobo"
+ else
+ myconf="--disable-bonobo"
+ fi
+
+ if [ "`use python`" ]
+ then
+ myconf="--enable-python"
+ else
+ myconf="--disable-python"
+ fi
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+ if [ -z "`use readline`" ] ; then
+ myconf="$myconf --disable-guile-readline"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --enable-gnumeric \
+ ${myconf}
+
+ try make ${MAKEOPTS}
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome PREFIX=${D}/usr install
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+
+
+
+
+
+
diff --git a/gnome-office/guppi/files/digest-guppi-0.35.5 b/gnome-office/guppi/files/digest-guppi-0.35.5
new file mode 100644
index 000000000000..8006822e0ff9
--- /dev/null
+++ b/gnome-office/guppi/files/digest-guppi-0.35.5
@@ -0,0 +1 @@
+MD5 93ba14b9334e3838466446614149e2b4 Guppi-0.35.5.tar.gz
diff --git a/gnome-office/guppi/guppi-0.35.5.ebuild b/gnome-office/guppi/guppi-0.35.5.ebuild
new file mode 100644
index 000000000000..fa83bb54abc5
--- /dev/null
+++ b/gnome-office/guppi/guppi-0.35.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# /home/cvsroot/gentoo-x86/gnome-office/gnumeric/gnumeric-0.64-r1.ebuild,v 1.1 2001/05/17 13:29:30 achim Exp
+
+A=Guppi-${PV}.tar.gz
+S=${WORKDIR}/Guppi-${PV}
+DESCRIPTION="GNOME Plottin Tool"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/Guppi/${A}"
+HOMEPAGE="http://www.gnome.org/guppi/"
+
+DEPEND="nls? ( sys-devel/gettext )
+ >=dev-util/guile-1.4
+ >=gnome-office/gnumeric-0.65
+ >=dev-util/xml-i18n-tools-0.8.4
+ python? ( >=dev-lang/python-2.0 )
+ bonobo? ( >=gnome-base/bonobo-0.37 )"
+
+RDEPEND=">=gnome-base/gdk-pixbuf-0.11.0
+ >=dev-util/guile-1.4
+ >=gnome-base/gnome-print-0.29
+ bonobo? ( >=gnome-base/bonobo-0.37 )"
+
+src_compile() {
+ local myconf
+
+ if [ "`use bonobo`" ]
+ then
+ myconf="--enable-bonobo"
+ else
+ myconf="--disable-bonobo"
+ fi
+
+ if [ "`use python`" ]
+ then
+ myconf="--enable-python"
+ else
+ myconf="--disable-python"
+ fi
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+ if [ -z "`use readline`" ] ; then
+ myconf="$myconf --disable-guile-readline"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --enable-gnumeric \
+ ${myconf}
+
+ try make ${MAKEOPTS}
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome PREFIX=${D}/usr install
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+
+
+
+
+
+
diff --git a/gnome-office/mrproject/files/digest-mrproject-0.2.1 b/gnome-office/mrproject/files/digest-mrproject-0.2.1
new file mode 100644
index 000000000000..ef6ed1aa0c13
--- /dev/null
+++ b/gnome-office/mrproject/files/digest-mrproject-0.2.1
@@ -0,0 +1 @@
+MD5 a107d28896def190280964ba1d29b25e mrproject-0.2.1.tar.gz
diff --git a/gnome-office/mrproject/mrproject-0.2.1.ebuild b/gnome-office/mrproject/mrproject-0.2.1.ebuild
new file mode 100644
index 000000000000..4e0602a62b00
--- /dev/null
+++ b/gnome-office/mrproject/mrproject-0.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mikael Hallendal <micke@hallendal.net>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Project management application for GNOME"
+SRC_URI="ftp://ftp.codefactory.se/pub/software/mrproject/source/${A}"
+HOMEPAGE="http://mrproject.codefactory.se/"
+
+DEPEND="nls? ( sys-devel/gettext )
+ >=gnome-base/gal-0.7
+ >=gnome-base/bonobo-1.0.0
+ >=dev-util/xml-i18n-tools-0.8.4"
+
+RDEPEND=">=gnome-base/gal-0.7
+ >=gnome-base/bonobo-1.0.0"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --sysconfdir=/etc/opt/gnome --disable-more-warnings $myconf
+ try make ${MAKEOPTS}
+
+}
+
+src_install () {
+
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO
+
+}
+
+
+
+
+