summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-12-05 03:46:28 +0000
committerBen de Groot <yngwin@gentoo.org>2012-12-05 03:46:28 +0000
commit6e262b02cb047d5612ac87cff545a4d57a18d0d1 (patch)
treeef2937649276d492635f9ddc81fa83158c17902a
parentQt 4.8.4 version bump (diff)
downloadgentoo-2-6e262b02cb047d5612ac87cff545a4d57a18d0d1.tar.gz
gentoo-2-6e262b02cb047d5612ac87cff545a4d57a18d0d1.tar.bz2
gentoo-2-6e262b02cb047d5612ac87cff545a4d57a18d0d1.zip
Qt 4.8.4 version bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--x11-libs/qt-test/ChangeLog7
-rw-r--r--x11-libs/qt-test/qt-test-4.8.4.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/x11-libs/qt-test/ChangeLog b/x11-libs/qt-test/ChangeLog
index 890c2d23dfb6..bcb812dcc2d7 100644
--- a/x11-libs/qt-test/ChangeLog
+++ b/x11-libs/qt-test/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-test
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.123 2012/10/14 17:25:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.124 2012/12/05 03:46:28 yngwin Exp $
+
+*qt-test-4.8.4 (05 Dec 2012)
+
+ 05 Dec 2012; Ben de Groot <yngwin@gentoo.org> +qt-test-4.8.4.ebuild:
+ Qt 4.8.4 version bump
14 Oct 2012; Raúl Porcel <armin76@gentoo.org> qt-test-4.8.2.ebuild:
alpha/ia64/sparc stable wrt #424625
diff --git a/x11-libs/qt-test/qt-test-4.8.4.ebuild b/x11-libs/qt-test/qt-test-4.8.4.ebuild
new file mode 100644
index 000000000000..c38ea6188715
--- /dev/null
+++ b/x11-libs/qt-test/qt-test-4.8.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.8.4.ebuild,v 1.1 2012/12/05 03:46:28 yngwin Exp $
+
+EAPI=4
+
+inherit qt4-build
+
+DESCRIPTION="The testing framework module for the Qt toolkit"
+SLOT="4"
+if [[ ${QT4_BUILD_TYPE} == live ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+IUSE=""
+
+DEPEND="
+ ~x11-libs/qt-core-${PV}[aqua=,debug=]
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/testlib"
+
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/QtTest
+ include/QtCore
+ src/corelib"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf+="
+ -no-xkb -no-fontconfig -no-xrender -no-xrandr -no-xfixes -no-xcursor
+ -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-accessibility -no-fontconfig -no-glib -no-svg"
+
+ qt4-build_src_configure
+}