summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-27 09:08:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-27 09:08:11 +0000
commit6e093240821b93912bfa9fea82f9134cb8bc9702 (patch)
tree24f316f2315edf9e97ca186594283033d4520c91
parentstable bump (Manifest recommit) (diff)
downloadgentoo-2-6e093240821b93912bfa9fea82f9134cb8bc9702.tar.gz
gentoo-2-6e093240821b93912bfa9fea82f9134cb8bc9702.tar.bz2
gentoo-2-6e093240821b93912bfa9fea82f9134cb8bc9702.zip
initial commit - ebuild submitted by Atzm Watanabe via bug #53225
-rw-r--r--games-action/rrootage/ChangeLog10
-rw-r--r--games-action/rrootage/Manifest2
-rw-r--r--games-action/rrootage/files/digest-rrootage-0.23a1
-rw-r--r--games-action/rrootage/metadata.xml5
-rw-r--r--games-action/rrootage/rrootage-0.23a.ebuild48
5 files changed, 66 insertions, 0 deletions
diff --git a/games-action/rrootage/ChangeLog b/games-action/rrootage/ChangeLog
new file mode 100644
index 000000000000..7d4b793faf5f
--- /dev/null
+++ b/games-action/rrootage/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-action/rrootage
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/rrootage/ChangeLog,v 1.1 2004/09/27 09:08:10 mr_bones_ Exp $
+
+*rrootage-0.23a (27 Sep 2004)
+
+ 27 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+ +rrootage-0.23a.ebuild:
+ initial commit - ebuild submitted by Atzm Watanabe via bug #53225
+
diff --git a/games-action/rrootage/Manifest b/games-action/rrootage/Manifest
new file mode 100644
index 000000000000..314acb0ccbc6
--- /dev/null
+++ b/games-action/rrootage/Manifest
@@ -0,0 +1,2 @@
+MD5 314e6077bc0471d36709b373c494afa9 rrootage-0.23a.ebuild 1240
+MD5 282b52d17f5c68430f3db79cb1cd8cfd files/digest-rrootage-0.23a 67
diff --git a/games-action/rrootage/files/digest-rrootage-0.23a b/games-action/rrootage/files/digest-rrootage-0.23a
new file mode 100644
index 000000000000..e4cfc66eac92
--- /dev/null
+++ b/games-action/rrootage/files/digest-rrootage-0.23a
@@ -0,0 +1 @@
+MD5 fb12876d703594d915ec43a56bd9ce62 rRootage-0.23a.tar.gz 3910941
diff --git a/games-action/rrootage/metadata.xml b/games-action/rrootage/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/rrootage/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/rrootage/rrootage-0.23a.ebuild b/games-action/rrootage/rrootage-0.23a.ebuild
new file mode 100644
index 000000000000..153f3b11892f
--- /dev/null
+++ b/games-action/rrootage/rrootage-0.23a.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/rrootage/rrootage-0.23a.ebuild,v 1.1 2004/09/27 09:08:10 mr_bones_ Exp $
+
+inherit games
+
+MY_PN="rRootage"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Abstract shooter - defeat auto-created huge battleships"
+HOMEPAGE="http://www.asahi-net.or.jp/~cs8k-cyu/windows/rr_e.html
+ http://rrootage.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ >=dev-libs/libbulletml-0.0.3"
+
+S="${WORKDIR}/${MY_PN}/src"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s/-lglut/-lGL -lGLU/" makefile.lin > Makefile || die "sed failed"
+
+ sed -i \
+ -e "s:/usr/share/games:${GAMES_DATADIR}:" \
+ barragemanager.cc screen.c soundmanager.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake MORE_CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ newgamesbin rr ${PN} || die "newgamesbin failed"
+ dodir "${GAMES_DATADIR}/${MY_PN}"
+ cp -r ../rr_share/* "${D}/${GAMES_DATADIR}/${MY_PN}" || die "cp failed"
+ dodoc ../readme*
+ prepgamesdirs
+}