summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2013-01-20 16:28:11 +0000
committerIan Whyman <thev00d00@gentoo.org>2013-01-20 16:28:11 +0000
commit6d92ea1f646666ababdcbb18cb197576d28bd6fe (patch)
tree83c896d728f7ad686ad0fb4852d85fde335eedd0
parent2.1.11.47 version bump. This fixes repoman 'TypeError: must be char, not (diff)
downloadgentoo-2-6d92ea1f646666ababdcbb18cb197576d28bd6fe.tar.gz
gentoo-2-6d92ea1f646666ababdcbb18cb197576d28bd6fe.tar.bz2
gentoo-2-6d92ea1f646666ababdcbb18cb197576d28bd6fe.zip
Fix #446922, thanks to Bradley Broom for the patch
(Portage version: 2.2.0_alpha157/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--net-misc/mediatomb/ChangeLog11
-rw-r--r--net-misc/mediatomb/files/mediatomb-0.12.1-avformatcontext-pointer.patch19
-rw-r--r--net-misc/mediatomb/mediatomb-0.12.1-r5.ebuild (renamed from net-misc/mediatomb/mediatomb-0.12.1-r4.ebuild)5
3 files changed, 31 insertions, 4 deletions
diff --git a/net-misc/mediatomb/ChangeLog b/net-misc/mediatomb/ChangeLog
index d382426a0371..454108933498 100644
--- a/net-misc/mediatomb/ChangeLog
+++ b/net-misc/mediatomb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/mediatomb
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/ChangeLog,v 1.40 2012/11/25 15:16:05 lu_zero Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/ChangeLog,v 1.41 2013/01/20 16:28:11 thev00d00 Exp $
+
+*mediatomb-0.12.1-r5 (20 Jan 2013)
+
+ 20 Jan 2013; Ian Whyman <thev00d00@gentoo.org>
+ +files/mediatomb-0.12.1-avformatcontext-pointer.patch,
+ +mediatomb-0.12.1-r5.ebuild, -mediatomb-0.12.1-r4.ebuild:
+ Fix #446922, thanks to Bradley Broom for the patch
25 Nov 2012; Luca Barbato <lu_zero@gentoo.org> mediatomb-0.12.1-r4.ebuild,
+files/mediatomb-0.12.1-libav9.patch,
diff --git a/net-misc/mediatomb/files/mediatomb-0.12.1-avformatcontext-pointer.patch b/net-misc/mediatomb/files/mediatomb-0.12.1-avformatcontext-pointer.patch
new file mode 100644
index 000000000000..ab3e7cf7e17d
--- /dev/null
+++ b/net-misc/mediatomb/files/mediatomb-0.12.1-avformatcontext-pointer.patch
@@ -0,0 +1,19 @@
+When opening a file to check its avformat, the AVFormatContext pointer was
+not initialized to NULL before it was passed by reference to the open
+function.
+
+Patch by Bradley Broom <bmbroom@gmail.com>
+
+https://bugs.gentoo.org/show_bug.cgi?id=446922
+
+--- mediatomb-0.12.1/src/metadata/ffmpeg_handler.cc
++++ mediatomb-0.12.1/src/metadata/ffmpeg_handler.cc
+@@ -281,7 +281,7 @@
+ int x = 0;
+ int y = 0;
+
+- AVFormatContext *pFormatCtx;
++ AVFormatContext *pFormatCtx = NULL;
+
+ // Suppress all log messages
+ av_log_set_callback(FfmpegNoOutputStub);
diff --git a/net-misc/mediatomb/mediatomb-0.12.1-r4.ebuild b/net-misc/mediatomb/mediatomb-0.12.1-r5.ebuild
index 8dac38434756..33c8b3ee41fd 100644
--- a/net-misc/mediatomb/mediatomb-0.12.1-r4.ebuild
+++ b/net-misc/mediatomb/mediatomb-0.12.1-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/mediatomb-0.12.1-r4.ebuild,v 1.2 2012/11/25 15:16:05 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/mediatomb-0.12.1-r5.ebuild,v 1.1 2013/01/20 16:28:11 thev00d00 Exp $
EAPI="4"
inherit autotools eutils linux-info user
@@ -67,6 +67,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-thumb-cache.patch
epatch "${FILESDIR}"/${P}-libav9.patch
epatch "${FILESDIR}"/${P}-no-thumbnail.patch
+ epatch "${FILESDIR}"/${P}-avformatcontext-pointer.patch #446922
eautoreconf
}