summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-02-02 05:55:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-02-02 05:55:29 +0000
commit6d419c1afe311c97ddd392cd4b007a38ef02b1c3 (patch)
tree008b78ad0226f05eeabc1772084ac6ee028284db
parentBump (diff)
downloadgentoo-2-6d419c1afe311c97ddd392cd4b007a38ef02b1c3.tar.gz
gentoo-2-6d419c1afe311c97ddd392cd4b007a38ef02b1c3.tar.bz2
gentoo-2-6d419c1afe311c97ddd392cd4b007a38ef02b1c3.zip
Bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--sci-libs/libghemical/ChangeLog10
-rw-r--r--sci-libs/libghemical/libghemical-3.0.0.ebuild42
2 files changed, 49 insertions, 3 deletions
diff --git a/sci-libs/libghemical/ChangeLog b/sci-libs/libghemical/ChangeLog
index 1202ec8908b0..d8fb7a738223 100644
--- a/sci-libs/libghemical/ChangeLog
+++ b/sci-libs/libghemical/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/libghemical
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/ChangeLog,v 1.27 2012/05/21 23:25:19 vapier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/ChangeLog,v 1.28 2013/02/02 05:55:29 patrick Exp $
+
+*libghemical-3.0.0 (02 Feb 2013)
+
+ 02 Feb 2013; Patrick Lauer <patrick@gentoo.org> +libghemical-3.0.0.ebuild:
+ Bump
21 May 2012; Mike Frysinger <vapier@gentoo.org> libghemical-2.99.1.ebuild:
Inherit eutils for epatch.
@@ -124,4 +129,3 @@
09 Jul 2005; Donnie Berkholz <dberkholz@gentoo.org>; +metadata.xml,
+libghemical-1.90.ebuild:
Initial commit of development version.
-
diff --git a/sci-libs/libghemical/libghemical-3.0.0.ebuild b/sci-libs/libghemical/libghemical-3.0.0.ebuild
new file mode 100644
index 000000000000..612f7c5c736f
--- /dev/null
+++ b/sci-libs/libghemical/libghemical-3.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/libghemical-3.0.0.ebuild,v 1.1 2013/02/02 05:55:29 patrick Exp $
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="Chemical quantum mechanics and molecular mechanics"
+HOMEPAGE="http://bioinformatics.org/ghemical/"
+SRC_URI="http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mopac7 mpqc static-libs"
+
+RDEPEND="
+ mopac7? ( >=sci-chemistry/mopac7-1.13-r1 )
+ mpqc? (
+ >=sci-chemistry/mpqc-2.3.1-r1
+ virtual/blas
+ virtual/lapack )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.98-gl.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable mopac7) \
+ $(use_enable mpqc) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}