summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2007-01-06 16:05:00 +0000
committerLars Weiler <pylon@gentoo.org>2007-01-06 16:05:00 +0000
commit6cafeaafaa8a885a4bb23f03857c69314e28b82a (patch)
tree37cc7e77a4aa2e5139f6052785c7afc2c63eef32
parentDummify src_compile. (diff)
downloadgentoo-2-6cafeaafaa8a885a4bb23f03857c69314e28b82a.tar.gz
gentoo-2-6cafeaafaa8a885a4bb23f03857c69314e28b82a.tar.bz2
gentoo-2-6cafeaafaa8a885a4bb23f03857c69314e28b82a.zip
Correct installation of files when GAMES_DATADIR is different than
/usr/share/games; bug #145008. (Portage version: 2.1.2_rc4-r5)
-rw-r--r--games-simulation/openttd/ChangeLog8
-rw-r--r--games-simulation/openttd/openttd-0.4.8.ebuild15
2 files changed, 16 insertions, 7 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
index f1dada567232..5572e281bff3 100644
--- a/games-simulation/openttd/ChangeLog
+++ b/games-simulation/openttd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/openttd
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.30 2006/12/03 17:22:25 pylon Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.31 2007/01/06 16:05:00 pylon Exp $
+
+ 06 Jan 2007; Lars Weiler <pylon@gentoo.org> openttd-0.4.8.ebuild:
+ Correct installation of files when GAMES_DATADIR is different than
+ /usr/share/games; bug #145008.
03 Dec 2006; Lars Weiler <pylon@gentoo.org> -openttd-0.4.0.1-r1.ebuild,
openttd-0.4.8.ebuild:
diff --git a/games-simulation/openttd/openttd-0.4.8.ebuild b/games-simulation/openttd/openttd-0.4.8.ebuild
index 324b28bfead7..515509d39138 100644
--- a/games-simulation/openttd/openttd-0.4.8.ebuild
+++ b/games-simulation/openttd/openttd-0.4.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.4.8.ebuild,v 1.6 2006/12/03 17:22:25 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.4.8.ebuild,v 1.7 2007/01/06 16:05:00 pylon Exp $
inherit eutils games
@@ -36,7 +36,9 @@ src_unpack() {
fi
cd ${S}
# Don't pre-strip binaries (bug #137822)
- sed -i '/+= -s$/s/-s//' Makefile || die "sed failed"
+ sed -i -e '/+= -s$/s/-s//' Makefile || die "sed failed"
+ # Don't install into prefixed DATA_DIR
+ sed -i -e 's#DATA_DIR_PREFIXED:=$(PREFIX)/$(DATA_DIR)#DATA_DIR_PREFIXED:=$(DATA_DIR)#' Makefile || die "sed failed"
}
src_compile() {
@@ -60,9 +62,11 @@ src_compile() {
INSTALL=1 \
RELEASE=${PV} \
USE_HOMEDIR=1 \
+ DEST_DIR=${D} \
PERSONAL_DIR=.openttd \
- PREFIX=/usr \
- DATA_DIR=share/games/${PN} \
+ PREFIX=${GAMES_PREFIX} \
+ DATA_DIR=${GAMES_DATADIR}/${PN} \
+ CUSTOM_LANG_DIR=${GAMES_DATADIR}/${PN}/lang \
${myopts} \
|| die "emake failed"
}
@@ -100,6 +104,7 @@ src_install() {
fi
dodoc readme.txt known-bugs.txt changelog.txt docs/Manual.txt docs/console.txt docs/multiplayer.txt
+ dohtml -a html,gif,png docs/*
newdoc scripts/readme.txt readme_scripts.txt
doman docs/openttd.6
prepgamesdirs