summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2014-08-08 09:06:38 +0000
committerTiziano Müller <dev-zero@gentoo.org>2014-08-08 09:06:38 +0000
commit6c50d91da3b372970d1707a954ac871abea66270 (patch)
treeff27cef30c1730bd523b97e9c6845d64f1e950c2
parentVersion bump per bug#519350, update SRC_URI, cleanup (diff)
downloadgentoo-2-6c50d91da3b372970d1707a954ac871abea66270.tar.gz
gentoo-2-6c50d91da3b372970d1707a954ac871abea66270.tar.bz2
gentoo-2-6c50d91da3b372970d1707a954ac871abea66270.zip
Rev bump to add php5-5 USE flag.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1A5D023975B0583D!)
-rw-r--r--dev-php/pecl-http/ChangeLog7
-rw-r--r--dev-php/pecl-http/pecl-http-1.7.6-r1.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-php/pecl-http/ChangeLog b/dev-php/pecl-http/ChangeLog
index 74c8738737ba..17caeb9fd0e2 100644
--- a/dev-php/pecl-http/ChangeLog
+++ b/dev-php/pecl-http/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/pecl-http
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-http/ChangeLog,v 1.15 2014/06/03 10:16:58 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-http/ChangeLog,v 1.16 2014/08/08 09:06:38 dev-zero Exp $
+
+*pecl-http-1.7.6-r1 (08 Aug 2014)
+
+ 08 Aug 2014; Tiziano Müller <dev-zero@gentoo.org> +pecl-http-1.7.6-r1.ebuild:
+ Rev bump to add php5-5 USE flag.
*pecl-http-1.7.6 (03 Jun 2014)
diff --git a/dev-php/pecl-http/pecl-http-1.7.6-r1.ebuild b/dev-php/pecl-http/pecl-http-1.7.6-r1.ebuild
new file mode 100644
index 000000000000..0e33b9b56dc9
--- /dev/null
+++ b/dev-php/pecl-http/pecl-http-1.7.6-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-http/pecl-http-1.7.6-r1.ebuild,v 1.1 2014/08/08 09:06:38 dev-zero Exp $
+
+EAPI="5"
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="docs/examples/tutorial.txt ThanksTo.txt KnownIssues.txt"
+
+USE_PHP="php5-3 php5-4 php5-5"
+
+inherit php-ext-pecl-r2 php-ext-source-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP."
+LICENSE="BSD-2 MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="net-misc/curl
+ sys-libs/zlib
+ dev-libs/libevent
+ dev-lang/php[hash,session,iconv]
+ "
+RDEPEND="${DEPEND}"
+
+my_conf="--enable-http \
+ --with-http-curl-requests \
+ --with-http-zlib-compression \
+ --with-http-curl-libevent \
+ --with-http-magic-mime"
+
+src_install() {
+ php-ext-pecl-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "http.etag.mode" "MD5"
+ php-ext-source-r2_addtoinifiles "http.force_exit" "1"
+ php-ext-source-r2_addtoinifiles "http.log.allowed_methods" ""
+ php-ext-source-r2_addtoinifiles "http.log.cache" ""
+ php-ext-source-r2_addtoinifiles "http.log.composite" ""
+ php-ext-source-r2_addtoinifiles "http.log.not_found" ""
+ php-ext-source-r2_addtoinifiles "http.log.redirect" ""
+ php-ext-source-r2_addtoinifiles "http.only_exceptions" "0"
+ php-ext-source-r2_addtoinifiles "http.persistent.handles.ident" "GLOBAL"
+ php-ext-source-r2_addtoinifiles "http.persistent.handles.limit" "-1"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.connect" "0"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.cookie" "0"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.dns" "1"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.ssl" "0"
+ php-ext-source-r2_addtoinifiles "http.request.methods.allowed" ""
+ php-ext-source-r2_addtoinifiles "http.request.methods.custom" ""
+ php-ext-source-r2_addtoinifiles "http.send.inflate.start_auto" "0"
+ php-ext-source-r2_addtoinifiles "http.send.inflate.start_flags" "0"
+ php-ext-source-r2_addtoinifiles "http.send.deflate.start_auto" "0"
+ php-ext-source-r2_addtoinifiles "http.send.deflate.start_flags" "0"
+ php-ext-source-r2_addtoinifiles "http.send.not_found_404" "1"
+}