summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-18 16:10:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-18 16:10:49 +0000
commit6bd9a94403171f4f2879ef538583d22c7037f787 (patch)
tree0a9c0b0700d5ebb72bb15295bfce0ab6ba14c16e
parentStable for amd64, wrt bug #443692 (diff)
downloadgentoo-2-6bd9a94403171f4f2879ef538583d22c7037f787.tar.gz
gentoo-2-6bd9a94403171f4f2879ef538583d22c7037f787.tar.bz2
gentoo-2-6bd9a94403171f4f2879ef538583d22c7037f787.zip
Disable the context library, which is currently not used by anything in tree and only works on a subset of architectures (bug #443012) and has problem with multilib builds (bug #441588). Make sure to remove the headers as well, for both context and locale.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
-rw-r--r--dev-libs/boost/ChangeLog11
-rw-r--r--dev-libs/boost/boost-1.52.0-r3.ebuild (renamed from dev-libs/boost/boost-1.52.0-r2.ebuild)16
2 files changed, 22 insertions, 5 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 49a88cb80434..7882320666c3 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.281 2012/11/13 19:36:19 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.282 2012/11/18 16:10:49 flameeyes Exp $
+
+*boost-1.52.0-r3 (18 Nov 2012)
+
+ 18 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org> +boost-1.52.0-r3.ebuild,
+ -boost-1.52.0-r2.ebuild:
+ Disable the context library, which is currently not used by anything in tree
+ and only works on a subset of architectures (bug #443012) and has problem with
+ multilib builds (bug #441588). Make sure to remove the headers as well, for
+ both context and locale.
13 Nov 2012; Jeroen Roovers <jer@gentoo.org> boost-1.52.0-r2.ebuild:
Marked -hppa (bug #443012).
diff --git a/dev-libs/boost/boost-1.52.0-r2.ebuild b/dev-libs/boost/boost-1.52.0-r3.ebuild
index e761db4b44d0..b5b78910379a 100644
--- a/dev-libs/boost/boost-1.52.0-r2.ebuild
+++ b/dev-libs/boost/boost-1.52.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.52.0-r2.ebuild,v 1.3 2012/11/13 19:36:19 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.52.0-r3.ebuild,v 1.1 2012/11/18 16:10:49 flameeyes Exp $
EAPI="5"
PYTHON_DEPEND="python? *"
@@ -18,7 +18,7 @@ SRC_URI="mirror://sourceforge/boost/${MY_P}.tar.bz2"
LICENSE="Boost-1.0"
SLOT=0
MAJOR_V="$(get_version_component_range 1-2)"
-KEYWORDS="~alpha ~amd64 ~arm -hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="debug doc icu +nls mpi python static-libs +threads tools"
RDEPEND="icu? ( >=dev-libs/icu-3.6:= )
@@ -116,7 +116,7 @@ src_configure() {
use python || OPTIONS+=" --without-python"
use nls || OPTIONS+=" --without-locale"
- OPTIONS+=" pch=off --boost-build=/usr/share/boost-build --prefix=\"${D}usr\" --layout=system threading=$(usex threads multi single) link=$(usex static-libs shared,static shared)"
+ OPTIONS+=" pch=off --boost-build=/usr/share/boost-build --prefix=\"${D}usr\" --layout=system threading=$(usex threads multi single) link=$(usex static-libs shared,static shared) --without-context"
}
src_compile() {
@@ -228,7 +228,15 @@ EOF
installation
fi
- use python || rm -rf "${D}usr/include/boost/python"* || die
+ if ! use python; then
+ rm -r "${D}"/usr/include/boost/python* || die
+ fi
+
+ if ! use nls; then
+ rm -r "${D}"/usr/include/boost/locale || die
+ fi
+
+ rm -r "${D}"/usr/include/boost/context || die
if use doc; then
find libs/*/* -iname "test" -or -iname "src" | xargs rm -rf