summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-08-19 22:17:53 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-08-19 22:17:53 +0000
commit6b690f62ddac79c4f979e544e979f52b2f56bb47 (patch)
tree44b99c14ae9f0abd5170ccb7f0080933678b995a
parentStable for ppc. (diff)
downloadgentoo-2-6b690f62ddac79c4f979e544e979f52b2f56bb47.tar.gz
gentoo-2-6b690f62ddac79c4f979e544e979f52b2f56bb47.tar.bz2
gentoo-2-6b690f62ddac79c4f979e544e979f52b2f56bb47.zip
now that app-editors/qe is gone we can live with a simple block and clean up patches
(Portage version: 2.1.6.13/cvs/Linux i686)
-rw-r--r--app-editors/qemacs/ChangeLog10
-rw-r--r--app-editors/qemacs/files/qemacs-0.4.0_pre20080605-Makefile.patch35
-rw-r--r--app-editors/qemacs/qemacs-0.4.0_pre20080605-r1.ebuild78
3 files changed, 122 insertions, 1 deletions
diff --git a/app-editors/qemacs/ChangeLog b/app-editors/qemacs/ChangeLog
index 58b706338b69..a9690fee1cc1 100644
--- a/app-editors/qemacs/ChangeLog
+++ b/app-editors/qemacs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-editors/qemacs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.43 2009/06/08 18:41:06 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.44 2009/08/19 22:17:52 fauli Exp $
+
+*qemacs-0.4.0_pre20080605-r1 (19 Aug 2009)
+
+ 19 Aug 2009; Christian Faulhammer <fauli@gentoo.org>
+ +qemacs-0.4.0_pre20080605-r1.ebuild,
+ +files/qemacs-0.4.0_pre20080605-Makefile.patch:
+ now that app-editors/qe is gone we can live with a simple block and clean
+ up patches
08 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
-qemacs-0.3.2_pre20070226.ebuild,
diff --git a/app-editors/qemacs/files/qemacs-0.4.0_pre20080605-Makefile.patch b/app-editors/qemacs/files/qemacs-0.4.0_pre20080605-Makefile.patch
new file mode 100644
index 000000000000..73c3f68b13a3
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.4.0_pre20080605-Makefile.patch
@@ -0,0 +1,35 @@
+--- Makefile.orig 2009-03-07 21:27:48.000000000 +0100
++++ Makefile 2009-03-07 21:28:43.000000000 +0100
+@@ -19,32 +19,6 @@
+
+ include config.mak
+
+-ifeq ($(CC),gcc)
+- CFLAGS := -Wall -g -O2 -funsigned-char
+- # do not warn about zero-length formats.
+- CFLAGS += -Wno-format-zero-length
+- LDFLAGS := -g
+-endif
+-
+-#include local compiler configuration file
+--include cflags.mk
+-
+-ifdef TARGET_GPROF
+- CFLAGS += -p
+- LDFLAGS += -p
+-endif
+-
+-TLDFLAGS := $(LDFLAGS)
+-
+-ifdef TARGET_ARCH_X86
+- #CFLAGS+=-fomit-frame-pointer
+- ifeq ($(GCC_MAJOR),2)
+- CFLAGS+=-m386 -malign-functions=0
+- else
+- CFLAGS+=-march=i386 -falign-functions=0
+- endif
+-endif
+-
+ DEFINES=-DHAVE_QE_CONFIG_H
+
+ ########################################################
diff --git a/app-editors/qemacs/qemacs-0.4.0_pre20080605-r1.ebuild b/app-editors/qemacs/qemacs-0.4.0_pre20080605-r1.ebuild
new file mode 100644
index 000000000000..d152c65d4764
--- /dev/null
+++ b/app-editors/qemacs/qemacs-0.4.0_pre20080605-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.4.0_pre20080605-r1.ebuild,v 1.1 2009/08/19 22:17:52 fauli Exp $
+
+EAPI=1
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="QEmacs is a very small but powerful UNIX editor"
+HOMEPAGE="http://savannah.nongnu.org/projects/qemacs"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X png unicode xv"
+RESTRICT="strip"
+
+DEPEND="X? ( x11-libs/libX11
+ x11-libs/libXext
+ xv? ( x11-libs/libXv ) )
+ png? ( media-libs/libpng:1.2 )
+ !app-editors/qe"
+
+RDEPEND="${DEPEND}"
+
+DEPEND="${DEPEND}
+ app-text/texi2html"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Removes forced march setting and align-functions on x86, as they
+ # would override user's CFLAGS..
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+ # Make backup files optional
+ epatch "${FILESDIR}/${P}-make_backup.patch"
+
+ useq unicode && epatch "${FILESDIR}/${PN}-0.3.2_pre20070226-tty_utf8.patch"
+ # Change the manpage to reference a /real/ file instead of just an
+ # approximation. Purely cosmetic!
+ sed -i "s,^/usr/share/doc/qe,&-${PVR}," qe.1
+}
+
+src_compile() {
+ # when using any other CFLAGS than -O0, qemacs will segfault on startup, see bug #92011
+ replace-flags -O? -O0
+ econf --cc="$(tc-getCC)" \
+ $(use_enable X x11) \
+ $(use_enable png) \
+ $(use_enable xv) \
+ || die "econf failed"
+ # Does not support parallel building
+ emake -j1 || die
+}
+
+src_test() {
+ # There are some files purporting to be tests in the tarball, however
+ # there is no defined way to use them and I imagine even if there was
+ # it would require user interaction.
+ # The toplevel Makefile calls the test target from the non-existant
+ # tests/Makefile, so just noop to stop errors if maketest is set.
+ :
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc Changelog README TODO config.eg
+ dohtml *.html
+
+ # Install headers so users can build their own plugins.
+ insinto /usr/include/qemacs
+ doins cfb.h config.h cutils.h display.h fbfrender.h libfbf.h qe.h \
+ qeconfig.h qestyles.h qfribidi.h
+ cd libqhtml
+ insinto /usr/include/qemacs/libqhtml
+ doins {css{,id},htmlent}.h
+}