summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-02 17:12:49 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-02 17:12:49 +0000
commit6b5d5beeeda1c1eb5303e57e276ce2baade01b5c (patch)
tree5af0a36406910080be7c6a7a971273546bd44d8a
parentStable on alpha. (diff)
downloadgentoo-2-6b5d5beeeda1c1eb5303e57e276ce2baade01b5c.tar.gz
gentoo-2-6b5d5beeeda1c1eb5303e57e276ce2baade01b5c.tar.bz2
gentoo-2-6b5d5beeeda1c1eb5303e57e276ce2baade01b5c.zip
Version bump.
(Portage version: 2.0.51.22-r1)
-rw-r--r--sys-libs/uclibc++/ChangeLog7
-rw-r--r--sys-libs/uclibc++/files/digest-uclibc++-0.1.111
-rw-r--r--sys-libs/uclibc++/uclibc++-0.1.11.ebuild74
3 files changed, 81 insertions, 1 deletions
diff --git a/sys-libs/uclibc++/ChangeLog b/sys-libs/uclibc++/ChangeLog
index 0c05e760c1e7..8471da2a6cc0 100644
--- a/sys-libs/uclibc++/ChangeLog
+++ b/sys-libs/uclibc++/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/uclibc++
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc++/ChangeLog,v 1.2 2005/01/22 05:21:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc++/ChangeLog,v 1.3 2005/07/02 17:12:49 vapier Exp $
+
+*uclibc++-0.1.11 (02 Jul 2005)
+
+ 02 Jul 2005; Mike Frysinger <vapier@gentoo.org> +uclibc++-0.1.11.ebuild:
+ Version bump.
*uclibc++-0.1.9 (22 Jan 2005)
diff --git a/sys-libs/uclibc++/files/digest-uclibc++-0.1.11 b/sys-libs/uclibc++/files/digest-uclibc++-0.1.11
new file mode 100644
index 000000000000..6f29281d8a7a
--- /dev/null
+++ b/sys-libs/uclibc++/files/digest-uclibc++-0.1.11
@@ -0,0 +1 @@
+MD5 8a8e0ee8fefef150c08a649fd7da04aa uClibc++-0.1.11.tbz2 253582
diff --git a/sys-libs/uclibc++/uclibc++-0.1.11.ebuild b/sys-libs/uclibc++/uclibc++-0.1.11.ebuild
new file mode 100644
index 000000000000..ff6325f28b9c
--- /dev/null
+++ b/sys-libs/uclibc++/uclibc++-0.1.11.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc++/uclibc++-0.1.11.ebuild,v 1.1 2005/07/02 17:12:49 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+DESCRIPTION="embedded C++ library"
+HOMEPAGE="http://cxx.uclibc.org/"
+SRC_URI="http://cxx.uclibc.org/src/uClibc++-${PV}.tbz2"
+
+LICENSE="GPL-2"
+[[ ${CTARGET} != ${CHOST} ]] \
+ && SLOT="${CTARGET}" \
+ || SLOT="0"
+KEYWORDS="~arm ~ppc ~x86"
+IUSE="debug static"
+
+DEPEND=""
+
+S=${WORKDIR}/uClibc++
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ make defconfig || die "defconfig failed"
+
+ local target
+ case $(tc-arch ${CTARGET}) in
+ arm) target="arm";;
+ mips) target="mips";;
+ ppc) target="powerpc";;
+ x86) target="i386";;
+ *) die "$(tc-arch ${CTARGET}) lists no defaults :/";;
+ esac
+
+ sed -i \
+ -e '/^UCLIBCXX_RUNTIME_PREFIX=/d' \
+ -e '/^TARGET_'${target}'/d' \
+ .config
+
+ echo "UCLIBCXX_RUNTIME_PREFIX=\"/usr/${CTARGET}\"" >> .config
+ echo "TARGET_${target}=y" >> .config
+ use debug && echo "CONFIG_DODEBUG=y" >> .config
+
+ yes "" | make oldconfig || die "oldconfig failed"
+
+ # has to come after make oldconfig, else it will be disabled
+ echo "BUILD_STATIC_LIB=y" >> .config
+ if use static ; then
+ echo "BUILD_ONLY_STATIC_LIB=y" >> .config
+ fi
+}
+
+src_compile() {
+ emake -j1 ARCH_CFLAGS="${CFLAGS}" CROSS=${CTARGET}- || die "make failed"
+}
+
+src_test() {
+ make test || die "test failed"
+}
+
+src_install() {
+ make install PREFIX="${D}" || die
+ dodir /usr/bin
+ dosym /usr/${CTARGET}/bin/g++-uc /usr/bin/g++-uc
+ dodoc ChangeLog README TODO
+}