summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2014-06-05 22:36:10 +0000
committerMichael Weber <xmw@gentoo.org>2014-06-05 22:36:10 +0000
commit68e8ad7e0205f5f9e50d6b00087863371a57ad7c (patch)
treea711a6c95b05c8f6b1ac168a23d21e5eeffc29da
parentUpdate License. (diff)
downloadgentoo-2-68e8ad7e0205f5f9e50d6b00087863371a57ad7c.tar.gz
gentoo-2-68e8ad7e0205f5f9e50d6b00087863371a57ad7c.tar.bz2
gentoo-2-68e8ad7e0205f5f9e50d6b00087863371a57ad7c.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
-rw-r--r--net-misc/clipgrab/ChangeLog10
-rw-r--r--net-misc/clipgrab/clipgrab-3.4.2.ebuild32
-rw-r--r--net-misc/clipgrab/files/clipgrab-3.4.2-obey.patch38
3 files changed, 78 insertions, 2 deletions
diff --git a/net-misc/clipgrab/ChangeLog b/net-misc/clipgrab/ChangeLog
index b918b621c357..32032a539404 100644
--- a/net-misc/clipgrab/ChangeLog
+++ b/net-misc/clipgrab/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/clipgrab
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/clipgrab/ChangeLog,v 1.17 2013/08/11 22:57:48 aballier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/clipgrab/ChangeLog,v 1.18 2014/06/05 22:36:10 xmw Exp $
+
+*clipgrab-3.4.2 (05 Jun 2014)
+
+ 05 Jun 2014; Michael Weber <xmw@gentoo.org> +clipgrab-3.4.2.ebuild,
+ +files/clipgrab-3.4.2-obey.patch:
+ Version bump
11 Aug 2013; Alexis Ballier <aballier@gentoo.org> clipgrab-3.2.0.11.ebuild,
clipgrab-3.2.1.0.ebuild:
diff --git a/net-misc/clipgrab/clipgrab-3.4.2.ebuild b/net-misc/clipgrab/clipgrab-3.4.2.ebuild
new file mode 100644
index 000000000000..82149927f679
--- /dev/null
+++ b/net-misc/clipgrab/clipgrab-3.4.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/clipgrab/clipgrab-3.4.2.ebuild,v 1.1 2014/06/05 22:36:10 xmw Exp $
+
+EAPI=5
+
+inherit qt4-r2 eutils
+
+DESCRIPTION="Download from various internet video services like Youtube etc."
+HOMEPAGE="http://clipgrab.de/en"
+SRC_URI="http://${PN}.de/download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtwebkit:4"
+# does not work with libav #474368
+RDEPEND="${DEPEND}
+ media-video/ffmpeg:0"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.4.2-obey.patch"
+)
+
+src_install() {
+ dobin ${PN}
+
+ newicon icon.png ${PN}.png
+ make_desktop_entry clipgrab Clipgrab "" "Qt;Video;AudioVideo;"
+}
diff --git a/net-misc/clipgrab/files/clipgrab-3.4.2-obey.patch b/net-misc/clipgrab/files/clipgrab-3.4.2-obey.patch
new file mode 100644
index 000000000000..353278d09d31
--- /dev/null
+++ b/net-misc/clipgrab/files/clipgrab-3.4.2-obey.patch
@@ -0,0 +1,38 @@
+--- clipgrab-3.4.2/clipgrab.cpp
++++ clipgrab-3.4.2/clipgrab.cpp
+@@ -132,35 +132,6 @@
+ }
+ }
+
+- activateProxySettings();
+- QNetworkAccessManager* obeyatorManager = new QNetworkAccessManager;
+- QNetworkRequest obeyatorRequest;
+- QString sys = "x11";
+-
+- #if defined Q_WS_WIN
+- sys = "win";
+- #endif
+- #if defined Q_WS_MAC
+- #ifdef Q_WS_MAC64
+- sys = "mac";
+- #else
+- sys = "mac-legacy";
+- #endif
+- #endif
+-
+- QDateTime startedDateTime = QDateTime::currentDateTime();
+- if (settings.value("firstStarted", 0).toInt() == 0)
+- {
+- settings.setValue("firstStarted", startedDateTime.toTime_t());
+- }
+- if (settings.value("firstStarted-" + version, 0) == 0)
+- {
+- settings.setValue("firstStarted-" + version, startedDateTime.toTime_t());
+- }
+- obeyatorRequest.setUrl("http://clipgrab.de/or.php?version=" + version +"&lang="+QLocale::system().name().split("_")[0]+"&sys="+sys+"&current=" + settings.value("firstStarted-" + version, startedDateTime.toTime_t()).toString()+"&first="+settings.value("firstStarted", startedDateTime.toTime_t()).toString());
+- obeyatorManager->get(obeyatorRequest);
+- connect(obeyatorManager, SIGNAL(finished(QNetworkReply*)), this, SLOT(obey(QNetworkReply*)));
+-
+ connect(QApplication::clipboard(), SIGNAL(dataChanged()), this, SLOT(clipboardChanged()));
+
+ }