summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-02-17 07:45:28 +0000
committerHans de Graaff <graaff@gentoo.org>2010-02-17 07:45:28 +0000
commit68a2fd7123fa3e9c9c31e2e4e3a56cb86a76924f (patch)
treec3dcb76bfc8460e8890232641c7172a9fcf73b3d
parentTransfer prefix keywords (diff)
downloadgentoo-2-68a2fd7123fa3e9c9c31e2e4e3a56cb86a76924f.tar.gz
gentoo-2-68a2fd7123fa3e9c9c31e2e4e3a56cb86a76924f.tar.bz2
gentoo-2-68a2fd7123fa3e9c9c31e2e4e3a56cb86a76924f.zip
Version bump.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
-rw-r--r--dev-ruby/haml/ChangeLog7
-rw-r--r--dev-ruby/haml/haml-2.2.20.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/haml/ChangeLog b/dev-ruby/haml/ChangeLog
index 78903bfac69b..9c1fa590da5a 100644
--- a/dev-ruby/haml/ChangeLog
+++ b/dev-ruby/haml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/haml
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.35 2010/02/10 20:51:22 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.36 2010/02/17 07:45:28 graaff Exp $
+
+*haml-2.2.20 (17 Feb 2010)
+
+ 17 Feb 2010; Hans de Graaff <graaff@gentoo.org> +haml-2.2.20.ebuild:
+ Version bump.
*haml-2.2.19 (10 Feb 2010)
diff --git a/dev-ruby/haml/haml-2.2.20.ebuild b/dev-ruby/haml/haml-2.2.20.ebuild
new file mode 100644
index 000000000000..1fbfc2c6e1f6
--- /dev/null
+++ b/dev-ruby/haml/haml-2.2.20.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-2.2.20.ebuild,v 1.1 2010/02/17 07:45:28 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HAML - a ruby web page templating engine"
+HOMEPAGE="http://haml.hamptoncatlin.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+# TODO: haml has some emacs modes that it could be installing, in case
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/haml.gemspec/,/Task\[:package\]/s:^:#:' "${S}"/Rakefile
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # This is needed otherwise it fails at runtime
+ ruby_fakegem_doins VERSION VERSION_NAME
+}
+
+# The html engine requires hpricot
+ruby_add_rdepend dev-ruby/hpricot
+
+# It could use merb during testing as well, but it's not mandatory
+ruby_add_bdepend test "virtual/ruby-test-unit dev-ruby/actionpack"
+ruby_add_bdepend doc "dev-ruby/yard dev-ruby/maruku"