summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-02-03 10:27:00 +0000
committerUlrich Müller <ulm@gentoo.org>2008-02-03 10:27:00 +0000
commit66d54842d9a7c2b2c24708503fcce7721dc82c9e (patch)
tree44c3ec79990c06a7c49e4c266ce4750cd85d663c
parentbump (diff)
downloadgentoo-2-66d54842d9a7c2b2c24708503fcce7721dc82c9e.tar.gz
gentoo-2-66d54842d9a7c2b2c24708503fcce7721dc82c9e.tar.bz2
gentoo-2-66d54842d9a7c2b2c24708503fcce7721dc82c9e.zip
Reorder image format options alphabetically.
(Portage version: 2.1.4.1)
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-23.0.50_pre20080201.ebuild10
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild16
2 files changed, 14 insertions, 12 deletions
diff --git a/app-editors/emacs-cvs/emacs-cvs-23.0.50_pre20080201.ebuild b/app-editors/emacs-cvs/emacs-cvs-23.0.50_pre20080201.ebuild
index 43a7a9151c20..41e2966b0444 100644
--- a/app-editors/emacs-cvs/emacs-cvs-23.0.50_pre20080201.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-23.0.50_pre20080201.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.50_pre20080201.ebuild,v 1.2 2008/02/02 09:14:26 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.50_pre20080201.ebuild,v 1.3 2008/02/03 10:27:00 ulm Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -33,9 +33,9 @@ RDEPEND="sys-libs/ncurses
x11-misc/emacs-desktop
gif? ( media-libs/giflib )
jpeg? ( media-libs/jpeg )
- tiff? ( media-libs/tiff )
png? ( media-libs/libpng )
svg? ( >=gnome-base/librsvg-2.0 )
+ tiff? ( media-libs/tiff )
xpm? ( x11-libs/libXpm )
gtk? ( =x11-libs/gtk+-2* )
!gtk? (
@@ -106,9 +106,9 @@ src_compile() {
if use X; then
myconf="${myconf} --with-x"
myconf="${myconf} $(use_with toolkit-scroll-bars)"
- myconf="${myconf} $(use_with jpeg) $(use_with tiff)"
- myconf="${myconf} $(use_with gif) $(use_with png)"
- myconf="${myconf} $(use_with xpm) $(use_with svg rsvg)"
+ myconf="${myconf} $(use_with gif) $(use_with jpeg)"
+ myconf="${myconf} $(use_with png) $(use_with svg rsvg)"
+ myconf="${myconf} $(use_with tiff) $(use_with xpm)"
# GTK+ is the default toolkit if USE=gtk is chosen with other
# possibilities. Emacs upstream thinks this should be standard
diff --git a/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild b/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild
index d05650e1c198..7f1a1a2f7bdb 100644
--- a/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild,v 1.4 2008/02/02 14:18:11 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild,v 1.5 2008/02/03 10:27:00 ulm Exp $
ECVS_AUTH="pserver"
ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
@@ -40,9 +40,9 @@ RDEPEND="sys-libs/ncurses
x11-misc/emacs-desktop
gif? ( media-libs/giflib )
jpeg? ( media-libs/jpeg )
- tiff? ( media-libs/tiff )
png? ( media-libs/libpng )
svg? ( >=gnome-base/librsvg-2.0 )
+ tiff? ( media-libs/tiff )
xpm? ( x11-libs/libXpm )
xft? (
media-libs/fontconfig
@@ -129,16 +129,18 @@ src_compile() {
if use X; then
myconf="${myconf} --with-x"
myconf="${myconf} $(use_with toolkit-scroll-bars)"
+ myconf="${myconf} $(use_with gif) $(use_with jpeg)"
+ myconf="${myconf} $(use_with png) $(use_with svg rsvg)"
+ myconf="${myconf} $(use_with tiff) $(use_with xpm)"
+
myconf="${myconf} $(use_enable xft font-backend)"
myconf="${myconf} $(use_with xft freetype) $(use_with xft)"
if use xft && use libotf; then
- myconf="${myconf} --with-libotf"
+ # disable m17n-flt since m17n-lib-1.3.4 doesn't support it
+ myconf="${myconf} --with-libotf --without-m17n-flt"
else
- myconf="${myconf} --without-libotf"
+ myconf="${myconf} --without-libotf --without-m17n-flt"
fi
- myconf="${myconf} $(use_with jpeg) $(use_with tiff)"
- myconf="${myconf} $(use_with gif) $(use_with png)"
- myconf="${myconf} $(use_with xpm) $(use_with svg rsvg)"
# GTK+ is the default toolkit if USE=gtk is chosen with other
# possibilities. Emacs upstream thinks this should be standard