summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-02-01 20:21:15 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-02-01 20:21:15 +0000
commit66b61a756fccd1565349bba5176278a09f484f17 (patch)
treeeb826faf22c0959bcbeb45e94499669c87beaa99
parentfix bug #13957: inherit kde-functions and use set-qtdir to get the qt sandbox... (diff)
downloadgentoo-2-66b61a756fccd1565349bba5176278a09f484f17.tar.gz
gentoo-2-66b61a756fccd1565349bba5176278a09f484f17.tar.bz2
gentoo-2-66b61a756fccd1565349bba5176278a09f484f17.zip
new version
-rw-r--r--sys-apps/module-init-tools/ChangeLog7
-rw-r--r--sys-apps/module-init-tools/files/digest-module-init-tools-0.9.92
-rw-r--r--sys-apps/module-init-tools/module-init-tools-0.9.9.ebuild108
3 files changed, 116 insertions, 1 deletions
diff --git a/sys-apps/module-init-tools/ChangeLog b/sys-apps/module-init-tools/ChangeLog
index 0d369fc089d8..1dbaa670f253 100644
--- a/sys-apps/module-init-tools/ChangeLog
+++ b/sys-apps/module-init-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/module-init-tools
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/ChangeLog,v 1.8 2003/01/19 21:21:58 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/ChangeLog,v 1.9 2003/02/01 20:21:15 azarah Exp $
+
+*module-init-tools-0.9.9 (01 Feb 2003)
+
+ 01 Feb 2003; Martin Schlemmer <azarah@gentoo.org> module-init-tools-0.9.9 :
+ New version.
*module-init-tools-0.9.9_pre1 (17 Jan 2003)
diff --git a/sys-apps/module-init-tools/files/digest-module-init-tools-0.9.9 b/sys-apps/module-init-tools/files/digest-module-init-tools-0.9.9
new file mode 100644
index 000000000000..8c2f1776a31f
--- /dev/null
+++ b/sys-apps/module-init-tools/files/digest-module-init-tools-0.9.9
@@ -0,0 +1,2 @@
+MD5 b697cb1099bc6c0a5738b1ebb7716a79 module-init-tools-0.9.9.tar.bz2 96524
+MD5 6c5d2a62ae98708f3ad0c57900d63919 modutils-2.4.22.tar.bz2 219457
diff --git a/sys-apps/module-init-tools/module-init-tools-0.9.9.ebuild b/sys-apps/module-init-tools/module-init-tools-0.9.9.ebuild
new file mode 100644
index 000000000000..f3d2aa8d0a98
--- /dev/null
+++ b/sys-apps/module-init-tools/module-init-tools-0.9.9.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/module-init-tools-0.9.9.ebuild,v 1.1 2003/02/01 20:21:15 azarah Exp $
+
+# This includes backwards compatability for stable kernels
+IUSE=""
+
+inherit flag-o-matic
+
+inherit eutils
+
+MYP="${P/_pre1/-pre}"
+S="${WORKDIR}/${MYP}"
+MODUTILS_PV="2.4.22"
+DESCRIPTION="Kernel module tools for the development kernel >=2.5.48"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/people/rusty/modules/${MYP}.tar.bz2
+ http://www.kernel.org/pub/linux/utils/kernel/modutils/v2.4/modutils-${MODUTILS_PV}.tar.bz2"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/rusty/modules"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc"
+RDEPEND=">=sys-kernel/development-sources-2.5.48"
+
+src_compile() {
+ filter-flags -fPIC
+
+ einfo "Building modutils..."
+ cd ${WORKDIR}/modutils-${MODUTILS_PV}
+
+ econf \
+ --disable-strip \
+ --prefix=/ \
+ --enable-insmod-static \
+ --disable-zlib \
+ ${myconf}
+ emake || die "emake modultils failed"
+
+ einfo "Building module-init-tools..."
+ cd ${S}
+
+ econf \
+ --prefix=/ \
+ ${myconf}
+
+ emake || die "emake module-init-tools failed"
+}
+
+src_install () {
+
+ cd ${WORKDIR}/modutils-${MODUTILS_PV}
+ einstall prefix="${D}"
+ dodoc COPYING CREDITS ChangeLog NEWS README TODO
+
+ cd ${S}
+ # This copies the old version of modutils to *.old so it still works
+ # with kernels <= 2.4
+ # This code was borrowed from the module-init-tools Makefile
+ for f in lsmod modprobe rmmod depmod insmod; do
+ if [ -L ${D}/sbin/${f} ]; then
+ ln -sf `ls -l ${D}/sbin/${f} | \
+ sed 's/.* -> //'`.old ${D}/sbin/${f};
+ fi;
+ mv ${D}/sbin/${f} ${D}/sbin/${f}.old;
+ done
+# make prefix=${D} move-old-targets || die "Renaming old bins to *.old failed"
+
+ einstall prefix=${D}
+
+ # Install the modules.conf2modprobe.conf tool, so we can update
+ # modprobe.conf.
+ into /
+ dosbin ${S}/generate-modprobe.conf
+
+ # Create the new modprobe.conf
+ dodir /etc
+ einfo "Generating /etc/modprobe.conf ..."
+ PATH="${D}/sbin:${PATH}" \
+ ${S}/generate-modprobe.conf ${D}/etc/modprobe.conf \
+ || die "Could not create modprobe.conf"
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+}
+
+pkg_postinst() {
+ # Notify user of evilness, hope for a better way ;-)
+ echo ""
+ einfo "This overwrites the modutils files, so if you remove this,"
+ einfo "remember to remerge modutils. However, this package has"
+ einfo "installed a copy of the modutils files with suffix .old"
+ einfo "in your /sbin directory, which will automatically be used"
+ einfo "when needed."
+ echo ""
+}
+
+
+
+pkg_postrm() {
+ if [ "$(best_version ${PN})" == "${CATEGORY}/${PF}" -a ! -f /sbin/insmod ]; then
+ ewarn "Uninstalling module-init-tools has left you"
+ ewarn "without a modutils installtion. we recommend"
+ ewarn "emerging modutils immediately or remerging"
+ ewarn "module-init-tools."
+ fi
+}
+