summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-07-14 13:18:16 +0000
committerStuart Herbert <stuart@gentoo.org>2004-07-14 13:18:16 +0000
commit663e0862918f25c944c51e0074c1fe3572db5040 (patch)
tree1148abd0e7303464e251d7933afa05735efdd460
parentNow uses php5 final (Manifest recommit) (diff)
downloadgentoo-2-663e0862918f25c944c51e0074c1fe3572db5040.tar.gz
gentoo-2-663e0862918f25c944c51e0074c1fe3572db5040.tar.bz2
gentoo-2-663e0862918f25c944c51e0074c1fe3572db5040.zip
Removed old BETA versions of PHP5 due to security bug
-rw-r--r--dev-php/php/ChangeLog9
-rw-r--r--dev-php/php/files/digest-php-5.0_beta11
-rw-r--r--dev-php/php/files/digest-php-5.0_beta1-r11
-rw-r--r--dev-php/php/php-5.0_beta1-r1.ebuild61
-rw-r--r--dev-php/php/php-5.0_beta1.ebuild55
5 files changed, 8 insertions, 119 deletions
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index 9a2ec49f1c5a..c169b2b2d2ec 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-php/php
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.101 2004/07/14 02:47:59 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.102 2004/07/14 13:18:16 stuart Exp $
+
+ 14 Jul 2004; Stuart Herbert <stuart@gentoo.org> -php-5.0_beta1-r1.ebuild,
+ -php-5.0_beta1.ebuild:
+ Obsolete version; removed by eversionrm tool
+
+ 14 Jul 2004; Stuart Herbert <stuart@gentoo.org> -php-5.0_beta1-r1.ebuild:
+ Obsolete version; removed by eversionrm tool
*php-4.3.8 (13 Jul 2004)
diff --git a/dev-php/php/files/digest-php-5.0_beta1 b/dev-php/php/files/digest-php-5.0_beta1
deleted file mode 100644
index 3ea47d456f66..000000000000
--- a/dev-php/php/files/digest-php-5.0_beta1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 0cb4ce9c05b639b763bc272c15fbb1a6 php-5.0.0b1.tar.bz2 3882958
diff --git a/dev-php/php/files/digest-php-5.0_beta1-r1 b/dev-php/php/files/digest-php-5.0_beta1-r1
deleted file mode 100644
index 3ea47d456f66..000000000000
--- a/dev-php/php/files/digest-php-5.0_beta1-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 0cb4ce9c05b639b763bc272c15fbb1a6 php-5.0.0b1.tar.bz2 3882958
diff --git a/dev-php/php/php-5.0_beta1-r1.ebuild b/dev-php/php/php-5.0_beta1-r1.ebuild
deleted file mode 100644
index 6dc91f862a75..000000000000
--- a/dev-php/php/php-5.0_beta1-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-5.0_beta1-r1.ebuild,v 1.7 2004/06/25 01:23:03 agriffis Exp $
-
-PHPSAPI="cli"
-MY_P="php-5.0.0b1"
-inherit php eutils
-
-#need to override SRC_URI, the beta isn't available from the usual url which is defined in the eclass
-SRC_URI="http://us3.php.net/distributions/php-5.0.0b1.tar.bz2"
-
-IUSE="${IUSE} readline"
-
-DESCRIPTION="PHP Shell Interpreter"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa mips"
-
-DEPEND="${DEPEND}
- readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
- truetype? ( >=media-libs/t1lib-5.0.0 )"
-
-RDEPEND="${RDEPEND}"
-
-EXCLUDE_DB4_FIX=1
-EXCLUDE_PEAR_FIX=1
-
-src_compile() {
-
- use readline && myconf="${myconf} --with-readline"
-
- myconf="${myconf} \
- --disable-cgi \
- --enable-cli \
- --enable-embed"
-
- php_src_compile
-
-}
-
-
-src_install() {
- installtargets="${installtargets} install-cli"
- php_src_install
-
- #embed hack..
- exeinto /usr/lib/
- doexe .libs/libphp5.so
-
- # php executable is located in ./sapi/cli/
- exeinto /usr/bin
- doexe sapi/cli/php
-}
-
-pkg_postinst() {
- php_pkg_postinst
- einfo "This is a CLI only build."
- einfo "You can not use it on a webserver."
-}
-pkg_preinst() {
- php_pkg_preinst
-}
diff --git a/dev-php/php/php-5.0_beta1.ebuild b/dev-php/php/php-5.0_beta1.ebuild
deleted file mode 100644
index 6006661c8cb4..000000000000
--- a/dev-php/php/php-5.0_beta1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-5.0_beta1.ebuild,v 1.5 2004/06/25 01:23:03 agriffis Exp $
-
-PHPSAPI="cli"
-MY_P="php-5.0.0b1"
-inherit php eutils
-
-#need to override SRC_URI, the beta isn't available from the usual url which is defined in the eclass
-SRC_URI="http://us3.php.net/distributions/php-5.0.0b1.tar.bz2"
-
-IUSE="${IUSE} readline"
-
-DESCRIPTION="PHP Shell Interpreter"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
-
-DEPEND="${DEPEND}
- readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 ) "
-
-RDEPEND="${RDEPEND}"
-
-EXCLUDE_DB4_FIX=1
-EXCLUDE_PEAR_FIX=1
-
-src_compile() {
-
- use readline && myconf="${myconf} --with-readline"
-
- myconf="${myconf} \
- --disable-cgi \
- --enable-cli"
-
- php_src_compile
-
-}
-
-
-src_install() {
- installtargets="${installtargets} install-cli"
- php_src_install
-
- # php executable is located in ./sapi/cli/
- exeinto /usr/bin
- doexe sapi/cli/php
-}
-
-pkg_postinst() {
- php_pkg_postinst
- einfo "This is a CLI only build."
- einfo "You can not use it on a webserver."
-}
-pkg_preinst() {
- php_pkg_preinst
-}