summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-03-12 14:18:12 +0000
committerSamuli Suominen <drac@gentoo.org>2008-03-12 14:18:12 +0000
commit6629aad4812647ecf97c90870dec3fac871c9afd (patch)
treed696129fb67738ca8c3b71ef0df348f1f930ef63
parentRemoving Peter Johanson (latexer, #206688) from metadata.xml. (diff)
downloadgentoo-2-6629aad4812647ecf97c90870dec3fac871c9afd.tar.gz
gentoo-2-6629aad4812647ecf97c90870dec3fac871c9afd.tar.bz2
gentoo-2-6629aad4812647ecf97c90870dec3fac871c9afd.zip
bump
(Portage version: 2.1.4.4)
-rw-r--r--x11-plugins/wmcliphist/ChangeLog10
-rw-r--r--x11-plugins/wmcliphist/files/wmcliphist-0.6-Makefile.patch47
-rw-r--r--x11-plugins/wmcliphist/wmcliphist-0.6.ebuild35
3 files changed, 90 insertions, 2 deletions
diff --git a/x11-plugins/wmcliphist/ChangeLog b/x11-plugins/wmcliphist/ChangeLog
index 39092531bb62..475b2a9956b4 100644
--- a/x11-plugins/wmcliphist/ChangeLog
+++ b/x11-plugins/wmcliphist/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmcliphist
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcliphist/ChangeLog,v 1.6 2007/02/06 01:58:05 flameeyes Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcliphist/ChangeLog,v 1.7 2008/03/12 14:18:11 drac Exp $
+
+*wmcliphist-0.6 (12 Mar 2008)
+
+ 12 Mar 2008; Samuli Suominen <drac@gentoo.org>
+ +files/wmcliphist-0.6-Makefile.patch, +wmcliphist-0.6.ebuild:
+ Version bump.
06 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/x11-plugins/wmcliphist/files/wmcliphist-0.6-Makefile.patch b/x11-plugins/wmcliphist/files/wmcliphist-0.6-Makefile.patch
new file mode 100644
index 000000000000..61e2d7db86ac
--- /dev/null
+++ b/x11-plugins/wmcliphist/files/wmcliphist-0.6-Makefile.patch
@@ -0,0 +1,47 @@
+diff -ur wmcliphist-0.6.orig/Makefile wmcliphist-0.6/Makefile
+--- wmcliphist-0.6.orig/Makefile 2003-06-24 01:35:45.000000000 +0300
++++ wmcliphist-0.6/Makefile 2008-03-12 16:13:34.000000000 +0200
+@@ -1,22 +1,18 @@
+-CC = gcc
+-
+-INCLUDES = `gtk-config --cflags` -I. -Ifoodock -g
+-
+-DESTDIR = "/usr/local/bin"
++CC ?= gcc
++PREFIX = /usr
++INCLUDES = `pkg-config --cflags gtk+-2.0` -I. -Ifoodock
+
+ # for normal use
+-CFLAGS = -Wall -O2 -ansi -pedantic $(INCLUDES)
++CFLAGS += -Wall -ansi -pedantic $(INCLUDES)
+ DEBUG =
+
+ # for debuggind purposes
+ # ISO doesn't support macros with variable number of arguments so -pedantic
+ # must not be used
+-#CFLAGS = -Wall -g -ansi $(INCLUDES) -DFNCALL_DEBUG
++#CFLAGS += -Wall -g -ansi $(INCLUDES) -DFNCALL_DEBUG
+ #DEBUG = debug.o
+
+-
+-LFLAGS = `gtk-config --libs`
+-
++LIBS = `pkg-config --libs gtk+-2.0`
+
+ OBJECTS = wmcliphist.o clipboard.o gui.o rcconfig.o history.o hotkeys.o $(DEBUG)
+ TARGET = wmcliphist
+@@ -27,7 +23,7 @@
+ lclint $(INCLUDES) +posixlib *.c >lclint.log
+
+ wmcliphist: $(OBJECTS) foodock/foodock.o
+- $(CC) $(LFLAGS) -o $@ $(OBJECTS) foodock/foodock.o
++ $(CC) $(LDFLAGS) $(OBJECTS) foodock/foodock.o $(LIBS) -o $@
+
+ wmcliphist.o: wmcliphist.c wmcliphist.h \
+ icon/ico_60x60_black.xpm icon/ico_60x60_gray.xpm \
+@@ -54,4 +50,4 @@
+ @(cd foodock && make clean)
+
+ install:
+- cp wmcliphist $(DESTDIR)
++ cp wmcliphist $(DESTDIR)$(PREFIX)/bin
diff --git a/x11-plugins/wmcliphist/wmcliphist-0.6.ebuild b/x11-plugins/wmcliphist/wmcliphist-0.6.ebuild
new file mode 100644
index 000000000000..93984f902125
--- /dev/null
+++ b/x11-plugins/wmcliphist/wmcliphist-0.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcliphist/wmcliphist-0.6.ebuild,v 1.1 2008/03/12 14:18:11 drac Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Dockable clipboard history application for Window Maker"
+HOMEPAGE="http://linux.nawebu.cz/wmcliphist"
+SRC_URI="http://linux.nawebu.cz/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc ChangeLog README
+ newdoc .${PN}rc ${PN}rc.sample
+}