summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2015-05-25 07:07:24 +0000
committerThomas Kahle <tomka@gentoo.org>2015-05-25 07:07:24 +0000
commit651aacf5b540688a0ae80ecc945339bc4c10345c (patch)
tree41bab924e4698425869995aee5f11ed449d43ebc
parentAdd go-oauth2. (diff)
downloadgentoo-2-651aacf5b540688a0ae80ecc945339bc4c10345c.tar.gz
gentoo-2-651aacf5b540688a0ae80ecc945339bc4c10345c.tar.bz2
gentoo-2-651aacf5b540688a0ae80ecc945339bc4c10345c.zip
Bump to 28.6 (bug 549972)
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 565C32BC)
-rw-r--r--sci-mathematics/gimps/ChangeLog7
-rw-r--r--sci-mathematics/gimps/gimps-28.6.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/sci-mathematics/gimps/ChangeLog b/sci-mathematics/gimps/ChangeLog
index 3550c8365278..45479956717a 100644
--- a/sci-mathematics/gimps/ChangeLog
+++ b/sci-mathematics/gimps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/gimps
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/ChangeLog,v 1.73 2015/03/05 08:32:40 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/ChangeLog,v 1.74 2015/05/25 07:07:24 tomka Exp $
+
+*gimps-28.6 (25 May 2015)
+
+ 25 May 2015; Thomas Kahle <tomka@gentoo.org> +gimps-28.6.ebuild:
+ Bump to 28.6 (bug 549972)
05 Mar 2015; Justin Lecher <jlec@gentoo.org> gimps-27.9-r2.ebuild,
gimps-28.5.ebuild:
diff --git a/sci-mathematics/gimps/gimps-28.6.ebuild b/sci-mathematics/gimps/gimps-28.6.ebuild
new file mode 100644
index 000000000000..c9360cb4a39d
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-28.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/gimps-28.6.ebuild,v 1.1 2015/05/25 07:07:24 tomka Exp $
+
+EAPI=4
+
+inherit pax-utils systemd
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="http://mersenne.org/"
+SRC_URI="
+ amd64? ( ftp://mersenne.org/gimps/p95v${PV/./}.linux64.tar.gz )
+ x86? ( ftp://mersenne.org/gimps/p95v${PV/./}.linux32.tar.gz )"
+
+SLOT="0"
+LICENSE="GIMPS"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+DEPEND=""
+RDEPEND="net-misc/curl"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+src_install() {
+ dodir ${I} /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${I}"
+ fperms a-w "${I}/mprime"
+ fowners root:0 "${I}"
+ fowners root:0 "${I}/mprime"
+
+ dodoc license.txt readme.txt stress.txt whatsnew.txt undoc.txt
+
+ newinitd "${FILESDIR}/${PN}-26.6-r1-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+ echo
+ einfo "You can use \`/etc/init.d/gimps start\` to start a GIMPS client in the"
+ einfo "background at boot. Have a look at /etc/conf.d/gimps and check some"
+ einfo "configuration options."
+ einfo
+ einfo "If you don't want to use the init script to start gimps, remember to"
+ einfo "pass it an additional command line parameter specifying where the data"
+ einfo "files are to be stored, e.g.:"
+ einfo " ${I}/mprime -w/var/lib/gimps"
+ echo
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}