summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-15 22:27:48 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-15 22:27:48 +0000
commit64d952ca3853ff0073fb4b89b6f94c3284d913ca (patch)
treed68b34fc0dfc871c8a0a64233d72f3af92287827
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-64d952ca3853ff0073fb4b89b6f94c3284d913ca.tar.gz
gentoo-2-64d952ca3853ff0073fb4b89b6f94c3284d913ca.tar.bz2
gentoo-2-64d952ca3853ff0073fb4b89b6f94c3284d913ca.zip
Version bump (bug #269920).
(Portage version: 13622-svn/cvs/Linux x86_64)
-rw-r--r--dev-libs/opensc/ChangeLog10
-rw-r--r--dev-libs/opensc/opensc-0.11.8.ebuild53
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-libs/opensc/ChangeLog b/dev-libs/opensc/ChangeLog
index ca5d5323b6c4..f1fb6e483acf 100644
--- a/dev-libs/opensc/ChangeLog
+++ b/dev-libs/opensc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/opensc
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/ChangeLog,v 1.64 2009/04/10 21:51:20 arfrever Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/ChangeLog,v 1.65 2009/05/15 22:27:48 arfrever Exp $
+
+*opensc-0.11.8 (15 May 2009)
+
+ 15 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +opensc-0.11.8.ebuild:
+ Version bump (bug #269920).
10 Apr 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
opensc-0.11.7.ebuild:
diff --git a/dev-libs/opensc/opensc-0.11.8.ebuild b/dev-libs/opensc/opensc-0.11.8.ebuild
new file mode 100644
index 000000000000..3d0522a021c8
--- /dev/null
+++ b/dev-libs/opensc/opensc-0.11.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/opensc-0.11.8.ebuild,v 1.1 2009/05/15 22:27:48 arfrever Exp $
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="SmartCard library and applications"
+HOMEPAGE="http://www.opensc-project.org/opensc/"
+
+SRC_URI="http://www.opensc-project.org/files/${PN}/${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="pcsc-lite openct nsplugin doc"
+
+RDEPEND="dev-libs/openssl
+ sys-libs/zlib
+ openct? ( >=dev-libs/openct-0.5.0 )
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )
+ nsplugin? (
+ app-crypt/pinentry
+ x11-libs/libXt
+ )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nsplugin? ( dev-libs/libassuan )"
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --htmldir="/usr/share/doc/${PF}/html" \
+ $(use_enable openct) \
+ $(use_enable pcsc-lite pcsc) \
+ $(use_enable nsplugin) \
+ $(use_enable doc) \
+ --with-pinentry="/usr/bin/pinentry"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ elog "This package contains security fix for CVE-2009-1603. pkcs11-tool from OpenSC 0.11.7,"
+ elog "when used with third-party PKCS#11 modules, generated RSA keys with incorrect public"
+ elog "exponents, which allows attackers to read the cleartext form of messages that were"
+ elog "intended to be encrypted."
+ elog "See http://www.opensc-project.org/pipermail/opensc-announce/2009-May/000025.html"
+ elog "for details"
+}