summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuval Yaari <yuval@gentoo.org>2008-04-29 05:58:06 +0000
committerYuval Yaari <yuval@gentoo.org>2008-04-29 05:58:06 +0000
commit645acd3bd2b6c0485fbba7abe6c49251b4b3c96f (patch)
treeb4efdb7469bac601be937ae2a79d2456587293d6
parentVersion bump (diff)
downloadgentoo-2-645acd3bd2b6c0485fbba7abe6c49251b4b3c96f.tar.gz
gentoo-2-645acd3bd2b6c0485fbba7abe6c49251b4b3c96f.tar.bz2
gentoo-2-645acd3bd2b6c0485fbba7abe6c49251b4b3c96f.zip
Version bump
(Portage version: 2.1.4.4)
-rw-r--r--dev-perl/Crypt-Cracklib/ChangeLog9
-rw-r--r--dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.2.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-perl/Crypt-Cracklib/ChangeLog b/dev-perl/Crypt-Cracklib/ChangeLog
index 1a20ef2b5785..87fcbfd36cff 100644
--- a/dev-perl/Crypt-Cracklib/ChangeLog
+++ b/dev-perl/Crypt-Cracklib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Crypt-Cracklib
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Crypt-Cracklib/ChangeLog,v 1.15 2007/07/05 14:50:09 armin76 Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Crypt-Cracklib/ChangeLog,v 1.16 2008/04/29 05:58:06 yuval Exp $
+
+*Crypt-Cracklib-1.2 (29 Apr 2008)
+
+ 29 Apr 2008; Yuval Yaari <yuval@gentoo.org> +Crypt-Cracklib-1.2.ebuild:
+ Version bump
05 Jul 2007; Raúl Porcel <armin76@gentoo.org> Crypt-Cracklib-1.1.ebuild:
ia64/x86 stable
diff --git a/dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.2.ebuild b/dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.2.ebuild
new file mode 100644
index 000000000000..43ba67e8bb42
--- /dev/null
+++ b/dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.2.ebuild,v 1.1 2008/04/29 05:58:06 yuval Exp $
+
+inherit perl-module
+
+AUTHOR="DANIEL"
+DESCRIPTION="Perl interface to Alec Muffett's Cracklib"
+HOMEPAGE="http://search.cpan.org/~daniel/${P}/"
+SRC_URI_BASE="mirror://cpan/authors/id/${AUTHOR:0:1}/${AUTHOR:0:2}/${AUTHOR}/"
+SRC_URI="${SRC_URI_BASE}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/cracklib
+ dev-lang/perl"
+
+src_compile() {
+ # this ebuild is very non-standard it seems
+ echo -en "/usr/include\n/usr/lib\n"| perl Makefile.PL
+ emake
+}
+
+src_install() {
+ myinst="DESTDIR=${D}"
+ perl-module_src_install
+}