summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-08-09 16:22:09 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-08-09 16:22:09 +0000
commit641a1956c1ab68ec6cbfa9350ae1ef99ab2372ca (patch)
treec6f3acfb9b75749c9453b77120eb8f56c805dc42
parentUpdate SRC_URI. (diff)
downloadgentoo-2-641a1956c1ab68ec6cbfa9350ae1ef99ab2372ca.tar.gz
gentoo-2-641a1956c1ab68ec6cbfa9350ae1ef99ab2372ca.tar.bz2
gentoo-2-641a1956c1ab68ec6cbfa9350ae1ef99ab2372ca.zip
Bump.
(Portage version: 2.1.1_pre4-r4)
-rw-r--r--sci-chemistry/reduce/ChangeLog8
-rw-r--r--sci-chemistry/reduce/files/digest-reduce-3.02.0607096
-rw-r--r--sci-chemistry/reduce/reduce-3.02.060709.ebuild48
3 files changed, 61 insertions, 1 deletions
diff --git a/sci-chemistry/reduce/ChangeLog b/sci-chemistry/reduce/ChangeLog
index 07fd89c78058..c5bf70b4a505 100644
--- a/sci-chemistry/reduce/ChangeLog
+++ b/sci-chemistry/reduce/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/reduce
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/reduce/ChangeLog,v 1.5 2006/08/09 16:19:38 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/reduce/ChangeLog,v 1.6 2006/08/09 16:22:09 dberkholz Exp $
+
+*reduce-3.02.060709 (09 Aug 2006)
+
+ 09 Aug 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +reduce-3.02.060709.ebuild:
+ Bump.
09 Aug 2006; Donnie Berkholz <dberkholz@gentoo.org>;
reduce-2.21.030604.ebuild:
diff --git a/sci-chemistry/reduce/files/digest-reduce-3.02.060709 b/sci-chemistry/reduce/files/digest-reduce-3.02.060709
new file mode 100644
index 000000000000..316a06e98041
--- /dev/null
+++ b/sci-chemistry/reduce/files/digest-reduce-3.02.060709
@@ -0,0 +1,6 @@
+MD5 b93cb5c561f7badc69f8bcdbfe7e2955 reduce.3.02.060709.source.tgz 1266648
+RMD160 2ea7cca496901fa3e7e4975bcd6fce4fba17ff44 reduce.3.02.060709.source.tgz 1266648
+SHA256 bd134c3e5859a6ec361b1c07405d17c3ffc14cfcb26ebbe439d1cfe07208a275 reduce.3.02.060709.source.tgz 1266648
+MD5 1ec7b357d652fb46c9db3a14cabefcd1 reduce_het_dict.txt.zip 983850
+RMD160 5d1aa16adc4c9e3355b58937dbe8033afa4e8a17 reduce_het_dict.txt.zip 983850
+SHA256 382802ebb89332dd0a0f208ef5ca6b9cd0ddca5b7a5d6bf8226d5aa1f506a384 reduce_het_dict.txt.zip 983850
diff --git a/sci-chemistry/reduce/reduce-3.02.060709.ebuild b/sci-chemistry/reduce/reduce-3.02.060709.ebuild
new file mode 100644
index 000000000000..a036a39f1b42
--- /dev/null
+++ b/sci-chemistry/reduce/reduce-3.02.060709.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/reduce/reduce-3.02.060709.ebuild,v 1.1 2006/08/09 16:22:09 dberkholz Exp $
+
+# If you want to fix the warnings about friend declaration 'foo' declared as
+# a non-template function, see http://gcc.gnu.org/faq.html#friend.
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}.${PV}.source"
+DESCRIPTION="Adds hydrogens to a Protein Data Bank (PDB) molecule structure file"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/reduce.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/reduce/${MY_P}.tgz
+ http://kinemage.biochem.duke.edu/downloads/software/reduce/reduce_het_dict.txt.zip"
+LICENSE="richardson"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ DICT_DIR="/usr/share/reduce"
+ DICT_FILE="reduce_het_dict.txt"
+ DICT_LOC="${DICT_DIR}/${DICT_FILE}"
+
+ unpack ${A}
+ epatch "${FILESDIR}"/${PV}-remove-extra-qualification.patch
+
+ einfo "Fixing location of dictionary"
+ sed -i \
+ -e "s:^\(DICT_HOME.*=\).*:\1 ${DICT_LOC}:g" \
+ "${S}"/*/Makefile
+}
+
+src_compile() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ OPT="${CXXFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ dobin ${S}/reduce_src/reduce
+ insinto ${DICT_DIR}
+ doins ${WORKDIR}/${DICT_FILE}
+}