summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-16 17:36:21 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-16 17:36:21 +0000
commit63efde4ab7385b1f67c8afd1635d1ab7604eb0be (patch)
tree1cbeb6074c1a0e8e6258649ac85a578f00e1751b
parentchanged so it compiles on gentoo 1.3+ (diff)
downloadgentoo-2-63efde4ab7385b1f67c8afd1635d1ab7604eb0be.tar.gz
gentoo-2-63efde4ab7385b1f67c8afd1635d1ab7604eb0be.tar.bz2
gentoo-2-63efde4ab7385b1f67c8afd1635d1ab7604eb0be.zip
gcc-3.1 compile fixes (finally figured this one out)
-rw-r--r--media-video/xine-ui/ChangeLog12
-rw-r--r--media-video/xine-ui/files/digest-xine-ui-0.9.9-r21
-rw-r--r--media-video/xine-ui/xine-ui-0.9.9-r1.ebuild17
-rw-r--r--media-video/xine-ui/xine-ui-0.9.9-r2.ebuild70
4 files changed, 96 insertions, 4 deletions
diff --git a/media-video/xine-ui/ChangeLog b/media-video/xine-ui/ChangeLog
index 0d9fbaaa49b1..f7d0e45de140 100644
--- a/media-video/xine-ui/ChangeLog
+++ b/media-video/xine-ui/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-video/xine-ui
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.10 2002/05/31 13:41:39 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.11 2002/06/16 17:36:21 lostlogic Exp $
+
+*xine-ui-0.9.9-r2 (16 Jun 2002)
+
+ 16 Jun 2002; Brandon Low <lostlogic@gentoo.org> xine-ui-0.9.9-r2.ebuild
+
+ Turn off directfb for real if it isn't in use, and also patch this
+ punk a little bit so that it works with gcc-3.1 (LDFLAGS issue)
+
+ gcc-3.1 users at this time will not be able to use directfb with xine,
+ hopefully this will be resolved in the near future...
*xine-ui-0.9.9-r1 (31 May 2002)
diff --git a/media-video/xine-ui/files/digest-xine-ui-0.9.9-r2 b/media-video/xine-ui/files/digest-xine-ui-0.9.9-r2
new file mode 100644
index 000000000000..eb77e3320db6
--- /dev/null
+++ b/media-video/xine-ui/files/digest-xine-ui-0.9.9-r2
@@ -0,0 +1 @@
+MD5 32bbdc8c44064b601c4a46623fc82562 xine-ui-0.9.9.tar.gz 2624150
diff --git a/media-video/xine-ui/xine-ui-0.9.9-r1.ebuild b/media-video/xine-ui/xine-ui-0.9.9-r1.ebuild
index 50c304f75762..b3c24a492a91 100644
--- a/media-video/xine-ui/xine-ui-0.9.9-r1.ebuild
+++ b/media-video/xine-ui/xine-ui-0.9.9-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Author Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.9-r1.ebuild,v 1.5 2002/05/31 13:41:39 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.9-r1.ebuild,v 1.6 2002/06/16 17:36:21 lostlogic Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Xine is a free gpl-licensed video player for unix-like systems"
@@ -23,20 +23,31 @@ src_unpack() {
unpack ${P}.tar.gz
+ cd ${S}
+
# for some reason upstream skipped on including some files for the
# DirectFB front-end for this.
use directfb && ( \
unpack ${PN}-gentoo-extra.tar.bz2
mv ${WORKDIR}/dfb/* ${S}/src/dfb
+ ) || ( \
+ sed -e "s:dfb::" src/Makefile.in \
+ > src/Makefile.in.hacked
+ mv src/Makefile.in.hacked src/Makefile.in
)
+
+ sed -e "s:LDFLAGS =:LDFLAGS = -L/lib:" src/xitk/Makefile.in \
+ > src/xitk/Makefile.in.hacked
+ mv src/xitk/Makefile.in.hacked src/xitk/Makefile.in
+
}
src_compile() {
# Most of these are not working currently, but are here for completeness
local myconf
- use X || myconf="${myconf} --disable-x11 --disable-xv"
- use nls || myconf="${myconf} --disable-nls"
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use nls || myconf="${myconf} --disable-nls"
./configure --host=${CHOST} \
--prefix=/usr \
diff --git a/media-video/xine-ui/xine-ui-0.9.9-r2.ebuild b/media-video/xine-ui/xine-ui-0.9.9-r2.ebuild
new file mode 100644
index 000000000000..4b2ce6781ded
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.9.9-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.9-r2.ebuild,v 1.1 2002/06/16 17:36:21 lostlogic Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Xine is a free gpl-licensed video player for unix-like systems"
+SRC_URI="http://xine.sourceforge.net/files/xine-ui-${PV}.tar.gz
+ directfb? ( http://www.ibiblio.org/gentoo/distfiles/${PN}-gentoo-extra.tar.bz2 )"
+HOMEPAGE="http://xine.sourceforge.net/"
+
+DEPEND="virtual/glibc
+ media-libs/libpng
+ >=media-libs/xine-lib-${PV}
+ nls? ( sys-devel/gettext )
+ X? ( virtual/x11 )
+ directfb? ( >=dev-libs/DirectFB-0.9.10 )
+ gnome? ( gnome-base/ORBit )"
+
+SLOT="0"
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+
+ cd ${S}
+
+ # for some reason upstream skipped on including some files for the
+ # DirectFB front-end for this.
+ use directfb && ( \
+ unpack ${PN}-gentoo-extra.tar.bz2
+ mv ${WORKDIR}/dfb/* ${S}/src/dfb
+ ) || ( \
+ sed -e "s:dfb::" src/Makefile.in \
+ > src/Makefile.in.hacked
+ mv src/Makefile.in.hacked src/Makefile.in
+ )
+
+ sed -e "s:LDFLAGS =:LDFLAGS = -L/lib:" src/xitk/Makefile.in \
+ > src/xitk/Makefile.in.hacked
+ mv src/xitk/Makefile.in.hacked src/xitk/Makefile.in
+
+}
+
+src_compile() {
+
+ # Most of these are not working currently, but are here for completeness
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}