summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-04-13 05:53:55 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-04-13 05:53:55 +0000
commit63d846f9b19b4d8c414650827b82767484e49a2d (patch)
treef60a1a14de61aa5bf2f56fdaa281c79153879602
parentCleanup. (diff)
downloadgentoo-2-63d846f9b19b4d8c414650827b82767484e49a2d.tar.gz
gentoo-2-63d846f9b19b4d8c414650827b82767484e49a2d.tar.bz2
gentoo-2-63d846f9b19b4d8c414650827b82767484e49a2d.zip
fixing test failure #423049
(Portage version: 2.2.0_alpha172/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
-rw-r--r--dev-haskell/texmath/ChangeLog7
-rw-r--r--dev-haskell/texmath/files/01-texmath-locale.patch19
-rw-r--r--dev-haskell/texmath/texmath-0.5.0.1.ebuild4
-rw-r--r--dev-haskell/texmath/texmath-0.6.0.3.ebuild8
-rw-r--r--dev-haskell/texmath/texmath-0.6.0.4.ebuild8
-rw-r--r--dev-haskell/texmath/texmath-0.6.0.6.ebuild8
-rw-r--r--dev-haskell/texmath/texmath-0.6.1.1.ebuild8
-rw-r--r--dev-haskell/texmath/texmath-0.6.1.3.ebuild6
8 files changed, 56 insertions, 12 deletions
diff --git a/dev-haskell/texmath/ChangeLog b/dev-haskell/texmath/ChangeLog
index d1b4f9a04ee8..f6bbb23fb317 100644
--- a/dev-haskell/texmath/ChangeLog
+++ b/dev-haskell/texmath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/texmath
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/ChangeLog,v 1.7 2013/02/09 19:10:11 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/ChangeLog,v 1.8 2013/04/13 05:53:55 qnikst Exp $
+
+ 13 Apr 2013; <qnikst@gentoo.org> +files/01-texmath-locale.patch,
+ texmath-0.5.0.1.ebuild, texmath-0.6.0.3.ebuild, texmath-0.6.0.4.ebuild,
+ texmath-0.6.0.6.ebuild, texmath-0.6.1.1.ebuild, texmath-0.6.1.3.ebuild:
+ fixing test failure #423049
*texmath-0.6.1.3 (09 Feb 2013)
diff --git a/dev-haskell/texmath/files/01-texmath-locale.patch b/dev-haskell/texmath/files/01-texmath-locale.patch
new file mode 100644
index 000000000000..fb31d98f69a1
--- /dev/null
+++ b/dev-haskell/texmath/files/01-texmath-locale.patch
@@ -0,0 +1,19 @@
+This patch fixes locale as texmath failed for systems with
+non UTF locale
+
+AUTHOR: Alexander Vershilov (qnikst@gentoo.org)
+FIXES: bug #423049 by Diego Elio Pettenò
+diff --git a/texmath.hs b/texmath.hs
+index 373127f..da214bd 100644
+--- a/texmath.hs
++++ b/texmath.hs
+@@ -39,6 +39,9 @@ main = do
+ then fmap show . parseFormula
+ else fmap ppTopElement . inHtml . texMathToMathML dt
+ inp <- getUTF8Contents
++#if MIN_VERSION_base(4,2,0)
++ hSetEncoding stdout utf8
++#endif
+ let (ms, rest) = parseMacroDefinitions inp
+ case (converter $! applyMacros ms rest) of
+ Left err -> hPutStrLn stderr err
diff --git a/dev-haskell/texmath/texmath-0.5.0.1.ebuild b/dev-haskell/texmath/texmath-0.5.0.1.ebuild
index 70a33a808469..103a6e9d14dd 100644
--- a/dev-haskell/texmath/texmath-0.5.0.1.ebuild
+++ b/dev-haskell/texmath/texmath-0.5.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.5.0.1.ebuild,v 1.2 2012/09/12 15:39:15 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.5.0.1.ebuild,v 1.3 2013/04/13 05:53:55 qnikst Exp $
# ebuild generated by hackport 0.2.13
diff --git a/dev-haskell/texmath/texmath-0.6.0.3.ebuild b/dev-haskell/texmath/texmath-0.6.0.3.ebuild
index 3edbbb1bf6c1..a7d8a59cf57f 100644
--- a/dev-haskell/texmath/texmath-0.6.0.3.ebuild
+++ b/dev-haskell/texmath/texmath-0.6.0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.0.3.ebuild,v 1.2 2012/09/12 15:39:15 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.0.3.ebuild,v 1.3 2013/04/13 05:53:55 qnikst Exp $
# ebuild generated by hackport 0.2.13
@@ -30,6 +30,10 @@ RDEPEND=">=dev-haskell/parsec-2[profile?]
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6"
+src_prepare() {
+ epatch "${FILESDIR}/01-${PN}-locale.patch"
+}
+
src_configure() {
cabal_src_configure \
$(cabal_flag cgi) \
diff --git a/dev-haskell/texmath/texmath-0.6.0.4.ebuild b/dev-haskell/texmath/texmath-0.6.0.4.ebuild
index 7e26bc7b4862..97a320047c77 100644
--- a/dev-haskell/texmath/texmath-0.6.0.4.ebuild
+++ b/dev-haskell/texmath/texmath-0.6.0.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.0.4.ebuild,v 1.2 2012/09/12 15:39:15 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.0.4.ebuild,v 1.3 2013/04/13 05:53:55 qnikst Exp $
# ebuild generated by hackport 0.2.13
@@ -30,6 +30,10 @@ RDEPEND=">=dev-haskell/parsec-3[profile?]
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6"
+src_prepare() {
+ epatch "${FILESDIR}/01-${PN}-locale.patch"
+}
+
src_configure() {
cabal_src_configure \
$(cabal_flag cgi) \
diff --git a/dev-haskell/texmath/texmath-0.6.0.6.ebuild b/dev-haskell/texmath/texmath-0.6.0.6.ebuild
index 9bf6d31bf12e..edcbb6825ae3 100644
--- a/dev-haskell/texmath/texmath-0.6.0.6.ebuild
+++ b/dev-haskell/texmath/texmath-0.6.0.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.0.6.ebuild,v 1.2 2012/09/12 15:39:15 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.0.6.ebuild,v 1.3 2013/04/13 05:53:55 qnikst Exp $
EAPI=4
@@ -30,6 +30,10 @@ RDEPEND=">=dev-haskell/parsec-3[profile?]
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6"
+src_prepare() {
+ epatch "${FILESDIR}/01-${PN}-locale.patch"
+}
+
src_configure() {
cabal_src_configure \
$(cabal_flag cgi) \
diff --git a/dev-haskell/texmath/texmath-0.6.1.1.ebuild b/dev-haskell/texmath/texmath-0.6.1.1.ebuild
index 361bccd0893a..7c67066a2eae 100644
--- a/dev-haskell/texmath/texmath-0.6.1.1.ebuild
+++ b/dev-haskell/texmath/texmath-0.6.1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.1.1.ebuild,v 1.1 2012/11/25 06:09:58 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.1.1.ebuild,v 1.2 2013/04/13 05:53:55 qnikst Exp $
EAPI=5
@@ -30,6 +30,10 @@ RDEPEND=">=dev-haskell/parsec-3:=[profile?]
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6"
+src_prepare() {
+ epatch "${FILESDIR}/01-${PN}-locale.patch"
+}
+
src_configure() {
cabal_src_configure \
$(cabal_flag cgi) \
diff --git a/dev-haskell/texmath/texmath-0.6.1.3.ebuild b/dev-haskell/texmath/texmath-0.6.1.3.ebuild
index a020df2f5542..eb80fccf65b6 100644
--- a/dev-haskell/texmath/texmath-0.6.1.3.ebuild
+++ b/dev-haskell/texmath/texmath-0.6.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.1.3.ebuild,v 1.1 2013/02/09 19:10:11 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.1.3.ebuild,v 1.2 2013/04/13 05:53:55 qnikst Exp $
EAPI=5
@@ -30,6 +30,10 @@ RDEPEND=">=dev-haskell/parsec-3:=[profile?]
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6"
+src_prepare() {
+ epatch "${FILESDIR}/01-${PN}-locale.patch"
+}
+
src_configure() {
cabal_src_configure \
$(cabal_flag cgi) \