summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2007-01-23 01:31:21 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2007-01-23 01:31:21 +0000
commit623ae4bcc09bd8d95381b5000858dbfa7b58eb22 (patch)
tree1e5d81452e1cee75004422801cd2d2d9980136c6
parentStable on Alpha + IA64. (diff)
downloadgentoo-2-623ae4bcc09bd8d95381b5000858dbfa7b58eb22.tar.gz
gentoo-2-623ae4bcc09bd8d95381b5000858dbfa7b58eb22.tar.bz2
gentoo-2-623ae4bcc09bd8d95381b5000858dbfa7b58eb22.zip
New release: 1.2.1
(Portage version: 2.1.2)
-rw-r--r--app-accessibility/gok/ChangeLog7
-rw-r--r--app-accessibility/gok/files/digest-gok-1.2.13
-rw-r--r--app-accessibility/gok/gok-1.2.1.ebuild63
3 files changed, 72 insertions, 1 deletions
diff --git a/app-accessibility/gok/ChangeLog b/app-accessibility/gok/ChangeLog
index 5a229ca811f9..e9c062860482 100644
--- a/app-accessibility/gok/ChangeLog
+++ b/app-accessibility/gok/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/gok
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gok/ChangeLog,v 1.83 2007/01/21 22:25:27 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gok/ChangeLog,v 1.84 2007/01/23 01:31:21 leonardop Exp $
+
+*gok-1.2.1 (23 Jan 2007)
+
+ 23 Jan 2007; Leonardo Boshell <leonardop@gentoo.org> +gok-1.2.1.ebuild:
+ New release. Added 'usb' USE flag.
21 Jan 2007; Bryan Østergaard <kloeri@gentoo.org> gok-1.2.0.ebuild:
Stable on IA64, bug 156662.
diff --git a/app-accessibility/gok/files/digest-gok-1.2.1 b/app-accessibility/gok/files/digest-gok-1.2.1
new file mode 100644
index 000000000000..daba94cef179
--- /dev/null
+++ b/app-accessibility/gok/files/digest-gok-1.2.1
@@ -0,0 +1,3 @@
+MD5 cba5eef61ed1a8f6a83fa18015781721 gok-1.2.1.tar.bz2 1212773
+RMD160 53c4e172793d2958656cda4bc273577274ad82e3 gok-1.2.1.tar.bz2 1212773
+SHA256 6230bd5738ab121fe3010fdb4d524598faf4f0869acc644798a9c9ce7be18c24 gok-1.2.1.tar.bz2 1212773
diff --git a/app-accessibility/gok/gok-1.2.1.ebuild b/app-accessibility/gok/gok-1.2.1.ebuild
new file mode 100644
index 000000000000..be4109772abd
--- /dev/null
+++ b/app-accessibility/gok/gok-1.2.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gok/gok-1.2.1.ebuild,v 1.1 2007/01/23 01:31:21 leonardop Exp $
+
+inherit virtualx gnome2
+
+DESCRIPTION="Gnome Onscreen Keyboard"
+HOMEPAGE="http://www.gok.ca/"
+
+LICENSE="LGPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc usb"
+
+RDEPEND=">=dev-libs/glib-2.11
+ >=gnome-base/libgnomeui-2
+ >=gnome-extra/at-spi-1.5.2
+ >=gnome-base/libbonobo-2.5.1
+ >=dev-libs/atk-1.3
+ >=x11-libs/gtk+-2.3.1
+ gnome-base/gail
+ >=x11-libs/libwnck-2.13.5
+ app-accessibility/gnome-speech
+ media-sound/esound
+ >=gnome-base/libglade-2
+ >=gnome-base/gconf-2
+ >=gnome-base/orbit-2
+ usb? ( dev-libs/libusb )
+
+ x11-libs/libXi
+ x11-libs/libX11
+ x11-libs/libSM
+ x11-libs/libICE"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ app-text/scrollkeeper
+ doc? ( >=dev-util/gtk-doc-1 )
+
+ x11-libs/libXt
+ x11-proto/inputproto
+ x11-proto/kbproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+# So it doesn't break when building kbd files
+MAKEOPTS="${MAKEOPTS} -j1"
+
+
+pkg_setup() {
+ # Don't use 'use_enable' for now, because of a bug in gok's configure.in.
+ use usb && G2CONF="--enable-libusb-input"
+}
+
+src_test() {
+ # Remove missing file from the Makefile to fix tests (bug #140265)
+ sed -i -e '/char-frequency.xml.in/d' ${S}/po/Makefile
+
+ addwrite "/root/.gnome2_private"
+ Xmake check || die
+}