summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-06-27 01:39:47 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-06-27 01:39:47 +0000
commit616627d8af7872ca6995c6166d43ebb470d6cffe (patch)
tree132fa247dbb4c67db6cd032a376286754210c431
parentmono.eclass: now exporting LC_ALL=C, added some descriptions (diff)
downloadgentoo-2-616627d8af7872ca6995c6166d43ebb470d6cffe.tar.gz
gentoo-2-616627d8af7872ca6995c6166d43ebb470d6cffe.tar.bz2
gentoo-2-616627d8af7872ca6995c6166d43ebb470d6cffe.zip
dev-lang/mono: LC_ALL=C is now being set in mono.eclass
(Portage version: 2.1.2.7)
-rw-r--r--dev-lang/mono/ChangeLog6
-rw-r--r--dev-lang/mono/mono-1.1.16.1.ebuild8
-rw-r--r--dev-lang/mono/mono-1.2.2.1.ebuild8
-rw-r--r--dev-lang/mono/mono-1.2.3.1.ebuild7
-rw-r--r--dev-lang/mono/mono-1.2.4.ebuild7
5 files changed, 15 insertions, 21 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 3f93c99469ba..46ea714afab2 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.119 2007/06/26 22:48:49 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.120 2007/06/27 01:39:47 jurek Exp $
+
+ 27 Jun 2007; Jurek Bartuszek <jurek@gentoo.org> mono-1.1.16.1.ebuild,
+ mono-1.2.2.1.ebuild, mono-1.2.3.1.ebuild, mono-1.2.4.ebuild:
+ LC_ALL=C is now being set in mono.eclass
26 Jun 2007; Jurek Bartuszek <jurek@gentoo.org>
+files/mono-1.2.4-make-check.patch, mono-1.1.16.1.ebuild,
diff --git a/dev-lang/mono/mono-1.1.16.1.ebuild b/dev-lang/mono/mono-1.1.16.1.ebuild
index bb9472d1f95f..e50763cb18f3 100644
--- a/dev-lang/mono/mono-1.1.16.1.ebuild
+++ b/dev-lang/mono/mono-1.1.16.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.16.1.ebuild,v 1.5 2007/06/26 22:48:49 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.16.1.ebuild,v 1.6 2007/06/27 01:39:47 jurek Exp $
inherit eutils mono flag-o-matic multilib autotools
@@ -77,11 +77,9 @@ src_compile() {
# Force the use of the monolite mcs, to prevent us from trying to build
# with old buggy classlibs/mcs versions. See bug #118062
touch ${S}/mcs/build/deps/use-monolite
- econf ${myconf} || die
- # Force LC_ALL=C and the use of internal mcs/mono to prevent issues with
- # I18N.dll (bug #146424)
- LC_ALL=C emake -j1 EXTERNAL_MCS=false EXTERNAL_MONO=false
+ econf ${myconf} || die
+ emake EXTERNAL_MCS=false EXTERNAL_MONO=false
if [[ "$?" -ne "0" ]]; then
ewarn "If you are using any hardening features such as"
diff --git a/dev-lang/mono/mono-1.2.2.1.ebuild b/dev-lang/mono/mono-1.2.2.1.ebuild
index e458dcc0a5c0..affe8e1d9586 100644
--- a/dev-lang/mono/mono-1.2.2.1.ebuild
+++ b/dev-lang/mono/mono-1.2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.2.1.ebuild,v 1.8 2007/06/26 22:48:49 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.2.1.ebuild,v 1.9 2007/06/27 01:39:47 jurek Exp $
inherit eutils flag-o-matic multilib autotools
@@ -85,11 +85,9 @@ src_compile() {
# Force the use of monolite mcs to prevent issues with classlibs (bug #118062)
touch ${S}/mcs/build/deps/use-monolite
- econf ${myconf} || die "configure failed"
- # Force LC_ALL=C and the use of internal mcs/mono to prevent issues with
- # I18N.dll (bug #146424)
- LC_ALL=C emake EXTERNAL_MCS=false EXTERNAL_MONO=false
+ econf ${myconf} || die "configure failed"
+ emake EXTERNAL_MCS=false EXTERNAL_MONO=false
if [[ "$?" -ne "0" ]]; then
ewarn "If you are using any hardening features such as"
diff --git a/dev-lang/mono/mono-1.2.3.1.ebuild b/dev-lang/mono/mono-1.2.3.1.ebuild
index c7e88b1e2f61..f5ba1b367243 100644
--- a/dev-lang/mono/mono-1.2.3.1.ebuild
+++ b/dev-lang/mono/mono-1.2.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.3.1.ebuild,v 1.5 2007/06/26 22:48:49 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.3.1.ebuild,v 1.6 2007/06/27 01:39:47 jurek Exp $
inherit eutils flag-o-matic multilib autotools
@@ -87,10 +87,7 @@ src_compile() {
touch ${S}/mcs/build/deps/use-monolite
econf ${myconf} || die "configure failed"
-
- # Force LC_ALL=C and the use of internal mcs/mono to prevent issues with
- # I18N.dll (bug #146424)
- LC_ALL=C emake EXTERNAL_MCS=false EXTERNAL_MONO=false
+ emake EXTERNAL_MCS=false EXTERNAL_MONO=false
if [[ "$?" -ne "0" ]]; then
ewarn "If you are using any hardening features such as"
diff --git a/dev-lang/mono/mono-1.2.4.ebuild b/dev-lang/mono/mono-1.2.4.ebuild
index cfc041067abf..42e1ba6033cd 100644
--- a/dev-lang/mono/mono-1.2.4.ebuild
+++ b/dev-lang/mono/mono-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.4.ebuild,v 1.8 2007/06/26 22:48:49 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.4.ebuild,v 1.9 2007/06/27 01:39:47 jurek Exp $
inherit eutils flag-o-matic multilib autotools
@@ -85,10 +85,7 @@ src_compile() {
touch ${S}/mcs/build/deps/use-monolite
econf ${myconf} || die "configure failed"
-
- # Force LC_ALL=C and the use of internal mcs/mono to prevent issues with
- # I18N.dll (bug #146424)
- LC_ALL=C emake EXTERNAL_MCS=false EXTERNAL_MONO=false
+ emake EXTERNAL_MCS=false EXTERNAL_MONO=false
if [[ "$?" -ne "0" ]]; then
ewarn "If you are using any hardening features such as"