summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-08-15 21:06:10 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-08-15 21:06:10 +0000
commit5c94fe155ef164c5cdc13ae58759837cbcf603f6 (patch)
tree9c988ca83feb201a478c8eed3830d32de3382858
parentClean up old revision. (diff)
downloadgentoo-2-5c94fe155ef164c5cdc13ae58759837cbcf603f6.tar.gz
gentoo-2-5c94fe155ef164c5cdc13ae58759837cbcf603f6.tar.bz2
gentoo-2-5c94fe155ef164c5cdc13ae58759837cbcf603f6.zip
Version bump, do not use preserve_old_lib - as one cannot possibly tell what version we're upgrading from which will cause invalid suggestions to run revdep-rebuild and upstream is bumpimg soversion often. Restore ewarn instead.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--app-text/poppler/ChangeLog10
-rw-r--r--app-text/poppler/poppler-0.14.2.ebuild95
2 files changed, 104 insertions, 1 deletions
diff --git a/app-text/poppler/ChangeLog b/app-text/poppler/ChangeLog
index ea89ba4d67a7..9bc942de251c 100644
--- a/app-text/poppler/ChangeLog
+++ b/app-text/poppler/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/poppler
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.250 2010/08/10 21:03:59 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.251 2010/08/15 21:06:10 reavertm Exp $
+
+*poppler-0.14.2 (13 Aug 2010)
+
+ 13 Aug 2010; Maciej Mrozowski <reavertm@gentoo.org>
+ +poppler-0.14.2.ebuild:
+ Version bump, do not use preserve_old_lib - as one cannot possibly tell what
+ version we're upgrading from which will cause invalid suggestions to run
+ revdep-rebuild and upstream is bumpimg soversion often. Restore ewarn instead.
10 Aug 2010; Markos Chandras <hwoarang@gentoo.org> poppler-0.14.1.ebuild:
Stable on amd64 wrt bug #331969
diff --git a/app-text/poppler/poppler-0.14.2.ebuild b/app-text/poppler/poppler-0.14.2.ebuild
new file mode 100644
index 000000000000..6417ffc16d59
--- /dev/null
+++ b/app-text/poppler/poppler-0.14.2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.14.2.ebuild,v 1.1 2010/08/15 21:06:10 reavertm Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="http://poppler.freedesktop.org/"
+SRC_URI="http://poppler.freedesktop.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="+abiword cairo cjk curl cxx debug doc exceptions jpeg jpeg2k +lcms png qt4 +utils +xpdf-headers"
+
+# No test data provided
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=media-libs/fontconfig-2.6.0
+ >=media-libs/freetype-2.3.9
+ sys-libs/zlib
+ abiword? ( dev-libs/libxml2:2 )
+ cairo? (
+ dev-libs/glib:2
+ >=x11-libs/cairo-1.8.4
+ >=x11-libs/gtk+-2.14.0:2
+ )
+ curl? ( net-misc/curl )
+ jpeg? ( virtual/jpeg )
+ jpeg2k? ( media-libs/openjpeg )
+ lcms? ( =media-libs/lcms-1* )
+ png? ( >=media-libs/libpng-1.4 )
+ qt4? (
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ !dev-libs/poppler
+ !dev-libs/poppler-glib
+ !dev-libs/poppler-qt3
+ !dev-libs/poppler-qt4
+ !app-text/poppler-utils
+ cjk? ( >=app-text/poppler-data-0.2.1 )
+"
+
+DOCS=(AUTHORS ChangeLog NEWS README README-XPDF TODO)
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT4_TESTS=OFF
+ -DBUILD_CPP_TESTS=OFF
+ -DWITH_Qt3=OFF
+ -DENABLE_SPLASH=ON
+ -DENABLE_ZLIB=ON
+ $(cmake-utils_use_enable abiword)
+ $(cmake-utils_use_enable curl LIBCURL)
+ $(cmake-utils_use_enable cxx CPP)
+ $(cmake-utils_use_enable jpeg2k LIBOPENJPEG)
+ $(cmake-utils_use_enable lcms)
+ $(cmake-utils_use_enable utils)
+ $(cmake-utils_use_enable xpdf-headers XPDF_HEADERS)
+ $(cmake-utils_use_with cairo)
+ $(cmake-utils_use_with cairo GTK)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with png)
+ $(cmake-utils_use_with qt4)
+ $(cmake-utils_use exceptions USE_EXCEPTIONS)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use cairo && use doc; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/* || die 'failed to install API documentation'
+ fi
+}
+
+pkg_postinst() {
+ ewarn "After upgrading app-text/poppler you may need to reinstall packages"
+ ewarn "linking to it. If you're not a portage-2.2_rc user, you're advised"
+ ewarn "to run revdep-rebuild"
+}