summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2006-04-28 09:13:41 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2006-04-28 09:13:41 +0000
commit5c0e99609d03a632cc215b402987dd5f2e4eacde (patch)
tree2eade3776fdd775c6edc2dc7a37666b0b4a6fa89
parentVersion bump, with fixes for bug #128018 and bug #128303 (diff)
downloadgentoo-2-5c0e99609d03a632cc215b402987dd5f2e4eacde.tar.gz
gentoo-2-5c0e99609d03a632cc215b402987dd5f2e4eacde.tar.bz2
gentoo-2-5c0e99609d03a632cc215b402987dd5f2e4eacde.zip
Spring clean-ups: removed all older unstable versions.
(Portage version: 2.1_pre7-r5)
-rw-r--r--x11-misc/adesklets/ChangeLog8
-rw-r--r--x11-misc/adesklets/adesklets-0.5.0-r1.ebuild106
-rw-r--r--x11-misc/adesklets/adesklets-0.5.1.ebuild104
-rw-r--r--x11-misc/adesklets/adesklets-0.6.0.ebuild106
-rw-r--r--x11-misc/adesklets/files/adesklets-0.5.0-adesklets_installer.patch43
-rw-r--r--x11-misc/adesklets/files/adesklets-0.5.0-ctrlmenu.patch10
-rw-r--r--x11-misc/adesklets/files/digest-adesklets-0.5.0-r13
-rw-r--r--x11-misc/adesklets/files/digest-adesklets-0.5.13
-rw-r--r--x11-misc/adesklets/files/digest-adesklets-0.6.03
9 files changed, 7 insertions, 379 deletions
diff --git a/x11-misc/adesklets/ChangeLog b/x11-misc/adesklets/ChangeLog
index c3665a712dd8..60373565ffa2 100644
--- a/x11-misc/adesklets/ChangeLog
+++ b/x11-misc/adesklets/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/adesklets
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/adesklets/ChangeLog,v 1.23 2006/03/15 08:01:11 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/adesklets/ChangeLog,v 1.24 2006/04/28 09:13:41 s4t4n Exp $
+
+*adesklets-0.6.1 (28 Apr 2006)
+
+ 28 Apr 2006; Michele Noberasco <s4t4n@gentoo.org> +adesklets-0.6.1.ebuild:
+ Version bump. Fixes bugs #128018 and 128303. Wiped out all older unstable
+ releases, since this one adds necessary stuff to RDEPEND.
*adesklets-0.6.0 (15 Mar 2006)
diff --git a/x11-misc/adesklets/adesklets-0.5.0-r1.ebuild b/x11-misc/adesklets/adesklets-0.5.0-r1.ebuild
deleted file mode 100644
index e5072ab79305..000000000000
--- a/x11-misc/adesklets/adesklets-0.5.0-r1.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/adesklets/adesklets-0.5.0-r1.ebuild,v 1.1 2006/02/24 10:23:15 s4t4n Exp $
-
-inherit eutils
-
-DESCRIPTION="An interactive Imlib2 console for the X Window system"
-HOMEPAGE="http://adesklets.sf.net/"
-SRC_URI="mirror://sourceforge/adesklets/${P}.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="X python debug ctrlmenu"
-
-RDEPEND="X? ( || ( (
- x11-libs/libX11
- x11-apps/xprop
- x11-libs/libXt )
- virtual/x11 ) )"
-
-DEPEND=">=media-libs/imlib2-1.2.0-r2
- X? ( || ( x11-proto/xproto virtual/x11 ) )
- python? ( >=dev-lang/python-2.3.4-r1 )"
-
-src_unpack()
-{
- unpack ${A}
- cd ${S}
-
- #Fix for bug #123402: adesklets_installer
- epatch ${FILESDIR}/${P}-${PN}_installer.patch
-
- #Fix for bug #123538: control con context menu fix
- epatch ${FILESDIR}/${P}-ctrlmenu.patch
-
- # when performing minor changes to src/adesklets.c or src/commands.c,
- # touching these files will avoid unneeded processing
- touch scripting/enums scripting/prototypes
-}
-
-src_compile()
-{
- local myconf=""
-
- use X || myconf="--without-x"
- use python || myconf="${myconf} --without-python-support"
- myconf="${myconf} $(use_enable debug)"
- use ctrlmenu && myconf="--enable-control-on-context-menu"
-
- econf ${myconf} || die
- emake || die
-}
-
-src_install()
-{
- dodir usr/share/info
- dodir usr/share/man/man1
- make DESTDIR=${D} install || die
- doinfo doc/*.info || die "info page installation failed"
- doman doc/*.1 || die "man page installation failed"
- dodoc ChangeLog NEWS TODO AUTHORS
- use debug &&
- {
- echo 'ADESKLETS_LOG="/tmp/adesklets_log"' > 70adesklets
- doenvd 70adesklets
- }
-}
-
-pkg_postinst()
-{
- use X ||
- {
- ewarn "You did not install the X Window support for ${P}"
- ewarn "If you intend to use it to display desklets, this"
- ewarn "is a mistake."
- echo
- ewarn "Type USE=\"X\" emerge adesklets to correct this."
- echo
- einfo "Please also note that if it is what you intended"
- einfo "to do, you need also to install imlib2 without"
- einfo "X support to effectively remove all dependencies."
- echo
- }
-
- use python ||
- {
- ewarn "You did not install the python bindings for ${P}"
- ewarn "If you intend to use it to display desklets, this"
- ewarn "is most probably an error."
- echo
- ewarn "Type USE=\"python\" emerge adesklets to correct this."
- echo
- }
-
- use debug &&
- {
- ewarn "You installed a debug build. Make sure you do:"
- echo
- ewarn "source /etc/profile"
- echo
- ewarn "If you want to use adesklets from your already"
- ewarn "opened sessions. The sessions log are automatically"
- ewarn "saved to /tmp/adesklets_log.pid*."
- }
-}
diff --git a/x11-misc/adesklets/adesklets-0.5.1.ebuild b/x11-misc/adesklets/adesklets-0.5.1.ebuild
deleted file mode 100644
index 5079e3d1b3c7..000000000000
--- a/x11-misc/adesklets/adesklets-0.5.1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/adesklets/adesklets-0.5.1.ebuild,v 1.1 2006/03/06 12:31:35 s4t4n Exp $
-
-inherit eutils
-
-DESCRIPTION="An interactive Imlib2 console for the X Window system"
-HOMEPAGE="http://adesklets.sf.net/"
-SRC_URI="mirror://sourceforge/adesklets/${P}.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="X python debug ctrlmenu"
-
-RDEPEND="X? ( || ( (
- x11-libs/libX11
- x11-apps/xprop
- x11-libs/libXt )
- virtual/x11 ) )"
-
-DEPEND=">=media-libs/imlib2-1.2.0-r2
- X? ( || ( x11-proto/xproto virtual/x11 ) )
- python? ( >=dev-lang/python-2.3.4-r1 )"
-
-src_unpack()
-{
- unpack ${A}
- cd ${S}
-
- #Fix for bug #123538: control context menu fix
- epatch ${FILESDIR}/${PN}-ctrlmenu.patch
-
- # when performing minor changes to src/adesklets.c or src/commands.c,
- # touching these files will avoid unneeded processing
- touch scripting/enums scripting/prototypes \
- scripting/python/adesklets/commands.py
-}
-
-src_compile()
-{
- local myconf=""
-
- use X || myconf="--without-x"
- use python || myconf="${myconf} --without-python-support"
- myconf="${myconf} $(use_enable debug)"
- use ctrlmenu && myconf="--enable-control-on-context-menu"
-
- econf ${myconf} || die
- emake || die
-}
-
-src_install()
-{
- dodir usr/share/info
- dodir usr/share/man/man1
- make DESTDIR=${D} install || die
- doinfo doc/*.info || die "info page installation failed"
- doman doc/*.1 || die "man page installation failed"
- dodoc ChangeLog NEWS TODO AUTHORS
- use debug &&
- {
- echo 'ADESKLETS_LOG="/tmp/adesklets_log"' > 70adesklets
- doenvd 70adesklets
- }
-}
-
-pkg_postinst()
-{
- use X ||
- {
- ewarn "You did not install the X Window support for ${P}"
- ewarn "If you intend to use it to display desklets, this"
- ewarn "is a mistake."
- echo
- ewarn "Type USE=\"X\" emerge adesklets to correct this."
- echo
- einfo "Please also note that if it is what you intended"
- einfo "to do, you need also to install imlib2 without"
- einfo "X support to effectively remove all dependencies."
- echo
- }
-
- use python ||
- {
- ewarn "You did not install the python bindings for ${P}"
- ewarn "If you intend to use it to display desklets, this"
- ewarn "is most probably an error."
- echo
- ewarn "Type USE=\"python\" emerge adesklets to correct this."
- echo
- }
-
- use debug &&
- {
- ewarn "You installed a debug build. Make sure you do:"
- echo
- ewarn "source /etc/profile"
- echo
- ewarn "If you want to use adesklets from your already"
- ewarn "opened sessions. The sessions log are automatically"
- ewarn "saved to /tmp/adesklets_log.pid*."
- }
-}
diff --git a/x11-misc/adesklets/adesklets-0.6.0.ebuild b/x11-misc/adesklets/adesklets-0.6.0.ebuild
deleted file mode 100644
index 4c0d3dbc8588..000000000000
--- a/x11-misc/adesklets/adesklets-0.6.0.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/adesklets/adesklets-0.6.0.ebuild,v 1.1 2006/03/15 08:01:11 s4t4n Exp $
-
-inherit eutils
-
-DESCRIPTION="An interactive Imlib2 console for the X Window system"
-HOMEPAGE="http://adesklets.sf.net/"
-SRC_URI="mirror://sourceforge/adesklets/${P}.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="X python perl debug ctrlmenu"
-
-RDEPEND="X? ( || ( (
- x11-libs/libX11
- x11-apps/xprop
- x11-libs/libXt )
- virtual/x11 ) )"
-
-DEPEND=">=media-libs/imlib2-1.2.0-r2
- X? ( || ( x11-proto/xproto virtual/x11 ) )
- python? ( >=dev-lang/python-2.3.4-r1 )"
-
-src_unpack()
-{
- unpack ${A}
- cd ${S}
-
- #Fix for bug #123538: control context menu fix
- epatch ${FILESDIR}/${PN}-ctrlmenu.patch
-
- # when performing minor changes to src/adesklets.c or src/commands.c,
- # touching these files will avoid unneeded processing
- touch scripting/enums scripting/prototypes \
- scripting/python/adesklets/commands.py \
- scripting/perl/adesklets.pm
-}
-
-src_compile()
-{
- local myconf=""
-
- use X || myconf="--without-x"
- use python || myconf="${myconf} --without-python-support"
- use perl || myconf="${myconf} --without-perl-support"
- myconf="${myconf} $(use_enable debug)"
- use ctrlmenu && myconf="--enable-control-on-context-menu"
-
- econf ${myconf} || die
- emake || die
-}
-
-src_install()
-{
- dodir usr/share/info
- dodir usr/share/man/man1
- make DESTDIR=${D} install || die
- doinfo doc/*.info || die "info page installation failed"
- doman doc/*.1 || die "man page installation failed"
- dodoc ChangeLog NEWS TODO AUTHORS
- use debug &&
- {
- echo 'ADESKLETS_LOG="/tmp/adesklets_log"' > 70adesklets
- doenvd 70adesklets
- }
-}
-
-pkg_postinst()
-{
- use X ||
- {
- ewarn "You did not install the X Window support for ${P}"
- ewarn "If you intend to use it to display desklets, this"
- ewarn "is a mistake."
- echo
- ewarn "Type USE=\"X\" emerge adesklets to correct this."
- echo
- einfo "Please also note that if it is what you intended"
- einfo "to do, you need also to install imlib2 without"
- einfo "X support to effectively remove all dependencies."
- echo
- }
-
- use python ||
- {
- ewarn "You did not install the python bindings for ${P}"
- ewarn "If you intend to use it to display desklets, this"
- ewarn "is most probably an error."
- echo
- ewarn "Type USE=\"python\" emerge adesklets to correct this."
- echo
- }
-
- use debug &&
- {
- ewarn "You installed a debug build. Make sure you do:"
- echo
- ewarn "source /etc/profile"
- echo
- ewarn "If you want to use adesklets from your already"
- ewarn "opened sessions. The sessions log are automatically"
- ewarn "saved to /tmp/adesklets_log.pid*."
- }
-}
diff --git a/x11-misc/adesklets/files/adesklets-0.5.0-adesklets_installer.patch b/x11-misc/adesklets/files/adesklets-0.5.0-adesklets_installer.patch
deleted file mode 100644
index fc706a75165b..000000000000
--- a/x11-misc/adesklets/files/adesklets-0.5.0-adesklets_installer.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- a/utils/adesklets_installer
-+++ b/utils/adesklets_installer
-@@ -470,7 +470,7 @@ try:
- self.lines = data.splitlines()
- else:
- self.lines = data
-- for i, line in zip(xrange(len(self.lines)), self.lines):
-+ for i, line in zip(range(len(self.lines)), self.lines):
- self.pad.addstr(i, 0, line)
- self.scroll(0)
- else:
-@@ -496,9 +496,10 @@ try:
- new = 0
- elif new >= len(self.lines):
- new = len(self.lines)-1
--
-- self.pad.addstr(self.cur, 0, self.lines[self.cur])
-- self.pad.addstr(new, 0, self.lines[new], self.hl)
-+
-+ if len(self.lines)>1:
-+ self.pad.addstr(self.cur, 0, self.lines[self.cur])
-+ self.pad.addstr(new, 0, self.lines[new], self.hl)
- self.cur = new
- self.refresh()
-
-@@ -620,14 +621,14 @@ warranty; not even for MERCHANTABILITY o
- opts, args= p.parse_args()
-
- # Just instanciate the right GUI to start up the application
-- # In orger, we try to instanciate the Tk, curses and raw
-+ # In order, we try to instanciate the Tk, curses and raw
- # interface, falling to the next in case of unavailability or
- # initialization errors
-- #
-+ #
- select = opts.raw + opts.curses + opts.Tk
- for ui in ('Tk', 'curses', 'raw'):
- if (globals().has_key('%sGUI' % ui) and
-- getattr(opts, ui) or select==0 or ui=='raw'):
-+ (getattr(opts, ui) or select==0 or ui=='raw')):
- if globals()['%sGUI' % ui](): break
-
-
diff --git a/x11-misc/adesklets/files/adesklets-0.5.0-ctrlmenu.patch b/x11-misc/adesklets/files/adesklets-0.5.0-ctrlmenu.patch
deleted file mode 100644
index a5913865bb95..000000000000
--- a/x11-misc/adesklets/files/adesklets-0.5.0-ctrlmenu.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/adesklets.c.old 2006-02-14 01:49:01.000000000 -0500
-+++ src/adesklets.c 2006-02-14 01:49:54.000000000 -0500
-@@ -2910,6 +2910,7 @@
- #ifdef CONTROL_ON_CONTEXT_MENU
- } else {
-+ XUngrabPointer(adesklets.display, ev.xbutton.time);
- ev.xbutton.window = adesklets.root ;
- XSendEvent(adesklets.display, ev.xbutton.window,
- False, ButtonPressMask, &ev);
- debug("menu call redirected to root\n");
diff --git a/x11-misc/adesklets/files/digest-adesklets-0.5.0-r1 b/x11-misc/adesklets/files/digest-adesklets-0.5.0-r1
deleted file mode 100644
index 3f1117dfbc86..000000000000
--- a/x11-misc/adesklets/files/digest-adesklets-0.5.0-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 a618289ea5c1512ec41085ac234341f3 adesklets-0.5.0.tar.bz2 367220
-RMD160 3ece06cd76567af3677006c881140bb731864322 adesklets-0.5.0.tar.bz2 367220
-SHA256 fa28f0f0ecb2b4b44b5e81c6a2e7ecc8151a4ca928ff4e3361535e28e0265294 adesklets-0.5.0.tar.bz2 367220
diff --git a/x11-misc/adesklets/files/digest-adesklets-0.5.1 b/x11-misc/adesklets/files/digest-adesklets-0.5.1
deleted file mode 100644
index b4c19c3fb1a3..000000000000
--- a/x11-misc/adesklets/files/digest-adesklets-0.5.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 325a8d2b9a3d421e8d7b270ed0b80cee adesklets-0.5.1.tar.bz2 368575
-RMD160 745ef0d1f03cfcac691ff86465d175651917c5f4 adesklets-0.5.1.tar.bz2 368575
-SHA256 47124e3633af480561a53bcc133f013b4545f4553011756767f102144cbe8021 adesklets-0.5.1.tar.bz2 368575
diff --git a/x11-misc/adesklets/files/digest-adesklets-0.6.0 b/x11-misc/adesklets/files/digest-adesklets-0.6.0
deleted file mode 100644
index de4e026472d8..000000000000
--- a/x11-misc/adesklets/files/digest-adesklets-0.6.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 222eee5225fef302c4cf839cc09c267d adesklets-0.6.0.tar.bz2 383321
-RMD160 80c857c010a7c409867ee2e339301ec708f6efbc adesklets-0.6.0.tar.bz2 383321
-SHA256 e3a059ca1770bb927bbf9ed822f0122e2a8c21da63c52a894ad3517cd5f28cb5 adesklets-0.6.0.tar.bz2 383321