summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-10-20 00:51:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-10-20 00:51:19 +0000
commit5c0e5ac665392fa766e36407f86360e5ce2a73b4 (patch)
tree6c50b0fc17ca88f5dc0874b2376d9370dad17d69
parentVersion bump, removed old version. (diff)
downloadgentoo-2-5c0e5ac665392fa766e36407f86360e5ce2a73b4.tar.gz
gentoo-2-5c0e5ac665392fa766e36407f86360e5ce2a73b4.tar.bz2
gentoo-2-5c0e5ac665392fa766e36407f86360e5ce2a73b4.zip
EAPI=2; fix parallel build
(Portage version: 2.1.6.13/cvs/Linux i686)
-rw-r--r--games-emulation/dgen-sdl/ChangeLog7
-rw-r--r--games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild28
2 files changed, 20 insertions, 15 deletions
diff --git a/games-emulation/dgen-sdl/ChangeLog b/games-emulation/dgen-sdl/ChangeLog
index 20f1cda10ad8..4ef532c00468 100644
--- a/games-emulation/dgen-sdl/ChangeLog
+++ b/games-emulation/dgen-sdl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/dgen-sdl
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/ChangeLog,v 1.11 2006/10/05 04:56:02 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/ChangeLog,v 1.12 2009/10/20 00:51:19 mr_bones_ Exp $
+
+ 20 Oct 2009; Michael Sterrett <mr_bones_@gentoo.org> dgen-sdl-1.23.ebuild:
+ EAPI=2; fix parallel build
05 Oct 2006; Michael Sterrett <mr_bones_@gentoo.org>
files/dgen-sdl-1.23-gcc34.patch, +files/dgen-sdl-1.23-gcc4.patch,
diff --git a/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild b/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
index d4c48f8288c9..b7b109d45de8 100644
--- a/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
+++ b/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild,v 1.12 2006/10/05 04:56:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild,v 1.13 2009/10/20 00:51:19 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="A Linux/SDL-Port of the famous DGen MegaDrive/Genesis-Emulator"
-HOMEPAGE="http://www.pknet.com/~joe/dgen-sdl.html"
-SRC_URI="http://www.pknet.com/~joe/${P}.tar.gz"
+HOMEPAGE="http://tamentis.com/projects/dgen/"
+SRC_URI="http://tamentis.com/projects/dgen/files/${P}.tar.gz"
LICENSE="dgen-sdl"
SLOT="0"
@@ -19,21 +20,22 @@ DEPEND="${RDEPEND}
X? ( x11-misc/imake )
dev-lang/nasm"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+PATCHES=(
# gcc34.patch for bug #116113
# gcc4.patch for bug #133203
- epatch \
- "${FILESDIR}/${P}-gcc34.patch" \
- "${FILESDIR}/${P}-gcc4.patch"
-}
+ "${FILESDIR}/${P}-gcc34.patch"
+ "${FILESDIR}/${P}-gcc4.patch"
+)
-src_compile() {
+src_configure() {
egamesconf \
$(use_with opengl) \
$(use_with X x) \
- $(use_with mmx) || die
+ $(use_with mmx)
+}
+
+src_compile() {
+ emake -C musa m68kops.h || die
emake || die "emake failed"
}