summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-10-05 19:28:10 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-10-05 19:28:10 +0000
commit5be1e585ef75db9b200e00a427ecc0da1e3b38f4 (patch)
treec0f23ddc0c13be7d07eb74b3b0ea8a7801740e90
parentx86 stable, bug #338990 (diff)
downloadgentoo-2-5be1e585ef75db9b200e00a427ecc0da1e3b38f4.tar.gz
gentoo-2-5be1e585ef75db9b200e00a427ecc0da1e3b38f4.tar.bz2
gentoo-2-5be1e585ef75db9b200e00a427ecc0da1e3b38f4.zip
Version bump 0.8.0p1 for bug 339863.
(Portage version: 2.1.9.13/cvs/Linux x86_64)
-rw-r--r--dev-util/buildbot/ChangeLog7
-rw-r--r--dev-util/buildbot/buildbot-0.8.0_p1.ebuild98
2 files changed, 104 insertions, 1 deletions
diff --git a/dev-util/buildbot/ChangeLog b/dev-util/buildbot/ChangeLog
index 394b7c67da9c..403fe44b5255 100644
--- a/dev-util/buildbot/ChangeLog
+++ b/dev-util/buildbot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/buildbot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.67 2010/09/10 14:06:05 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.68 2010/10/05 19:28:10 djc Exp $
+
+*buildbot-0.8.0_p1 (05 Oct 2010)
+
+ 05 Oct 2010; Dirkjan Ochtman <djc@gentoo.org> +buildbot-0.8.0_p1.ebuild:
+ Version bump 0.8.0p1 for bug 339863.
10 Sep 2010; Tobias Klausmann <klausman@gentoo.org> buildbot-0.8.0.ebuild:
Stable on alpha, bug #325899
diff --git a/dev-util/buildbot/buildbot-0.8.0_p1.ebuild b/dev-util/buildbot/buildbot-0.8.0_p1.ebuild
new file mode 100644
index 000000000000..90a9d98d9c97
--- /dev/null
+++ b/dev-util/buildbot/buildbot-0.8.0_p1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.8.0_p1.ebuild,v 1.1 2010/10/05 19:28:10 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="trial"
+DISTUTILS_DISABLE_TEST_DEPENDENCY="1"
+
+inherit distutils eutils
+
+MY_PV="${PV/_p/p}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A Python system to automate the compile/test cycle to validate code changes"
+HOMEPAGE="http://buildbot.net/ http://pypi.python.org/pypi/buildbot"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc irc mail manhole test"
+
+# sqlite3 module of Python 2.5 is not supported.
+RDEPEND="dev-python/jinja
+ || ( dev-python/pysqlite:2 >=dev-lang/python-2.6[sqlite] )
+ >=dev-python/twisted-2.0.1
+ dev-python/twisted-web
+ dev-python/twisted-mail
+ irc? ( dev-python/twisted-words )
+ mail? ( dev-python/twisted-mail )
+ manhole? ( dev-python/twisted-conch )"
+DEPEND="${DEPEND}
+ doc? ( dev-python/epydoc )
+ test? ( dev-python/twisted-mail
+ dev-python/twisted-web
+ dev-python/twisted-words )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewuser buildbot
+ python_pkg_setup
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ PYTHONPATH="." "$(PYTHON -f)" docs/epyrun -o docs/reference || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ #doinfo docs/buildbot.info # not in 0.8.0p1
+ dohtml -r docs/images
+
+ insinto /usr/share/doc/${PF}
+ doins -r contrib
+ doins -r docs/examples
+
+ if use doc; then
+ doins -r docs/reference || die "doins failed"
+ fi
+
+ newconfd "${FILESDIR}/buildslave.confd" buildslave || die "newconfd failed"
+ newinitd "${FILESDIR}/buildbot.initd-r1" buildslave || die "newinitd failed"
+ newconfd "${FILESDIR}/buildmaster.confd" buildmaster || die "newconfd failed"
+ newinitd "${FILESDIR}/buildbot.initd-r1" buildmaster || die "newinitd failed"
+
+ # Make it print the right names when you start/stop the script.
+ sed -e "s/@buildbot@/buildslave/" -i "${ED}etc/init.d/buildslave" || die "sed buildslave failed"
+ sed -e "s/@buildbot@/buildmaster/" -i "${ED}etc/init.d/buildmaster" || die "sed buildmaster failed"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog 'The "buildbot" user and the "buildmaster" and "buildslave" init'
+ elog "scripts were added to support starting buildbot through gentoo's"
+ elog "init system. To use this set up your build master or build slave"
+ elog "following the buildbot documentation, make sure the resulting"
+ elog 'directories are owned by the "buildbot" user and point'
+ elog "${ROOT}etc/conf.d/buildmaster or ${ROOT}etc/conf.d/buildslave"
+ elog "at the right location. The scripts can run as a different user"
+ elog "if desired. If you need to run more than one master or slave"
+ elog "just copy the scripts."
+ elog ""
+ elog "Upstream recommends the following when upgrading:"
+ elog "Each time you install a new version of Buildbot, you should run the new"
+ elog "'buildbot upgrade-master' command on each of your pre-existing buildmasters."
+ elog "This will add files and fix (or at least detect) incompatibilities between"
+ elog "your old config and the new code."
+}