summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-06-07 17:29:26 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-06-07 17:29:26 +0000
commit5b25b3099a2667eec9dc13a9d5c0db354effa5bd (patch)
treec2e1db25e4ed9d7629c8a1fc2df2144b289a9b13
parentRevert adding dependency on xmlto, configure.ac checks for it but it is reall... (diff)
downloadgentoo-2-5b25b3099a2667eec9dc13a9d5c0db354effa5bd.tar.gz
gentoo-2-5b25b3099a2667eec9dc13a9d5c0db354effa5bd.tar.bz2
gentoo-2-5b25b3099a2667eec9dc13a9d5c0db354effa5bd.zip
version 5.44* recalled by upstream
(Portage version: 2.2_rc33/cvs/Linux x86_64)
-rw-r--r--dev-tcltk/expect/ChangeLog5
-rw-r--r--dev-tcltk/expect/expect-5.44.1.ebuild109
2 files changed, 4 insertions, 110 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index 09996ccdedbd..54032170fe36 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-tcltk/expect
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.53 2009/06/07 17:01:04 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.54 2009/06/07 17:29:26 mescalinum Exp $
+
+ 07 Jun 2009; Federico Ferri <mescalinum@gentoo.org> -expect-5.44.1.ebuild:
+ version 5.44* recalled by upstream
07 Jun 2009; Federico Ferri <mescalinum@gentoo.org>
+files/expect-5.42.1-missing-includes.patch, +expect-5.42.1-r2.ebuild:
diff --git a/dev-tcltk/expect/expect-5.44.1.ebuild b/dev-tcltk/expect/expect-5.44.1.ebuild
deleted file mode 100644
index 89b1aa543f61..000000000000
--- a/dev-tcltk/expect/expect-5.44.1.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.44.1.ebuild,v 1.4 2009/05/16 13:11:21 flameeyes Exp $
-
-WANT_AUTOCONF="2.5"
-inherit autotools eutils
-
-DESCRIPTION="tool for automating interactive applications"
-HOMEPAGE="http://expect.nist.gov/"
-SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="X doc"
-
-# We need dejagnu for src_test, but dejagnu needs expect
-# to compile/run, so we cant add dejagnu to DEPEND :/
-DEPEND=">=dev-lang/tcl-8.2
- >=dev-lang/tk-8.2"
-RDEPEND="${DEPEND}"
-
-RESTRICT="test"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- sed -i 's#/usr/local/bin#/usr/bin#' expect.man
- sed -i 's#/usr/local/bin#/usr/bin#' expectk.man
- #stops any example scripts being installed by default
- sed -i \
- -e '/^install:/s/install-libraries //' \
- -e 's/^SCRIPTS_MANPAGES = /_&/' \
- Makefile.in
-
- #they forgot to include expect.m4 (now it's in expect cvs)
- cp "${FILESDIR}/expect.m4" .
- #configure broken for testsuite
- sed -i -e 's/^AC_CONFIG_SUBDIRS(testsuite)$//' configure.in
- #fixes "TCL_REG_BOSONLY undeclared" error due to a change in tcl8.5
- sed -i -e 's/^#include "tcl.h"/#include "tclInt.h"/' exp_inter.c
- #slacky destdir support in Makefile
- epatch "${FILESDIR}/${P}-destdir.patch"
-
- epatch "${FILESDIR}/${P}-gfbsd.patch"
-
- eautoconf
-}
-
-src_compile() {
- local myconf
- local tclv
- local tkv
- # Find the version of tcl/tk that has headers installed.
- # This will be the most recently merged, not necessarily the highest
- # version number.
- tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
- #tkv isn't really needed, included for symmetry and the future
- #tkv=$(grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
-
- #configure needs to find the files tclConfig.sh and tclInt.h
- myconf="--with-tcl=/usr/$(get_libdir) --with-tclinclude=/usr/$(get_libdir)/tcl${tclv}/include/generic"
-
- if use X ; then
- #--with-x is enabled by default
- #configure needs to find the file tkConfig.sh and tk.h
- #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
- myconf="$myconf --with-tk=/usr/$(get_libdir)"
- else
- #configure knows that tk depends on X so just disable X
- myconf="$myconf --without-x"
- fi
-
- econf $myconf --enable-shared || die "econf failed"
- emake || die "emake failed"
-}
-
-src_test() {
- # we need dejagnu to do tests ... but dejagnu needs
- # expect ... so don't do tests unless we have dejagnu
- type -p runtest || return 0
- make check || die "make check failed"
-}
-
-src_install() {
- dodir /usr/$(get_libdir)
- make install DESTDIR="${D}" || die "make install failed"
-
- dodoc ChangeLog FAQ HISTORY NEWS README
-
- local static_lib="lib${NON_MICRO_V/-/}.a"
- rm "${D}"/usr/$(get_libdir)/${NON_MICRO_V/-/}/${static_lib}
-
- #install examples if 'doc' is set
- if use doc ; then
- docinto examples
- local scripts=$(make -qp | \
- sed -e 's/^SCRIPTS = //' -et -ed | head -n1)
- exeinto /usr/share/doc/${PF}/examples
- doexe ${scripts}
- local scripts_manpages=$(make -qp | \
- sed -e 's/^_SCRIPTS_MANPAGES = //' -et -ed | head -n1)
- for m in ${scripts_manpages}; do
- dodoc example/${m}.man
- done
- dodoc example/README
- fi
-}