summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-01-01 00:16:44 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-01-01 00:16:44 +0000
commit5a09353e2e1a1b1b2aec870502a90737fe2cd15b (patch)
tree8b434e4f1871d35c8b7fff926feff8a258eae29c
parentVersion Bump (diff)
downloadgentoo-2-5a09353e2e1a1b1b2aec870502a90737fe2cd15b.tar.gz
gentoo-2-5a09353e2e1a1b1b2aec870502a90737fe2cd15b.tar.bz2
gentoo-2-5a09353e2e1a1b1b2aec870502a90737fe2cd15b.zip
New upstream version.
(Portage version: 2.1_pre2)
-rw-r--r--dev-lisp/cl-tbnl/ChangeLog9
-rw-r--r--dev-lisp/cl-tbnl/Manifest12
-rw-r--r--dev-lisp/cl-tbnl/cl-tbnl-0.9.2.ebuild36
-rw-r--r--dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.9.21
4 files changed, 46 insertions, 12 deletions
diff --git a/dev-lisp/cl-tbnl/ChangeLog b/dev-lisp/cl-tbnl/ChangeLog
index 9cafb0171080..dcddc6ee5f8a 100644
--- a/dev-lisp/cl-tbnl/ChangeLog
+++ b/dev-lisp/cl-tbnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-tbnl
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.24 2005/12/30 21:36:00 mkennedy Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.25 2006/01/01 00:16:44 mkennedy Exp $
+
+*cl-tbnl-0.9.2 (01 Jan 2006)
+
+ 01 Jan 2006; Matthew Kennedy <mkennedy@gentoo.org> +cl-tbnl-0.9.2.ebuild:
+ New upstream version.
*cl-tbnl-0.9.1 (30 Dec 2005)
diff --git a/dev-lisp/cl-tbnl/Manifest b/dev-lisp/cl-tbnl/Manifest
index 3441fb4bc74d..76f93f55a185 100644
--- a/dev-lisp/cl-tbnl/Manifest
+++ b/dev-lisp/cl-tbnl/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 2299bf4c7c41af89fadacee685cf58b5 ChangeLog 4239
MD5 e4051610958787d2ff87c2ebdcbe773c cl-tbnl-0.8.9.ebuild 1012
MD5 cc7879f6a10aa99b3da2bff3650ae39d cl-tbnl-0.9.1.ebuild 962
+MD5 cc7879f6a10aa99b3da2bff3650ae39d cl-tbnl-0.9.2.ebuild 962
MD5 b7377fe929b0307f2d7b4c8cf44965f0 files/digest-cl-tbnl-0.8.9 66
MD5 054e9aa5186f7d89b2d17137fe7bd5dd files/digest-cl-tbnl-0.9.1 66
+MD5 14521d0851a5473b12fd759b433cee74 files/digest-cl-tbnl-0.9.2 66
MD5 a2199253dbe57d398c785af8f7744485 metadata.xml 804
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDtahMyiNZaEAZA+ARAmDyAJ47FfgrEPuoqjrjsvD7VM24xbNCcwCeN/7N
-1tscd2/IQXJuvc7X1ZQ45xc=
-=KC3V
------END PGP SIGNATURE-----
diff --git a/dev-lisp/cl-tbnl/cl-tbnl-0.9.2.ebuild b/dev-lisp/cl-tbnl/cl-tbnl-0.9.2.ebuild
new file mode 100644
index 000000000000..352548bedb74
--- /dev/null
+++ b/dev-lisp/cl-tbnl/cl-tbnl-0.9.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/cl-tbnl-0.9.2.ebuild,v 1.1 2006/01/01 00:16:44 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="TBNL is a toolkit for building dynamic websites with Common Lisp based on mod_lisp."
+HOMEPAGE="http://www.weitz.de/tbnl/"
+SRC_URI="mirror://gentoo/tbnl_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="standalone apache2"
+
+DEPEND="dev-lisp/cl-kmrcl
+ dev-lisp/cl-md5
+ dev-lisp/cl-base64
+ dev-lisp/cl-url-rewrite
+ dev-lisp/cl-ppcre
+ dev-lisp/cl-rfc2388"
+
+RDEPEND="${DEPEND}
+ !standalone? ( apache2? ( >=www-apache/mod_lisp2-1.2 ) !apache2? ( www-apache/mod_lisp ) )"
+
+S=${WORKDIR}/tbnl-${PV}
+
+CLPACKAGE=tbnl
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ insinto $CLSOURCEROOT/$CLPACKAGE/
+ doins -r test contrib
+ dodoc CHANGELOG README
+ dohtml doc/index.html
+}
diff --git a/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.9.2 b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.9.2
new file mode 100644
index 000000000000..f592b2abd894
--- /dev/null
+++ b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.9.2
@@ -0,0 +1 @@
+MD5 ab2ea68dad41fa89bb42bdc36ff7f6e1 tbnl_0.9.2.orig.tar.gz 93118