summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-01-22 10:59:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-01-22 10:59:16 +0000
commit59bcd123ef89d361012f756ba12b149fbb2efd6e (patch)
tree2fdf58937ba4da574a6abadd1d6bcec367ad3d1c
parentUse global USE flags introspection and systemd (diff)
downloadgentoo-2-59bcd123ef89d361012f756ba12b149fbb2efd6e.tar.gz
gentoo-2-59bcd123ef89d361012f756ba12b149fbb2efd6e.tar.bz2
gentoo-2-59bcd123ef89d361012f756ba12b149fbb2efd6e.zip
old
(Portage version: 2.2.0_alpha155/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
-rw-r--r--sys-apps/linux-misc-apps/ChangeLog8
-rw-r--r--sys-apps/linux-misc-apps/linux-misc-apps-3.1.ebuild164
-rw-r--r--sys-apps/linux-misc-apps/linux-misc-apps-3.6.ebuild199
3 files changed, 6 insertions, 365 deletions
diff --git a/sys-apps/linux-misc-apps/ChangeLog b/sys-apps/linux-misc-apps/ChangeLog
index c31a2705673c..f2c107e9989f 100644
--- a/sys-apps/linux-misc-apps/ChangeLog
+++ b/sys-apps/linux-misc-apps/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/linux-misc-apps
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/linux-misc-apps/ChangeLog,v 1.3 2012/11/19 10:23:08 robbat2 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/linux-misc-apps/ChangeLog,v 1.4 2013/01/22 10:59:16 ssuominen Exp $
+
+ 22 Jan 2013; Samuli Suominen <ssuominen@gentoo.org>
+ -linux-misc-apps-3.1.ebuild, -linux-misc-apps-3.6.ebuild:
+ old
*linux-misc-apps-3.6-r1 (19 Nov 2012)
diff --git a/sys-apps/linux-misc-apps/linux-misc-apps-3.1.ebuild b/sys-apps/linux-misc-apps/linux-misc-apps-3.1.ebuild
deleted file mode 100644
index 11b6fa2778f4..000000000000
--- a/sys-apps/linux-misc-apps/linux-misc-apps-3.1.ebuild
+++ /dev/null
@@ -1,164 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/linux-misc-apps/linux-misc-apps-3.1.ebuild,v 1.1 2011/11/01 09:06:05 robbat2 Exp $
-
-EAPI=4
-
-inherit versionator eutils toolchain-funcs linux-info
-
-DESCRIPTION="Misc tools bundled with kernel sources"
-HOMEPAGE="http://kernel.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~ppc"
-IUSE=""
-
-MY_PV="${PV/_/-}"
-MY_PV="${MY_PV/-pre/-git}"
-
-LINUX_V=$(get_version_component_range 1-2)
-
-if [ ${PV/_rc} != ${PV} ]; then
- LINUX_VER=$(get_version_component_range 1-2).$(($(get_version_component_range 3)-1))
- PATCH_VERSION=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV//_/-}.bz2
- SRC_URI="mirror://kernel/linux/kernel/v${LINUX_V}/testing/${LINUX_PATCH}
- mirror://kernel/linux/kernel/v${LINUX_V}/testing/v${PATCH_VERSION}/${LINUX_PATCH}"
-elif [ $(get_version_component_count) == 4 ]; then
- # stable-release series
- LINUX_VER=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV}.bz2
- SRC_URI="mirror://kernel/linux/kernel/v${LINUX_V}/${LINUX_PATCH}"
-else
- LINUX_VER=${PV}
-fi
-
-LINUX_SOURCES=linux-${LINUX_VER}.tar.bz2
-SRC_URI="${SRC_URI} mirror://kernel/linux/kernel/v${LINUX_V}/${LINUX_SOURCES}"
-
-RDEPEND="sys-apps/pciutils" # pciutils for cpupower
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/linux-${LINUX_VER}"
-
-# All of these are integrated with the kernel build system,
-# No make install, and ideally build with with the root Makefile
-TARGETS_SIMPLE=(
- Documentation/accounting/getdelays.c
- Documentation/cgroups/cgroup_event_listener.c
- Documentation/laptops/dslm.c
- Documentation/laptops/hpfall.c
- Documentation/networking/timestamping/timestamping.c
- Documentation/virtual/lguest/lguest.c
- Documentation/vm/page-types.c
- Documentation/watchdog/src/watchdog-simple.c
- drivers/staging/hv/tools/hv_kvp_daemon.c
- tools/slub/slabinfo.c
- usr/gen_init_cpio.c
-)
-# Documentation/networking/ifenslave.c - obsolete
-# Documentation/ptp/testptp.c - pending linux-headers-3.0
-# tools/hv/hv_kvp_daemon.c - pending linux-3.2
-
-# These have a broken make install, no DESTDIR
-TARGET_MAKE_SIMPLE=(
- tools/firewire:nosy-dump
- tools/power/x86/turbostat:turbostat
- tools/power/x86/x86_energy_perf_policy:x86_energy_perf_policy
-)
-# tools/perf - covered by dev-utils/perf
-# tools/usb - testcases only
-# tools/virtio - testcaes only
-
- #for _pattern in {Documentation,scripts,tools,usr,include,lib,"arch/*/include",Makefile,Kbuild,Kconfig}; do
-src_unpack() {
- unpack ${LINUX_SOURCES}
-
- MY_A=
- for _AFILE in ${A}; do
- [[ ${_AFILE} == ${LINUX_SOURCES} ]] && continue
- [[ ${_AFILE} == ${LINUX_PATCH} ]] && continue
- MY_A="${MY_A} ${_AFILE}"
- done
- [[ -n ${MY_A} ]] && unpack ${MY_A}
-}
-
-src_prepare() {
- if [[ -n ${LINUX_PATCH} ]]; then
- epatch "${DISTDIR}"/${LINUX_PATCH}
- fi
- libs="-lcpupower -lrt -lpci"
- sed -i \
- -e "/$libs/{ s,${libs},,g; s,\$, ${libs},g;}" \
- "${S}"/tools/power/cpupower/Makefile
-}
-
-cpupower_make() {
- emake ${makeargs} \
- CC="$(tc-getCC)" AR="$(tc-getAR)" \
- docdir="/usr/share/doc/${PF}/cpupower" \
- mandir="/usr/share/man" \
- libdir="/usr/$(get_libdir)" \
- OPTIMIZATION="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- CPUFREQ_BENCH=/bin/false \
- DEBUG=/bin/false \
- STRIP=/bin/true \
- "$@" || die
-}
-
-kernel_asm_arch() {
- a="${1:${ARCH}}"
- case ${a} in
- # Merged arches
- x86|amd64) echo x86 ;;
- ppc*) echo powerpc ;;
- # Non-merged
- alpha|arm|ia64|m68k|mips|sh|sparc*) echo ${1} ;;
- *) die "TODO: Update the code for your asm-ARCH symlink" ;;
- esac
-}
-
-src_compile() {
- local karch=$(kernel_asm_arch "${ARCH}")
- # This is the minimal amount needed to start building host binaries.
- #emake allmodconfig ARCH=${karch} || die
- #emake prepare modules_prepare ARCH=${karch} || die
- #touch Module.symvers
-
- # Now we can start building
- for s in ${TARGETS_SIMPLE[@]} ; do
- dir=$(dirname $s) src=$(basename $s) bin=${src%.c}
- einfo "Building $s => $bin"
- emake -f /dev/null M=${dir} ARCH=${karch} ${s%.c} || die
- done
-
- for t in ${TARGET_MAKE_SIMPLE[@]} ; do
- einfo "Building $dir => $target"
- dir=${t/:*} target=${t/*:}
- emake -C $dir ARCH=${karch} $target || die
- done
-
- # cpupower is special
- einfo "Buildling cpupower"
- cd "${S}"/tools/power/cpupower
- cpupower_make ARCH=${karch} all || die
-}
-
-src_install() {
- into /usr
- for s in ${TARGETS_SIMPLE[@]} ; do
- dir=$(dirname $s) src=$(basename $s) bin=${src%.c}
- dosbin ${dir}/${bin} || die "Failed to install ${bin}"
- done
-
- for t in ${TARGET_MAKE_SIMPLE[@]} ; do
- dir=${t/:*} target=${t/*:}
- dosbin ${dir}/${target} || die
- done
-
- local karch=$(kernel_asm_arch "${ARCH}")
- cd "${S}"/tools/power/cpupower
- cpupower_make ARCH=${karch} DESTDIR="${D}" install || die
-}
diff --git a/sys-apps/linux-misc-apps/linux-misc-apps-3.6.ebuild b/sys-apps/linux-misc-apps/linux-misc-apps-3.6.ebuild
deleted file mode 100644
index 3624d0a28474..000000000000
--- a/sys-apps/linux-misc-apps/linux-misc-apps-3.6.ebuild
+++ /dev/null
@@ -1,199 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/linux-misc-apps/linux-misc-apps-3.6.ebuild,v 1.1 2012/11/19 10:02:22 robbat2 Exp $
-
-EAPI=4
-
-inherit versionator eutils toolchain-funcs linux-info autotools flag-o-matic
-
-DESCRIPTION="Misc tools bundled with kernel sources"
-HOMEPAGE="http://kernel.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~ppc"
-IUSE=""
-
-MY_PV="${PV/_/-}"
-MY_PV="${MY_PV/-pre/-git}"
-
-LINUX_V=$(get_version_component_range 1-2)
-
-if [ ${PV/_rc} != ${PV} ]; then
- LINUX_VER=$(get_version_component_range 1-2).$(($(get_version_component_range 3)-1))
- PATCH_VERSION=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV//_/-}.bz2
- SRC_URI="mirror://kernel/linux/kernel/v${LINUX_V}/testing/${LINUX_PATCH}
- mirror://kernel/linux/kernel/v${LINUX_V}/testing/v${PATCH_VERSION}/${LINUX_PATCH}"
-elif [ $(get_version_component_count) == 4 ]; then
- # stable-release series
- LINUX_VER=$(get_version_component_range 1-3)
- LINUX_PATCH=patch-${PV}.bz2
- SRC_URI="mirror://kernel/linux/kernel/v${LINUX_V}/${LINUX_PATCH}"
-else
- LINUX_VER=${PV}
-fi
-
-LINUX_SOURCES=linux-${LINUX_VER}.tar.bz2
-SRC_URI="${SRC_URI} mirror://kernel/linux/kernel/v${LINUX_V}/${LINUX_SOURCES}"
-
-# pciutils for cpupower
-# pmtools also provides turbostat
-# sysfsutils and glib for usbip
-RDEPEND="sys-apps/pciutils
- sys-fs/sysfsutils
- dev-libs/glib
- !sys-power/pmtools
- !net-misc/usbip"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/linux-${LINUX_VER}"
-
-# All of these are integrated with the kernel build system,
-# No make install, and ideally build with with the root Makefile
-TARGETS_SIMPLE=(
- Documentation/accounting/getdelays.c
- Documentation/cgroups/cgroup_event_listener.c
- Documentation/laptops/dslm.c
- Documentation/laptops/hpfall.c
- Documentation/networking/timestamping/timestamping.c
- Documentation/watchdog/src/watchdog-simple.c
- tools/lguest/lguest.c
- tools/vm/page-types.c
- tools/vm/slabinfo.c
- usr/gen_init_cpio.c
-)
-# tools/hv/hv_kvp_daemon.c - broken in 3.7 by missing linux/hyperv.h userspace
-# Documentation/networking/ifenslave.c - obsolete
-# Documentation/ptp/testptp.c - pending linux-headers-3.0
-
-# These have a broken make install, no DESTDIR
-TARGET_MAKE_SIMPLE=(
- tools/firewire:nosy-dump
- tools/power/x86/turbostat:turbostat
- tools/power/x86/x86_energy_perf_policy:x86_energy_perf_policy
- Documentation/misc-devices/mei:mei-amt-version
- tools/power/cpupower:cpupower
-)
-# tools/perf - covered by dev-utils/perf
-# tools/usb - testcases only
-# tools/virtio - testcaes only
-
- #for _pattern in {Documentation,scripts,tools,usr,include,lib,"arch/*/include",Makefile,Kbuild,Kconfig}; do
-src_unpack() {
- unpack ${LINUX_SOURCES}
-
- MY_A=
- for _AFILE in ${A}; do
- [[ ${_AFILE} == ${LINUX_SOURCES} ]] && continue
- [[ ${_AFILE} == ${LINUX_PATCH} ]] && continue
- MY_A="${MY_A} ${_AFILE}"
- done
- [[ -n ${MY_A} ]] && unpack ${MY_A}
-}
-
-src_prepare() {
- if [[ -n ${LINUX_PATCH} ]]; then
- epatch "${DISTDIR}"/${LINUX_PATCH}
- fi
-
- pushd drivers/staging/usbip/userspace >/dev/null &&
- eautoreconf -i -f -v &&
- popd >/dev/null || die "usbip"
-
- libs="-lcpupower -lrt -lpci"
- sed -i \
- -e "/$libs/{ s,${libs},,g; s,\$, ${libs},g;}" \
- "${S}"/tools/power/cpupower/Makefile
-
- sed -i \
- -e '/^nosy-dump.*LDFLAGS/d' \
- -e '/^nosy-dump.*CFLAGS/d' \
- -e '/^nosy-dump.*CPPFLAGS/s,CPPFLAGS =,CPPFLAGS +=,g' \
- "${S}"/tools/firewire/Makefile
-}
-
-cpupower_make() {
- emake ${makeargs} \
- CC="$(tc-getCC)" AR="$(tc-getAR)" \
- docdir="/usr/share/doc/${PF}/cpupower" \
- mandir="/usr/share/man" \
- libdir="/usr/$(get_libdir)" \
- OPTIMIZATION="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- CPUFREQ_BENCH=/bin/false \
- DEBUG=/bin/false \
- STRIP=/bin/true \
- "$@" || die
-}
-
-kernel_asm_arch() {
- a="${1:${ARCH}}"
- case ${a} in
- # Merged arches
- x86|amd64) echo x86 ;;
- ppc*) echo powerpc ;;
- # Non-merged
- alpha|arm|ia64|m68k|mips|sh|sparc*) echo ${1} ;;
- *) die "TODO: Update the code for your asm-ARCH symlink" ;;
- esac
-}
-
-src_configure() {
- cd drivers/staging/usbip/userspace && econf
-}
-
-src_compile() {
- local karch=$(kernel_asm_arch "${ARCH}")
- # This is the minimal amount needed to start building host binaries.
- #emake allmodconfig ARCH=${karch} || die
- #emake prepare modules_prepare ARCH=${karch} || die
- #touch Module.symvers
-
- # Now we can start building
- for s in ${TARGETS_SIMPLE[@]} ; do
- dir=$(dirname $s) src=$(basename $s) bin=${src%.c}
- einfo "Building $s => $bin"
- emake -f /dev/null M=${dir} ARCH=${karch} ${s%.c} || die
- done
-
- for t in ${TARGET_MAKE_SIMPLE[@]} ; do
- dir=${t/:*} target=${t/*:}
- einfo "Building $dir => $target"
- emake -C $dir ARCH=${karch} $target || die
- done
-
- emake -C drivers/staging/usbip/userspace
-
- # cpupower is special
- einfo "Buildling cpupower"
- cd "${S}"/tools/power/cpupower
- cpupower_make ARCH=${karch} all || die
-}
-
-src_install() {
- into /usr
- for s in ${TARGETS_SIMPLE[@]} ; do
- dir=$(dirname $s) src=$(basename $s) bin=${src%.c}
- einfo "Installing $s => $bin"
- dosbin ${dir}/${bin} || die "Failed to install ${bin}"
- done
-
- for t in ${TARGET_MAKE_SIMPLE[@]} ; do
- dir=${t/:*} target=${t/*:}
- einfo "Installing $dir => $target"
- dosbin ${dir}/${target} || die
- done
-
- emake -C drivers/staging/usbip/userspace DESTDIR="${D}" install
-
- local karch=$(kernel_asm_arch "${ARCH}")
- cd "${S}"/tools/power/cpupower
- cpupower_make ARCH=${karch} DESTDIR="${D}" install || die
-
- # Avoid conflict
- rm -f "${D}"/usr/include/cpufreq.h
-
- newconfd "${FILESDIR}"/hpfall.confd hpfall
- newinitd "${FILESDIR}"/hpfall.initd hpfall
-}