summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-05-10 17:24:34 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-05-10 17:24:34 +0000
commit58d4f7d37762de04c578bc19e6521d16ac6c679c (patch)
tree09747f7e11fec8e5bd4fe9d481de45c3e67fac76
parentremoved old version (diff)
downloadgentoo-2-58d4f7d37762de04c578bc19e6521d16ac6c679c.tar.gz
gentoo-2-58d4f7d37762de04c578bc19e6521d16ac6c679c.tar.bz2
gentoo-2-58d4f7d37762de04c578bc19e6521d16ac6c679c.zip
Version bumped.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
-rw-r--r--app-i18n/ibus-skk/ChangeLog7
-rw-r--r--app-i18n/ibus-skk/ibus-skk-0.0.7.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/app-i18n/ibus-skk/ChangeLog b/app-i18n/ibus-skk/ChangeLog
index 01135fe7f480..c41e9c8a51d8 100644
--- a/app-i18n/ibus-skk/ChangeLog
+++ b/app-i18n/ibus-skk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-skk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ChangeLog,v 1.6 2010/05/04 00:13:52 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ChangeLog,v 1.7 2010/05/10 17:24:34 matsuu Exp $
+
+*ibus-skk-0.0.7 (10 May 2010)
+
+ 10 May 2010; MATSUU Takuto <matsuu@gentoo.org> +ibus-skk-0.0.7.ebuild:
+ Version bumped.
*ibus-skk-0.0.5 (03 May 2010)
diff --git a/app-i18n/ibus-skk/ibus-skk-0.0.7.ebuild b/app-i18n/ibus-skk/ibus-skk-0.0.7.ebuild
new file mode 100644
index 000000000000..63e205ae26f5
--- /dev/null
+++ b/app-i18n/ibus-skk/ibus-skk-0.0.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ibus-skk-0.0.7.ebuild,v 1.1 2010/05/10 17:24:34 matsuu Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+inherit python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://github.com/ueno/ibus-skk"
+SRC_URI="http://cloud.github.com/downloads/ueno/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="app-i18n/ibus
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ app-i18n/skk-jisyo"
+
+pkg_setup() {
+ python_set_active_version 2
+
+}
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}