summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-09-25 16:13:39 +0000
committerMarien Zwart <marienz@gentoo.org>2006-09-25 16:13:39 +0000
commit5763a414fbafcfa543bc2711587b260744773d92 (patch)
tree0e1ad3b78837e3e97848388ede87cc8c2d05f9f0
parentMade the desktop icon show up under System. (diff)
downloadgentoo-2-5763a414fbafcfa543bc2711587b260744773d92.tar.gz
gentoo-2-5763a414fbafcfa543bc2711587b260744773d92.tar.bz2
gentoo-2-5763a414fbafcfa543bc2711587b260744773d92.zip
Version bump with an updated ebuild by Martin von Gagern <Martin.vGagern@gmx.net> from bug #145399.
(Portage version: 2.1.2_pre1)
-rw-r--r--dev-python/pycairo/ChangeLog9
-rw-r--r--dev-python/pycairo/files/digest-pycairo-1.2.23
-rw-r--r--dev-python/pycairo/files/pycairo-1.2.2-no-automagic-deps.patch40
-rw-r--r--dev-python/pycairo/pycairo-1.2.2.ebuild44
4 files changed, 95 insertions, 1 deletions
diff --git a/dev-python/pycairo/ChangeLog b/dev-python/pycairo/ChangeLog
index 8574dd3e7926..1a62f9ea672a 100644
--- a/dev-python/pycairo/ChangeLog
+++ b/dev-python/pycairo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pycairo
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.24 2006/09/08 01:37:55 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/ChangeLog,v 1.25 2006/09/25 16:13:39 marienz Exp $
+
+*pycairo-1.2.2 (25 Sep 2006)
+
+ 25 Sep 2006; Marien Zwart <marienz@gentoo.org>
+ +files/pycairo-1.2.2-no-automagic-deps.patch, +pycairo-1.2.2.ebuild:
+ Version bump with an updated ebuild by Martin von Gagern
+ <Martin.vGagern@gmx.net> from bug #145399.
06 Sep 2006; Javier Villavicencio <the_paya@gentoo.org>
pycairo-1.2.0.ebuild:
diff --git a/dev-python/pycairo/files/digest-pycairo-1.2.2 b/dev-python/pycairo/files/digest-pycairo-1.2.2
new file mode 100644
index 000000000000..fb15c530def8
--- /dev/null
+++ b/dev-python/pycairo/files/digest-pycairo-1.2.2
@@ -0,0 +1,3 @@
+MD5 83a2e06d9fc3530753701d580a18087e pycairo-1.2.2.tar.gz 482417
+RMD160 3151ca5b80985c9fcd2b001488e23938bd8db84e pycairo-1.2.2.tar.gz 482417
+SHA256 ab10b00c209e9feaebfff944d411f300ca032d09d3ebb64e3498acf9fea09c6d pycairo-1.2.2.tar.gz 482417
diff --git a/dev-python/pycairo/files/pycairo-1.2.2-no-automagic-deps.patch b/dev-python/pycairo/files/pycairo-1.2.2-no-automagic-deps.patch
new file mode 100644
index 000000000000..fcb5650715d9
--- /dev/null
+++ b/dev-python/pycairo/files/pycairo-1.2.2-no-automagic-deps.patch
@@ -0,0 +1,40 @@
+--- pycairo-1.2.2.orig/configure.ac 2006-08-28 22:12:10.000000000 +0200
++++ pycairo-1.2.2/configure.ac 2006-08-28 22:13:38.000000000 +0200
+@@ -32,6 +32,9 @@
+ [AC_HELP_STRING([--with-pygtk], [support pygtk [default=yes]])],
+ [],
+ [with_pygtk="yes"])
++AC_ARG_WITH([numeric],
++ AS_HELP_STRING([--without-numeric],
++ [Build without numeric support (default: test)]))
+
+
+ # put the ACLOCAL flags in the makefile
+@@ -79,14 +82,19 @@
+ AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
+
+ # Numeric Python
+-save_CPPFLAGS="$CPPFLAGS"
+-CPPFLAGS="$CPPFLAGS $PYTHON_INCLUDES"
+-AC_CHECK_HEADER([Numeric/arrayobject.h],
+- [have_numpy=yes], [have_numpy=no],
+- [#include <Python.h>])
+-CPPFLAGS="$save_CPPFLAGS"
+-if test x$have_numpy = xyes; then
+- AC_DEFINE(HAVE_NUMPY, [1], [Define to 1 if Numeric python is found])
++if test "x$with_numeric" != "xno"; then
++ save_CPPFLAGS="$CPPFLAGS"
++ CPPFLAGS="$CPPFLAGS $PYTHON_INCLUDES"
++ AC_CHECK_HEADER([Numeric/arrayobject.h],
++ [have_numpy=yes], [have_numpy=no],
++ [#include <Python.h>])
++ CPPFLAGS="$save_CPPFLAGS"
++ if test x$have_numpy = xyes; then
++ AC_DEFINE(HAVE_NUMPY, [1], [Define to 1 if Numeric python is found])
++ fi
++else
++ # only needed for the summary printed at the end of configure
++ have_numpy=no
+ fi
+
+ # checks for types and compilers ---
diff --git a/dev-python/pycairo/pycairo-1.2.2.ebuild b/dev-python/pycairo/pycairo-1.2.2.ebuild
new file mode 100644
index 000000000000..4319c79eb5de
--- /dev/null
+++ b/dev-python/pycairo/pycairo-1.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.2.2.ebuild,v 1.1 2006/09/25 16:13:39 marienz Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Python wrapper for cairo vector graphics library"
+HOMEPAGE="http://cairographics.org/pycairo"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="numeric"
+
+DEPEND=">=dev-lang/python-2.3
+ >=x11-libs/cairo-1.2.0
+ numeric? ( dev-python/numeric )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-no-automagic-deps.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_with numeric) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "install failed"
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ rm "${D}"/usr/share/doc/${PF}/examples/Makefile*
+
+ dodoc AUTHORS NOTES README NEWS ChangeLog
+}