summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-08-11 23:32:27 +0000
committerAron Griffis <agriffis@gentoo.org>2005-08-11 23:32:27 +0000
commit5620c27d9e1606221169d1dd393e29d379b8ba4f (patch)
tree475d00c856c19c33771b57db2417dd60abd7a518
parentDisable sasl unless pop or imap is specified; it's the same as ssl or gnutls (diff)
downloadgentoo-2-5620c27d9e1606221169d1dd393e29d379b8ba4f.tar.gz
gentoo-2-5620c27d9e1606221169d1dd393e29d379b8ba4f.tar.bz2
gentoo-2-5620c27d9e1606221169d1dd393e29d379b8ba4f.zip
Don't enable sasl unless pop or imap is in USE, same as gnutls or ssl in
that regard #102129. Use --with-mailpath instead of --with-maildir (Portage version: 2.0.51.22-r2)
-rw-r--r--mail-client/muttng/ChangeLog6
-rw-r--r--mail-client/muttng/muttng-20050809-r1.ebuild14
2 files changed, 13 insertions, 7 deletions
diff --git a/mail-client/muttng/ChangeLog b/mail-client/muttng/ChangeLog
index be9ba0594054..2d81f86a4a1a 100644
--- a/mail-client/muttng/ChangeLog
+++ b/mail-client/muttng/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/muttng
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/muttng/ChangeLog,v 1.8 2005/08/11 22:38:10 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/muttng/ChangeLog,v 1.9 2005/08/11 23:32:27 agriffis Exp $
+
+ 11 Aug 2005; Aron Griffis <agriffis@gentoo.org> muttng-20050809-r1.ebuild:
+ Don't enable sasl unless pop or imap is in USE, same as gnutls or ssl in
+ that regard #102129. Use --with-mailpath instead of --with-maildir
*muttng-20050809-r1 (11 Aug 2005)
diff --git a/mail-client/muttng/muttng-20050809-r1.ebuild b/mail-client/muttng/muttng-20050809-r1.ebuild
index 417f982c7358..906526226d77 100644
--- a/mail-client/muttng/muttng-20050809-r1.ebuild
+++ b/mail-client/muttng/muttng-20050809-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/muttng/muttng-20050809-r1.ebuild,v 1.1 2005/08/11 22:38:10 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/muttng/muttng-20050809-r1.ebuild,v 1.2 2005/08/11 23:32:27 agriffis Exp $
inherit eutils flag-o-matic
@@ -24,13 +24,14 @@ RDEPEND="nls? ( sys-devel/gettext )
imap? (
gnutls? ( >=net-libs/gnutls-1.0.17 )
!gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
)
pop? (
gnutls? ( >=net-libs/gnutls-1.0.17 )
!gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
)
- gpgme? ( >=app-crypt/gpgme-0.9.0 )
- sasl? ( >=dev-libs/cyrus-sasl-2 )"
+ gpgme? ( >=app-crypt/gpgme-0.9.0 )"
DEPEND="${RDEPEND}
sys-devel/automake
>=sys-devel/autoconf-2.5
@@ -55,7 +56,6 @@ src_compile() {
$(use_enable gpgme) \
$(use_enable imap) \
$(use_enable pop) \
- $(use_with sasl sasl2) \
$(use_enable crypt pgp) \
$(use_enable smime) \
$(use_enable cjk default-japanese) \
@@ -96,8 +96,10 @@ src_compile() {
elif use ssl; then
myconf="${myconf} --with-ssl"
fi
+ # not sure if this should be mutually exclusive with the other two
+ myconf="${myconf} $(use_with sasl sasl2)"
else
- myconf="${myconf} --without-gnutls --without-ssl"
+ myconf="${myconf} --without-gnutls --without-ssl --without-sasl2"
fi
# See Bug #11170
@@ -121,7 +123,7 @@ src_compile() {
fi
if use mbox; then
- myconf="${myconf} --with-maildir=/var/spool/mail"
+ myconf="${myconf} --with-mailpath=/var/spool/mail"
else
myconf="${myconf} --with-homespool=Maildir"
fi