summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2014-11-15 12:32:44 +0000
committerBen de Groot <yngwin@gentoo.org>2014-11-15 12:32:44 +0000
commit555aa4cc0c0246b56943a06964bbbc5d41fa4ebd (patch)
tree4af17c4ab963e50ae1aefc8f039e666d8dbe7f50
parentFix building against sys-libs/ncurses[tinfo] (bug #528382). (diff)
downloadgentoo-2-555aa4cc0c0246b56943a06964bbbc5d41fa4ebd.tar.gz
gentoo-2-555aa4cc0c0246b56943a06964bbbc5d41fa4ebd.tar.bz2
gentoo-2-555aa4cc0c0246b56943a06964bbbc5d41fa4ebd.zip
Add ebuild improvements from bug #526938. Remove old.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x0F9C590B7FF324F6!)
-rw-r--r--app-editors/vim-qt/ChangeLog9
-rw-r--r--app-editors/vim-qt/files/vim-qt.desktop9
-rw-r--r--app-editors/vim-qt/metadata.xml1
-rw-r--r--app-editors/vim-qt/vim-qt-20130201-r1.ebuild80
-rw-r--r--app-editors/vim-qt/vim-qt-20130220-r1.ebuild80
-rw-r--r--app-editors/vim-qt/vim-qt-20140827-r1.ebuild115
6 files changed, 133 insertions, 161 deletions
diff --git a/app-editors/vim-qt/ChangeLog b/app-editors/vim-qt/ChangeLog
index 20f0b146e0e9..ba5710fbb87b 100644
--- a/app-editors/vim-qt/ChangeLog
+++ b/app-editors/vim-qt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/vim-qt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-qt/ChangeLog,v 1.7 2014/10/25 02:10:14 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-qt/ChangeLog,v 1.8 2014/11/15 12:32:44 yngwin Exp $
+
+*vim-qt-20140827-r1 (15 Nov 2014)
+
+ 15 Nov 2014; Ben de Groot <yngwin@gentoo.org> +files/vim-qt.desktop,
+ +vim-qt-20140827-r1.ebuild, -vim-qt-20130201-r1.ebuild,
+ -vim-qt-20130220-r1.ebuild, metadata.xml:
+ Add ebuild improvements from bug #526938. Remove old.
*vim-qt-20140827 (25 Oct 2014)
diff --git a/app-editors/vim-qt/files/vim-qt.desktop b/app-editors/vim-qt/files/vim-qt.desktop
new file mode 100644
index 000000000000..207bf332ed14
--- /dev/null
+++ b/app-editors/vim-qt/files/vim-qt.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=vim-Qt
+Comment=A highly configurable text editor
+Exec=qvim -f %F
+Icon=vim-qt
+Terminal=false
+Type=Application
+MimeType=text/plain;
+Categories=Qt;TextEditor;Development;
diff --git a/app-editors/vim-qt/metadata.xml b/app-editors/vim-qt/metadata.xml
index 1cca6173e11c..f9d6c82c525c 100644
--- a/app-editors/vim-qt/metadata.xml
+++ b/app-editors/vim-qt/metadata.xml
@@ -4,5 +4,6 @@
<herd>qt</herd>
<use>
<flag name='luajit'>Use <pkg>dev-lang/luajit</pkg> instead of <pkg>dev-lang/lua</pkg></flag>
+ <flag name='racket'>Enable support for Scheme using <pkg>dev-lang/racket</pkg></flag>
</use>
</pkgmetadata>
diff --git a/app-editors/vim-qt/vim-qt-20130201-r1.ebuild b/app-editors/vim-qt/vim-qt-20130201-r1.ebuild
deleted file mode 100644
index c07d68823d44..000000000000
--- a/app-editors/vim-qt/vim-qt-20130201-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-qt/vim-qt-20130201-r1.ebuild,v 1.1 2013/10/16 12:20:28 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
-PYTHON_REQ_USE="threads"
-inherit eutils fdo-mime flag-o-matic python-single-r1
-
-DESCRIPTION="Qt GUI version of the Vim text editor"
-HOMEPAGE="https://bitbucket.org/equalsraf/vim-qt/wiki/Home"
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-2
- EGIT_REPO_URI="https://bitbucket.org/equalsraf/${PN}.git
- git://github.com/equalsraf/${PN}.git
- git://gitorious.org/${PN}/${PN}.git"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/equalsraf/${PN}/archive/package-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${PN}-package-${PV}"
-fi
-
-LICENSE="vim"
-SLOT="0"
-IUSE="acl cscope debug gpm nls perl python ruby"
-
-RDEPEND="app-admin/eselect-vi
- >=app-editors/vim-core-7.3.762[acl?]
- sys-libs/ncurses
- >=dev-qt/qtcore-4.7.0:4
- >=dev-qt/qtgui-4.7.0:4
- acl? ( kernel_linux? ( sys-apps/acl ) )
- cscope? ( dev-util/cscope )
- gpm? ( sys-libs/gpm )
- nls? ( virtual/libintl )
- perl? ( dev-lang/perl )
- python? ( ${PYTHON_DEPS} )
- ruby? ( || ( dev-lang/ruby:1.9 dev-lang/ruby:1.8 ) )"
-DEPEND="${RDEPEND}"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-pkg_setup() {
- export LC_COLLATE="C" # prevent locale brokenness bug #82186
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- use debug && append-flags "-DDEBUG"
-
- local myconf="--with-features=huge --enable-multibyte"
- myconf+=" $(use_enable acl)"
- myconf+=" $(use_enable gpm)"
- myconf+=" $(use_enable nls)"
- myconf+=" $(use_enable perl perlinterp)"
- myconf+=" $(use_enable python pythoninterp)"
- myconf+=" $(use_enable ruby rubyinterp)"
- myconf+=" --enable-gui=qt --with-vim-name=qvim --with-x"
-
- if ! use cscope ; then
- sed -i -e '/# define FEAT_CSCOPE/d' src/feature.h || die 'sed failed'
- fi
- econf ${myconf}
-}
-
-src_install() {
- dobin src/qvim
- doicon -s 64 src/qt/icons/vim-qt.png
- make_desktop_entry qvim Vim-qt vim-qt "Qt;TextEditor;Development;"
-}
-
-pkg_postinst() {
- fdo-mime_mime_database_update
-}
-
-pkg_postrm() {
- fdo-mime_mime_database_update
-}
diff --git a/app-editors/vim-qt/vim-qt-20130220-r1.ebuild b/app-editors/vim-qt/vim-qt-20130220-r1.ebuild
deleted file mode 100644
index 840a3125767e..000000000000
--- a/app-editors/vim-qt/vim-qt-20130220-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-qt/vim-qt-20130220-r1.ebuild,v 1.1 2013/10/16 12:20:28 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
-PYTHON_REQ_USE="threads"
-inherit eutils fdo-mime flag-o-matic python-single-r1
-
-DESCRIPTION="Qt GUI version of the Vim text editor"
-HOMEPAGE="https://bitbucket.org/equalsraf/vim-qt/wiki/Home"
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-2
- EGIT_REPO_URI="https://bitbucket.org/equalsraf/${PN}.git
- git://github.com/equalsraf/${PN}.git
- git://gitorious.org/${PN}/${PN}.git"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/equalsraf/${PN}/archive/package-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${PN}-package-${PV}"
-fi
-
-LICENSE="vim"
-SLOT="0"
-IUSE="acl cscope debug gpm nls perl python ruby"
-
-RDEPEND="app-admin/eselect-vi
- >=app-editors/vim-core-7.3.762[acl?]
- sys-libs/ncurses
- >=dev-qt/qtcore-4.7.0:4
- >=dev-qt/qtgui-4.7.0:4
- acl? ( kernel_linux? ( sys-apps/acl ) )
- cscope? ( dev-util/cscope )
- gpm? ( sys-libs/gpm )
- nls? ( virtual/libintl )
- perl? ( dev-lang/perl )
- python? ( ${PYTHON_DEPS} )
- ruby? ( || ( dev-lang/ruby:1.9 dev-lang/ruby:1.8 ) )"
-DEPEND="${RDEPEND}"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-pkg_setup() {
- export LC_COLLATE="C" # prevent locale brokenness bug #82186
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- use debug && append-flags "-DDEBUG"
-
- local myconf="--with-features=huge --enable-multibyte"
- myconf+=" $(use_enable acl)"
- myconf+=" $(use_enable gpm)"
- myconf+=" $(use_enable nls)"
- myconf+=" $(use_enable perl perlinterp)"
- myconf+=" $(use_enable python pythoninterp)"
- myconf+=" $(use_enable ruby rubyinterp)"
- myconf+=" --enable-gui=qt --with-vim-name=qvim --with-x"
-
- if ! use cscope ; then
- sed -i -e '/# define FEAT_CSCOPE/d' src/feature.h || die 'sed failed'
- fi
- econf ${myconf}
-}
-
-src_install() {
- dobin src/qvim
- doicon -s 64 src/qt/icons/vim-qt.png
- make_desktop_entry qvim Vim-qt vim-qt "Qt;TextEditor;Development;"
-}
-
-pkg_postinst() {
- fdo-mime_mime_database_update
-}
-
-pkg_postrm() {
- fdo-mime_mime_database_update
-}
diff --git a/app-editors/vim-qt/vim-qt-20140827-r1.ebuild b/app-editors/vim-qt/vim-qt-20140827-r1.ebuild
new file mode 100644
index 000000000000..43043c0b208a
--- /dev/null
+++ b/app-editors/vim-qt/vim-qt-20140827-r1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-qt/vim-qt-20140827-r1.ebuild,v 1.1 2014/11/15 12:32:44 yngwin Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+PYTHON_REQ_USE="threads"
+inherit eutils fdo-mime flag-o-matic prefix python-single-r1
+
+DESCRIPTION="Qt GUI version of the Vim text editor"
+HOMEPAGE="https://bitbucket.org/equalsraf/vim-qt/wiki/Home"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI=(
+ "https://bitbucket.org/equalsraf/${PN}.git"
+ "https://github.com/equalsraf/${PN}.git"
+ "git://gitorious.org/${PN}/${PN}.git"
+ )
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/equalsraf/${PN}/archive/package-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-package-${PV}"
+fi
+
+LICENSE="vim"
+SLOT="0"
+IUSE="acl cscope debug gpm lua luajit nls perl python racket ruby"
+
+REQUIRED_USE="luajit? ( lua )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="app-admin/eselect-vi
+ >=app-editors/vim-core-7.4.417[acl?]
+ sys-libs/ncurses
+ >=dev-qt/qtcore-4.7.0:4
+ >=dev-qt/qtgui-4.7.0:4
+ acl? ( kernel_linux? ( sys-apps/acl ) )
+ cscope? ( dev-util/cscope )
+ gpm? ( sys-libs/gpm )
+ lua? ( luajit? ( dev-lang/luajit )
+ !luajit? ( dev-lang/lua[deprecated] ) )
+ nls? ( virtual/libintl )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ racket? ( dev-scheme/racket )
+ ruby? ( || ( dev-lang/ruby:2.0 dev-lang/ruby:1.9 ) )"
+DEPEND="${RDEPEND}
+ dev-util/ctags
+ sys-devel/autoconf
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ export LC_COLLATE="C" # prevent locale brokenness bug #82186
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ use debug && append-flags "-DDEBUG"
+
+ local myconf="--with-features=huge --disable-gpm --enable-multibyte"
+ myconf+=" $(use_enable acl)"
+ myconf+=" $(use_enable cscope)"
+ myconf+=" $(use_enable nls)"
+ myconf+=" $(use_enable lua luainterp)"
+ myconf+=" $(use_with luajit)"
+ myconf+=" $(use_enable perl perlinterp)"
+ myconf+=" $(use_enable racket mzschemeinterp)"
+ myconf+=" $(use_enable ruby rubyinterp)"
+
+ if ! use cscope ; then
+ sed -i -e '/# define FEAT_CSCOPE/d' src/feature.h || die 'sed failed'
+ fi
+
+ # keep prefix env contained within the EPREFIX
+ use prefix && myconf+=" --without-local-dir"
+
+ if use python ; then
+ if [[ ${EPYTHON} == python3* ]] ; then
+ myconf+=" --enable-python3interp"
+ export vi_cv_path_python3="${PYTHON}"
+ else
+ myconf+=" --enable-pythoninterp"
+ export vi_cv_path_python="${PYTHON}"
+ fi
+ else
+ myconf+=" --disable-pythoninterp --disable-python3interp"
+ fi
+
+ econf ${myconf} --enable-gui=qt --with-vim-name=qvim --with-modified-by=Gentoo-${PVR}
+}
+
+src_install() {
+ dobin src/qvim
+ dosym qvim /usr/bin/qvimdiff
+
+ dodir /usr/share/man/man1
+ echo ".so vim.1" > "${ED}"/usr/share/man/man1/qvim.1
+ echo ".so vimdiff.1" > "${ED}"/usr/share/man/man1/qvimdiff.1
+
+ # track https://bitbucket.org/equalsraf/vim-qt/issue/93/include-desktop-file-in-source
+ # for inclusion of desktop file
+ newmenu "${FILESDIR}"/vim-qt.desktop vim-qt.desktop
+ doicon -s 64 src/qt/icons/vim-qt.png
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}