summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2010-09-30 18:59:02 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2010-09-30 18:59:02 +0000
commit5527e9b7d1e9714d30093ee46308f4160d1cfcb8 (patch)
treec6cfa9e2f76419bcca83eebafc324030ea5ee2d5
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-5527e9b7d1e9714d30093ee46308f4160d1cfcb8.tar.gz
gentoo-2-5527e9b7d1e9714d30093ee46308f4160d1cfcb8.tar.bz2
gentoo-2-5527e9b7d1e9714d30093ee46308f4160d1cfcb8.zip
Revision bumps for new genpatches.
(Portage version: 2.1.9.12/cvs/Linux x86_64)
-rw-r--r--sys-kernel/ck-sources/ChangeLog9
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.34-r4.ebuild47
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.35-r3.ebuild47
3 files changed, 102 insertions, 1 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index d4f7e3dd2a46..2173cbc6c722 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.180 2010/08/31 16:22:31 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.181 2010/09/30 18:59:02 nelchael Exp $
+
+*ck-sources-2.6.35-r3 (30 Sep 2010)
+*ck-sources-2.6.34-r4 (30 Sep 2010)
+
+ 30 Sep 2010; Krzysztof Pawlik <nelchael@gentoo.org>
+ +ck-sources-2.6.34-r4.ebuild, +ck-sources-2.6.35-r3.ebuild:
+ Revision bumps for new genpatches.
*ck-sources-2.6.34-r3 (31 Aug 2010)
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.34-r4.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.34-r4.ebuild
new file mode 100644
index 000000000000..0e0ac9ca30e7
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.6.34-r4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.34-r4.ebuild,v 1.1 2010/09/30 18:59:02 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="13"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="Con Kolivas' high performance patchset + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://www.kernel.org/pub/linux/kernel/people/ck/patches/2.6/"
+
+CK_VERSION="1"
+CK_REVISION="1"
+K_SECURITY_UNSUPPORTED="1"
+
+if [[ -z "${CK_REVISION}" ]]; then
+ CK_URI="mirror://kernel/linux/kernel/people/ck/patches/2.6/${PV}/${PV}-ck${CK_VERSION}/patch-${PV}-ck${CK_VERSION}.bz2"
+ UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}.bz2"
+else
+ # This is ck${CK_VERSION} but resynced to apply cleanly to stable kernel
+ # release:
+ CK_URI="mirror://gentoo/patch-${PV}-ck${CK_VERSION}-r${CK_REVISION}.bz2"
+ UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}-r${CK_REVISION}.bz2"
+fi
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ # Comment out EXTRAVERSION added by CK patch:
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.35-r3.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.35-r3.ebuild
new file mode 100644
index 000000000000..23f1edf3dc1d
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.6.35-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.35-r3.ebuild,v 1.1 2010/09/30 18:59:02 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="Con Kolivas' high performance patchset + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://www.kernel.org/pub/linux/kernel/people/ck/patches/2.6/"
+
+CK_VERSION="1"
+CK_REVISION=""
+K_SECURITY_UNSUPPORTED="1"
+
+if [[ -z "${CK_REVISION}" ]]; then
+ CK_URI="mirror://kernel/linux/kernel/people/ck/patches/2.6/${PV}/${PV}-ck${CK_VERSION}/patch-${PV}-ck${CK_VERSION}.bz2"
+ UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}.bz2"
+else
+ # This is ck${CK_VERSION} but resynced to apply cleanly to stable kernel
+ # release:
+ CK_URI="mirror://gentoo/patch-${PV}-ck${CK_VERSION}-r${CK_REVISION}.bz2"
+ UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}-r${CK_REVISION}.bz2"
+fi
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ # Comment out EXTRAVERSION added by CK patch:
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}