summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-01-30 08:29:43 +0000
committerHans de Graaff <graaff@gentoo.org>2010-01-30 08:29:43 +0000
commit544853c5e78e377f7024c93d9be8d529c7f46313 (patch)
tree946cee02f3d0b6d1d5b5cce6bc17e5115ee2ac24
parentSkip install of combine.pl (bug #236205) (diff)
downloadgentoo-2-544853c5e78e377f7024c93d9be8d529c7f46313.tar.gz
gentoo-2-544853c5e78e377f7024c93d9be8d529c7f46313.tar.bz2
gentoo-2-544853c5e78e377f7024c93d9be8d529c7f46313.zip
Version bump with unspecified bug fixes.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
-rw-r--r--dev-libs/fcgi/ChangeLog10
-rw-r--r--dev-libs/fcgi/fcgi-2.4.1_pre0910052249.ebuild50
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-libs/fcgi/ChangeLog b/dev-libs/fcgi/ChangeLog
index da358b66efea..57d8097c0140 100644
--- a/dev-libs/fcgi/ChangeLog
+++ b/dev-libs/fcgi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/fcgi
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/ChangeLog,v 1.39 2009/04/18 12:32:48 graaff Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/ChangeLog,v 1.40 2010/01/30 08:29:43 graaff Exp $
+
+*fcgi-2.4.1_pre0910052249 (30 Jan 2010)
+
+ 30 Jan 2010; Hans de Graaff <graaff@gentoo.org>
+ +fcgi-2.4.1_pre0910052249.ebuild:
+ Version bump with unspecified bug fixes.
18 Apr 2009; Hans de Graaff <graaff@gentoo.org>
+files/fcgi-2.4.1_pre0311112127-gcc44.patch,
diff --git a/dev-libs/fcgi/fcgi-2.4.1_pre0910052249.ebuild b/dev-libs/fcgi/fcgi-2.4.1_pre0910052249.ebuild
new file mode 100644
index 000000000000..d56b649875c6
--- /dev/null
+++ b/dev-libs/fcgi/fcgi-2.4.1_pre0910052249.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/fcgi-2.4.1_pre0910052249.ebuild,v 1.1 2010/01/30 08:29:43 graaff Exp $
+
+EAPI="2"
+
+inherit eutils autotools multilib
+
+DESCRIPTION="FastCGI Developer's Kit"
+HOMEPAGE="http://www.fastcgi.com/"
+SRC_URI="http://www.fastcgi.com/dist/fcgi-2.4.1-SNAP-0910052249.tar.gz"
+
+LICENSE="FastCGI"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="html"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/fcgi-2.4.1-SNAP-0910052249"
+
+src_prepare() {
+ epatch "${FILESDIR}/fcgi-2.4.0-Makefile.patch"
+ epatch "${FILESDIR}/fcgi-2.4.0-clientdata-pointer.patch"
+ epatch "${FILESDIR}/fcgi-2.4.0-html-updates.patch"
+ epatch "${FILESDIR}"/fcgi-2.4.1_pre0311112127-gcc44.patch
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install LIBRARY_PATH="${D}/usr/$(get_libdir)" || die
+
+ dodoc README
+
+ # install the manpages into the right place
+ doman doc/*.[13]
+
+ # Only install the html documentation if USE=html
+ if use html ; then
+ dohtml "${S}"/doc/*/*
+ insinto /usr/share/doc/${PF}/html
+ doins -r "${S}/images"
+ fi
+
+ # install examples in the right place
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}/examples/"*.c
+}