summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-03 10:06:31 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-03 10:06:31 +0000
commit5423491ab7743d775087ded3f8f4d0ff60b335ed (patch)
treefae7645bbd4698801d1b026fc1cbb5746bc33973
parentRemove older version. (diff)
downloadgentoo-2-5423491ab7743d775087ded3f8f4d0ff60b335ed.tar.gz
gentoo-2-5423491ab7743d775087ded3f8f4d0ff60b335ed.tar.bz2
gentoo-2-5423491ab7743d775087ded3f8f4d0ff60b335ed.zip
version bump; convert to webapp; fixes #208584
(Portage version: 2.1.4)
-rw-r--r--net-mail/vqadmin/ChangeLog10
-rw-r--r--net-mail/vqadmin/files/postinstall-en.txt12
-rw-r--r--net-mail/vqadmin/vqadmin-2.3.6.ebuild13
-rw-r--r--net-mail/vqadmin/vqadmin-2.3.7.ebuild64
4 files changed, 92 insertions, 7 deletions
diff --git a/net-mail/vqadmin/ChangeLog b/net-mail/vqadmin/ChangeLog
index 6ea10d35b8f3..5e6b417cadc9 100644
--- a/net-mail/vqadmin/ChangeLog
+++ b/net-mail/vqadmin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/vqadmin
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vqadmin/ChangeLog,v 1.7 2007/07/29 17:02:17 phreak Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vqadmin/ChangeLog,v 1.8 2008/02/03 10:06:30 hollow Exp $
+
+*vqadmin-2.3.7 (03 Feb 2008)
+
+ 03 Feb 2008; Benedikt Böhm <hollow@gentoo.org> +files/postinstall-en.txt,
+ vqadmin-2.3.6.ebuild, +vqadmin-2.3.7.ebuild:
+ version bump; convert to webapp; fixes #208584
29 Jul 2007; Christian Heim <phreak@gentoo.org> vqadmin-2.3.6.ebuild:
Fixing the DEPEND/RDEPEND for the move of net-www/apache to
diff --git a/net-mail/vqadmin/files/postinstall-en.txt b/net-mail/vqadmin/files/postinstall-en.txt
new file mode 100644
index 000000000000..3a909a78d9fb
--- /dev/null
+++ b/net-mail/vqadmin/files/postinstall-en.txt
@@ -0,0 +1,12 @@
+You need to setup authentication. For apache do the following:
+
+<Files ${VHOST_CGIBINDIR}/${PN}>
+ AuthType Basic
+ AuthUserFile ${VHOST_CONFDIR}${PN}.passwd
+ AuthName ${PN}
+ Require valid-user
+</Files>
+
+The create the password file like this:
+
+htpasswd -c ${VHOST_CONFDIR}${PN}.passwd <user>
diff --git a/net-mail/vqadmin/vqadmin-2.3.6.ebuild b/net-mail/vqadmin/vqadmin-2.3.6.ebuild
index 489071a9dbba..c718c828ea69 100644
--- a/net-mail/vqadmin/vqadmin-2.3.6.ebuild
+++ b/net-mail/vqadmin/vqadmin-2.3.6.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vqadmin/vqadmin-2.3.6.ebuild,v 1.9 2007/07/29 17:02:17 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vqadmin/vqadmin-2.3.6.ebuild,v 1.10 2008/02/03 10:06:30 hollow Exp $
+
+inherit depend.apache
DESCRIPTION="A web based control pannel to manage Virtual Qmail Domains. Works with qmailadmin"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -12,8 +14,9 @@ SLOT="0"
DEPEND=">=net-mail/vpopmail-5.3
virtual/qmail"
RDEPEND="${DEPEND}
- net-mail/qmailadmin
- www-servers/apache"
+ net-mail/qmailadmin"
+
+need_apache
src_compile() {
local dir_vhost="/var/www/localhost/"
@@ -57,7 +60,7 @@ src_install () {
make DESTDIR=${D} install || die
# Install documentation.
- dodoc ACL AUTHORS BUGS LICENSE ChangeLog FAQ INSTALL NEWS TODO README
+ dodoc ACL AUTHORS BUGS ChangeLog FAQ INSTALL NEWS TODO README
}
#pkg_config() {
diff --git a/net-mail/vqadmin/vqadmin-2.3.7.ebuild b/net-mail/vqadmin/vqadmin-2.3.7.ebuild
new file mode 100644
index 000000000000..9de030d809a6
--- /dev/null
+++ b/net-mail/vqadmin/vqadmin-2.3.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vqadmin/vqadmin-2.3.7.ebuild,v 1.1 2008/02/03 10:06:30 hollow Exp $
+
+inherit webapp eutils autotools
+
+DESCRIPTION="A web based control pannel to manage Virtual Qmail Domains. Works with qmailadmin"
+HOMEPAGE="http://www.inter7.com/index.php?page=vqadmin"
+SRC_URI="http://www.inter7.com/vqadmin/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+WEBAPP_MANUAL_SLOT="yes"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/qmail
+ >=net-mail/vpopmail-5.3"
+RDEPEND="${DEPEND}
+ net-mail/qmailadmin"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fixes for sane webapp integration
+ sed -i \
+ -e "s|html/|/usr/share/${PN}/|g" \
+ -e "s|/images/vqadmin/|/vqadmin/|g" \
+ -e "s|/cgi-bin/vqadmin/|/cgi-bin/|g" \
+ -e "s|vqadmin\.cgi|vqadmin|g" \
+ *.h *.c html/*.html
+}
+
+src_compile() {
+ econf ${myopts} \
+ --enable-qmaildir=/var/qmail \
+ --enable-vpopuser=vpopmail \
+ --enable-vpopgroup=vpopmail \
+ --enable-cgibindir="${MY_CGIBINDIR}" \
+ || die "econf failed"
+
+ emake || die "make failed"
+}
+
+src_install () {
+ webapp_src_preinst
+
+ insinto /usr/share/${PN}
+ doins html/*
+
+ insinto "${MY_HTDOCSDIR}"
+ doins html/*.css
+
+ insinto "${MY_CGIBINDIR}"
+ doins vqadmin.acl
+ insopts -m 755
+ doins vqadmin
+
+ dodoc ACL AUTHORS BUGS ChangeLog FAQ INSTALL NEWS TODO README
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}