summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-12-21 20:39:14 +0000
committerPeter Volkov <pva@gentoo.org>2009-12-21 20:39:14 +0000
commit5372b5e945e273506da48ff42e7824ecf88b2507 (patch)
tree0a77e7751d2cc58d56f7aeb0adc61a1a68ae3a93
parentAdd FreeBSD 8.0 profiles for i686 and x86_64 (diff)
downloadgentoo-2-5372b5e945e273506da48ff42e7824ecf88b2507.tar.gz
gentoo-2-5372b5e945e273506da48ff42e7824ecf88b2507.tar.bz2
gentoo-2-5372b5e945e273506da48ff42e7824ecf88b2507.zip
Initial import. Ebuild by me and Constantin Bergemann, bug #219138. Nice alternative for pidgin-latex.
(Portage version: 2.1.7.15/cvs/Linux x86_64)
-rw-r--r--x11-plugins/pidgintex/ChangeLog11
-rw-r--r--x11-plugins/pidgintex/metadata.xml15
-rw-r--r--x11-plugins/pidgintex/pidgintex-1.1.1.ebuild43
3 files changed, 69 insertions, 0 deletions
diff --git a/x11-plugins/pidgintex/ChangeLog b/x11-plugins/pidgintex/ChangeLog
new file mode 100644
index 000000000000..6a200dbabf7d
--- /dev/null
+++ b/x11-plugins/pidgintex/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-plugins/pidgintex
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgintex/ChangeLog,v 1.1 2009/12/21 20:39:14 pva Exp $
+
+*pidgintex-1.1.1 (21 Dec 2009)
+
+ 21 Dec 2009; Peter Volkov <pva@gentoo.org> +pidgintex-1.1.1.ebuild,
+ +metadata.xml:
+ Initial import. Ebuild by me and Constantin Bergemann, bug #219138. Nice
+ alternative for pidgin-latex.
+
diff --git a/x11-plugins/pidgintex/metadata.xml b/x11-plugins/pidgintex/metadata.xml
new file mode 100644
index 000000000000..1b7319740533
--- /dev/null
+++ b/x11-plugins/pidgintex/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-im</herd>
+<maintainer>
+ <email>pva@gentoo.org</email>
+ <name>Peter Volkov</name>
+</maintainer>
+<longdescription>
+pidginTeX is a fast plugin for the instant messaging client Pidgin and uses
+mimeTeX or mathTeX to render LaTeX expressions in messages and chat. It is
+intended for math but mathTeX is fully compatible with LaTeX and any package can
+be used and mimeTeX also supports many other features.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/pidgintex/pidgintex-1.1.1.ebuild b/x11-plugins/pidgintex/pidgintex-1.1.1.ebuild
new file mode 100644
index 000000000000..ce8a8419c35e
--- /dev/null
+++ b/x11-plugins/pidgintex/pidgintex-1.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgintex/pidgintex-1.1.1.ebuild,v 1.1 2009/12/21 20:39:14 pva Exp $
+
+EAPI="2"
+inherit toolchain-funcs multilib
+
+MY_P=pidginTeX-${PV}
+
+DESCRIPTION="Pidgin plugin to render LaTeX expressions in messages."
+HOMEPAGE="http://code.google.com/p/pidgintex"
+SRC_URI="http://pidgintex.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-im/pidgin[gtk]
+ app-text/mathtex"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e "s:\(^CC.*=\).*:\1 $(tc-getCC):" \
+ -e "s:\(^STRIP.*=\).*:\1 true:" \
+ -e "s:\(^CFLAGS[[:space:]]*\)=:\1+=:" \
+ -e "/LIB_INSTALL_DIR/{s:/lib/purple-2:/$(get_libdir)/pidgin:;}" \
+ -i Makefile || die
+ # set default renderer to mathtex
+ sed -e "/purple_prefs_add_string.*PREFS_RENDERER/{s:mimetex:mathtex:;}" \
+ -i pidginTeX.c || die
+}
+
+src_compile() {
+ emake PREFIX=/usr || die
+}
+
+src_install() {
+ make PREFIX="${D}/usr" install || die "make install failed"
+ dodoc CHANGELOG README TODO || die
+}