summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-07-24 12:21:41 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-07-24 12:21:41 +0000
commit520d038488a6b4ff6eb2cae15e552854527c7c71 (patch)
tree44b855663b90c09eb1836e1d615a9a64a6ca4266
parentremoving old versions (diff)
downloadgentoo-2-520d038488a6b4ff6eb2cae15e552854527c7c71.tar.gz
gentoo-2-520d038488a6b4ff6eb2cae15e552854527c7c71.tar.bz2
gentoo-2-520d038488a6b4ff6eb2cae15e552854527c7c71.zip
remove old version
(Portage version: 2.1.2.7)
-rw-r--r--dev-cpp/Ice/ChangeLog7
-rw-r--r--dev-cpp/Ice/Ice-3.1.1.ebuild64
-rw-r--r--dev-cpp/Ice/files/Ice-3.1.1-Makefile.patch68
-rw-r--r--dev-cpp/Ice/files/digest-Ice-3.1.13
-rw-r--r--dev-cpp/Ice/files/ice-makefile-speedup.patch17
5 files changed, 6 insertions, 153 deletions
diff --git a/dev-cpp/Ice/ChangeLog b/dev-cpp/Ice/ChangeLog
index 8a01e856664b..bc4924c2461a 100644
--- a/dev-cpp/Ice/ChangeLog
+++ b/dev-cpp/Ice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/Ice
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/ChangeLog,v 1.7 2007/07/15 09:39:49 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/ChangeLog,v 1.8 2007/07/24 12:21:41 caleb Exp $
+
+ 24 Jul 2007; Caleb Tennis <caleb@gentoo.org>
+ -files/Ice-3.1.1-Makefile.patch, -files/ice-makefile-speedup.patch,
+ -Ice-3.1.1.ebuild:
+ remove old version
15 Jul 2007; Tiziano Müller <dev-zero@gentoo.org> metadata.xml:
cpp-herd taking over
diff --git a/dev-cpp/Ice/Ice-3.1.1.ebuild b/dev-cpp/Ice/Ice-3.1.1.ebuild
deleted file mode 100644
index 773b29fd44bb..000000000000
--- a/dev-cpp/Ice/Ice-3.1.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/Ice-3.1.1.ebuild,v 1.2 2007/02/03 03:14:53 beandog Exp $
-
-inherit eutils
-
-DESCRIPTION="ICE middleware C++ bindings"
-HOMEPAGE="http://www.zeroc.com/index.html"
-SRC_URI="http://www.zeroc.com/download/Ice/3.1/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ncurses test debug"
-
-DEPEND="ncurses? ( sys-libs/ncurses sys-libs/readline )
- test? ( >=dev-lang/python-2.2 )
- ~sys-libs/db-4.3.29
- >=dev-libs/openssl-0.9.7"
-RDEPEND=">=dev-libs/expat-1.9
- >=app-arch/bzip2-1.0"
-
-pkg_setup() {
- if built_with_use sys-libs/db nocxx; then
- eerror "sys-libs/db must be compiled with C++ support!"
- eerror "Remove the 'nocxx' use flag and try again."
- die "Fix use flags and re-emerge"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-Makefile.patch
- epatch "${FILESDIR}"/ice-makefile-speedup.patch
-
- if use amd64; then
- sed -i -e "s:^#LP64:LP64:g" ${S}/config/Make.rules \
- || die "Failed to set lib64 directory"
- fi
-
- if ! use ncurses; then
- sed -i -e "s# USE_READLINE.*# USE_READLINE := no#g" \
- ${S}/config/Make.rules || die "Failed to set no readline"
- fi
-
- if ! use debug; then
- sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
- ${S}/config/Make.rules || die "Failed to remove debug"
- fi
-
- sed -i -e \
- "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
- ${S}/config/Make.rules.Linux || die "CXXFLAGS patching failed!"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "Install Failed!"
-}
-
-src_test() {
- make test || die "Test failed"
-}
diff --git a/dev-cpp/Ice/files/Ice-3.1.1-Makefile.patch b/dev-cpp/Ice/files/Ice-3.1.1-Makefile.patch
deleted file mode 100644
index 689c28abdb6a..000000000000
--- a/dev-cpp/Ice/files/Ice-3.1.1-Makefile.patch
+++ /dev/null
@@ -1,68 +0,0 @@
---- Makefile.orig 2006-01-25 16:25:45.000000000 -0500
-+++ Makefile 2006-01-25 16:28:04.000000000 -0500
-@@ -19,7 +19,7 @@
- @if test ! -d $(prefix) ; \
- then \
- echo "Creating $(prefix)..." ; \
-- $(call mkdir,$(prefix)) ; \
-+ mkdir -p $(prefix) ; \
- fi
-
- @for subdir in $(INSTALL_SUBDIRS); \
-@@ -47,8 +47,8 @@
- then \
- ( cd doc && $(MAKE) install ) || exit 1 ; \
- fi
-- $(call installdata,ICE_LICENSE,$(prefix))
-- $(call installdata,LICENSE,$(prefix))
-+ $(call installdata,ICE_LICENSE,$(install_docdir))
-+ $(call installdata,LICENSE,$(install_docdir))
-
- clean::
- @if test -d doc ; \
---- config/Make.rules.old 2006-10-16 09:05:48.000000000 -0400
-+++ config/Make.rules 2006-10-16 09:07:30.000000000 -0400
-@@ -11,7 +11,7 @@
- # Select an installation base directory. The directory will be created
- # if it does not exist.
- #
--prefix ?= /opt/Ice-$(VERSION)
-+prefix ?= $(DESTDIR)/usr
-
- #
- # The "root directory" for runpath embedded in executables. Can be unset
-@@ -125,9 +125,9 @@
- install_bindir = $(prefix)/bin
-
- install_includedir = $(prefix)/include
--install_slicedir = $(prefix)/slice
--install_schemadir = $(prefix)/schema
--install_docdir = $(prefix)/doc
-+install_slicedir = $(prefix)/share/ice-$(VERSION)/slice
-+install_schemadir = $(prefix)/share/ice-$(VERSION)/schema
-+install_docdir = $(prefix)/share/doc/ice-$(VERSION)
-
- INSTALL = cp -fp
- INSTALL_PROGRAM = ${INSTALL}
-@@ -179,8 +179,8 @@
- BZIP2_LIBS = $(if $(BZIP2_HOME),-L$(BZIP2_HOME)/$(libsubdir)) -lbz2
- BZIP2_RPATH_LINK = $(if $(BZIP2_HOME),$(call rpathlink,$(BZIP2_HOME)/$(libsubdir)))
-
--DB_FLAGS = $(if $(DB_HOME),-I$(DB_HOME)/include)
--DB_LIBS = $(if $(DB_HOME),-L$(DB_HOME)/$(libsubdir)) -ldb_cxx
-+DB_FLAGS = -I/usr/include/db4.3
-+DB_LIBS = -ldb_cxx-4.3
- DB_RPATH_LINK = $(if $(DB_HOME),$(call rpathlink,$(DB_HOME)/$(libsubdir)))
-
- EXPAT_FLAGS = $(if $(EXPAT_HOME),-I$(EXPAT_HOME)/include)
---- config/Make.rules.orig 2006-10-16 09:23:27.000000000 -0400
-+++ config/Make.rules 2006-10-16 09:23:34.000000000 -0400
-@@ -17,7 +17,7 @@
- # The "root directory" for runpath embedded in executables. Can be unset
- # to avoid adding a runpath to Ice executables.
- #
--embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-+#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-
- #
- # Define OPTIMIZE as yes if you want to build with
diff --git a/dev-cpp/Ice/files/digest-Ice-3.1.1 b/dev-cpp/Ice/files/digest-Ice-3.1.1
deleted file mode 100644
index 7f0a44a55a18..000000000000
--- a/dev-cpp/Ice/files/digest-Ice-3.1.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 2bb84e1e8cf1cf67370467d6aee6659d Ice-3.1.1.tar.gz 2183969
-RMD160 737f453d8d3b44fecbbee10f13d84658675c8e91 Ice-3.1.1.tar.gz 2183969
-SHA256 b20286bbdb4100d5120e27b6bf3d8babab39a75b1b4bf4c8e743ed6789df0a80 Ice-3.1.1.tar.gz 2183969
diff --git a/dev-cpp/Ice/files/ice-makefile-speedup.patch b/dev-cpp/Ice/files/ice-makefile-speedup.patch
deleted file mode 100644
index 6c00214968a8..000000000000
--- a/dev-cpp/Ice/files/ice-makefile-speedup.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- Makefile.orig 2006-08-03 08:11:09.000000000 -0400
-+++ Makefile 2006-08-03 08:12:06.000000000 -0400
-@@ -11,7 +11,7 @@
-
- include $(top_srcdir)/config/Make.rules
-
--SUBDIRS = config src include test demo slice
-+SUBDIRS = config src include slice
-
- INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_slicedir) $(install_docdir)
-
-@@ -57,4 +57,5 @@
- fi
-
- test::
-+ @( cd test && $(MAKE) ) || exit 1
- @python $(top_srcdir)/allTests.py