summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2013-01-08 11:37:08 +0000
committerEray Aslan <eras@gentoo.org>2013-01-08 11:37:08 +0000
commit51f5beb3be728eb3c593252745b268e81d041e89 (patch)
treebd6c7665c44cc08effbc95dba0f9e2f89b464fbf
parentBackport patch from upstream to fix build with libav-9, wrt bug #443260. (diff)
downloadgentoo-2-51f5beb3be728eb3c593252745b268e81d041e89.tar.gz
gentoo-2-51f5beb3be728eb3c593252745b268e81d041e89.tar.bz2
gentoo-2-51f5beb3be728eb3c593252745b268e81d041e89.zip
Documentation and init script update
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 0x77F1F175586A3B1F)
-rw-r--r--mail-mta/nullmailer/ChangeLog10
-rw-r--r--mail-mta/nullmailer/files/init.d-nullmailer-r257
-rw-r--r--mail-mta/nullmailer/files/remotes.sample-1.1129
-rw-r--r--mail-mta/nullmailer/nullmailer-1.11-r1.ebuild124
4 files changed, 218 insertions, 2 deletions
diff --git a/mail-mta/nullmailer/ChangeLog b/mail-mta/nullmailer/ChangeLog
index a0cd0ceaadfc..d424d872f0bc 100644
--- a/mail-mta/nullmailer/ChangeLog
+++ b/mail-mta/nullmailer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-mta/nullmailer
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/ChangeLog,v 1.59 2012/12/06 11:27:28 eras Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/ChangeLog,v 1.60 2013/01/08 11:37:08 eras Exp $
+
+*nullmailer-1.11-r1 (08 Jan 2013)
+
+ 08 Jan 2013; Eray Aslan <eras@gentoo.org> +files/init.d-nullmailer-r2,
+ +files/remotes.sample-1.11, +nullmailer-1.11-r1.ebuild:
+ Documentation and init script update
06 Dec 2012; Eray Aslan <eras@gentoo.org> -files/init.d-nullmailer,
-files/nullmailer-1.10-fix-sendmail.patch, -nullmailer-1.05.ebuild,
diff --git a/mail-mta/nullmailer/files/init.d-nullmailer-r2 b/mail-mta/nullmailer/files/init.d-nullmailer-r2
new file mode 100644
index 000000000000..ccf53b374d06
--- /dev/null
+++ b/mail-mta/nullmailer/files/init.d-nullmailer-r2
@@ -0,0 +1,57 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/files/init.d-nullmailer-r2,v 1.1 2013/01/08 11:37:07 eras Exp $
+
+DAEMON="/usr/sbin/nullmailer-send"
+ARGS="--daemon"
+USER=nullmail
+GROUP=nullmail
+
+depend() {
+ use net logger
+ provide mta
+}
+
+checkconfig() {
+ local error=0
+ local f=/etc/nullmailer/me
+ if [ ! -s ${f} ]; then
+ eerror "${f} does not exist"
+ error=1
+ fi
+ f=/etc/nullmailer/defaultdomain
+ if [ ! -s ${f} ]; then
+ eerror "${f} does not exist"
+ error=1
+ fi
+ if [ ${error} -eq 1 ]; then
+ einfo "You need to run 'emerge --config nullmailer'!"
+ fi
+ if [ -e /service/nullmailer ]; then
+ eerror "Nullmailer is already running under svscan!"
+ error=2
+ fi
+ if [ ${error} -ne 0 ]; then
+ return 1
+ else
+ return 0
+ fi
+}
+
+start() {
+ checkconfig
+ ebegin "Starting nullmailer"
+ cd /var/nullmailer
+ start-stop-daemon --start --quiet --user ${USER}:${GROUP} \
+ --exec ${DAEMON} -- ${ARGS}
+ eend $?
+}
+
+stop() {
+ checkconfig # to avoid init.d stopping svscan instance
+ ebegin "Stopping nullmailer"
+ cd /var/nullmailer
+ start-stop-daemon --stop --user ${USER} --exec ${DAEMON}
+ eend $?
+}
diff --git a/mail-mta/nullmailer/files/remotes.sample-1.11 b/mail-mta/nullmailer/files/remotes.sample-1.11
new file mode 100644
index 000000000000..4e692258691e
--- /dev/null
+++ b/mail-mta/nullmailer/files/remotes.sample-1.11
@@ -0,0 +1,29 @@
+# Format is: HOST PROTOCOL [OPTIONS]
+# HOST = IP or DNS
+# PROTOCOL = smtp | qmtp
+# OPTIONS = [--port=NUMBER] [--auth=user,pass] [--starttls | --ssl [--insecure] ]
+#
+# Examples:
+# A standard SMTP server:
+# somesendmailserver.domain.com smtp
+#
+# A qmail server with QMQP setup:
+# someqmailserver.domain.com qmqp
+#
+# A nonstandard SMTP server setup:
+# someotherserver.domain.com smtp --port=2525
+#
+# SMTP server supporting AUTH PLAIN
+# mailserver smtp --user=<user> --pass=<pass>
+#
+# SMTP server supporting AUTH LOGIN
+# mailserver smtp --user=<user> --pass=<pass> --auth-login
+#
+# SMTP server with smtps (legacy - use starttls instead)
+# mailserver smtp --user=<user> --pass=<pass> --port=465 --ssl
+#
+# SMTP server on submission port with starttls
+# mailserver smtp --user=<user> --pass=<pass> --port=587 --starttls
+#
+# SMTP server on submission port with starttls and self-signed certificate
+# mailserver smtp --user=<user> --pass=<pass> --port=587 --starttls --insecure
diff --git a/mail-mta/nullmailer/nullmailer-1.11-r1.ebuild b/mail-mta/nullmailer/nullmailer-1.11-r1.ebuild
new file mode 100644
index 000000000000..274126531489
--- /dev/null
+++ b/mail-mta/nullmailer/nullmailer-1.11-r1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/nullmailer-1.11-r1.ebuild,v 1.1 2013/01/08 11:37:07 eras Exp $
+
+EAPI=4
+WANT_AUTOMAKE="1.10.3"
+inherit eutils flag-o-matic autotools user multilib
+
+MY_P="${P/_rc/RC}"
+S=${WORKDIR}/${MY_P}
+DEBIAN_PV=1.11
+DEBIAN_PR="1"
+DEBIAN_P="${PN}-${DEBIAN_PV}"
+DEBIAN_PF="${DEBIAN_P/-/_}-${DEBIAN_PR}"
+DEBIAN_SRC="${DEBIAN_PF}.debian.tar.gz"
+DESCRIPTION="Simple relay-only local mail transport agent"
+SRC_URI="http://untroubled.org/${PN}/archive/${MY_P}.tar.gz
+ mirror://debian/pool/main/n/${PN}/${DEBIAN_SRC}"
+HOMEPAGE="http://untroubled.org/nullmailer/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="ssl"
+
+DEPEND="sys-apps/groff
+ ssl? ( net-libs/gnutls )"
+RDEPEND="virtual/shadow
+ virtual/logger
+ ssl? ( net-libs/gnutls )
+ !mail-mta/courier
+ !mail-mta/esmtp
+ !mail-mta/exim
+ !mail-mta/mini-qmail
+ !mail-mta/msmtp
+ !mail-mta/netqmail
+ !mail-mta/postfix
+ !mail-mta/qmail-ldap
+ !mail-mta/sendmail
+ !mail-mta/ssmtp"
+
+src_prepare() {
+ sed -i -e 's/nullmailer-1.10/nullmailer-1.11/g' \
+ "${WORKDIR}"/debian/patches/*.diff || die
+ EPATCH_OPTS="-d ${S} -p1" \
+ epatch "${DISTDIR}"/${DEBIAN_SRC}
+ # why revert? Ask Robin when he is back!
+ EPATCH_OPTS="-d ${WORKDIR} -p0 -R" \
+ epatch "${WORKDIR}"/debian/patches/02_ipv6.diff
+ # this fixes the debian daemon/syslog to actually compile
+ sed -i.orig \
+ -e '/^nullmailer_send_LDADD/s, =, = ../lib/cli++/libcli++.a,' \
+ "${S}"/src/Makefile.am || die "Sed failed"
+ eautoreconf
+}
+
+pkg_setup() {
+ enewgroup nullmail 88
+ enewuser nullmail 88 -1 /var/nullmailer nullmail
+}
+
+src_configure() {
+ # Note that we pass a different directory below due to bugs in the makefile!
+ econf \
+ --localstatedir=/var \
+ $(use_enable ssl tls)
+}
+
+src_install () {
+ einstall localstatedir="${D}"/var/nullmailer
+ dodoc AUTHORS BUGS HOWTO INSTALL ChangeLog NEWS README TODO
+ # A small bit of sample config
+ insinto /etc/nullmailer
+ newins "${FILESDIR}"/remotes.sample-1.11 remotes
+ # daemontools stuff
+ dodir /var/nullmailer/service{,/log}
+ insinto /var/nullmailer/service
+ newins scripts/nullmailer.run run
+ fperms 700 /var/nullmailer/service/run
+ insinto /var/nullmailer/service/log
+ newins scripts/nullmailer-log.run run
+ fperms 700 /var/nullmailer/service/log/run
+ # usability
+ dodir /usr/$(get_libdir)
+ dosym /usr/sbin/sendmail usr/$(get_libdir)/sendmail
+ # permissions stuff
+ keepdir /var/log/nullmailer /var/nullmailer/{tmp,queue}
+ fperms 770 /var/log/nullmailer /var/nullmailer/{tmp,queue}
+ fowners nullmail:nullmail /usr/sbin/nullmailer-queue /usr/bin/mailq
+ fperms 4711 /usr/sbin/nullmailer-queue /usr/bin/mailq
+ fowners nullmail:nullmail /var/log/nullmailer /var/nullmailer/{tmp,queue,trigger}
+ fperms 660 /var/nullmailer/trigger
+ newinitd "${FILESDIR}"/init.d-nullmailer-r2 nullmailer
+}
+
+pkg_postinst() {
+ [ ! -e "${ROOT}"/var/nullmailer/trigger ] && mkfifo "${ROOT}"/var/nullmailer/trigger
+ chown nullmail:nullmail "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue,trigger}
+ chmod 770 "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue}
+ chmod 660 "${ROOT}"/var/nullmailer/trigger
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To create an initial setup, please do:"
+ elog "emerge --config =${CATEGORY}/${PF}"
+ fi
+ #echo
+ #elog "To start nullmailer at boot you may use either the nullmailer init.d"
+ #elog "script, or emerge sys-process/supervise-scripts, enable the"
+ #elog "svscan init.d script and create the following link:"
+ #elog "ln -fs /var/nullmailer/service /service/nullmailer"
+ #echo
+}
+
+pkg_config() {
+ if [ ! -s "${ROOT}"/etc/nullmailer/me ]; then
+ einfo "Setting /etc/nullmailer/me"
+ /bin/hostname --fqdn > "${ROOT}"/etc/nullmailer/me
+ fi
+ if [ ! -s "${ROOT}"/etc/nullmailer/defaultdomain ]; then
+ einfo "Setting /etc/nullmailer/defaultdomain"
+ /bin/hostname --domain > "${ROOT}"/etc/nullmailer/defaultdomain
+ fi
+}